View Issue Details

IDProjectCategoryView StatusLast Update
14335Bug reports[All Projects] Print Viewpublic2019-04-30 09:11
ReporterMaziAssigned ToLouisGac 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.15.x 
Target Version3.16.xFixed in Version 
Summary14335: Print answers overview shows {TOKEN:FIRSTNAME} instead of properly replacing it
Description

We are using a boilerplate question at the beginning of the survey at which we are showing first name and last name taken from the token details. At survey runtime the placehodlers get relaced properly but when using the "print answers" feature the overview shows "Vorname: {TOKEN:FIRSTNAME} Nachname: {TOKEN:LASTNAME}" instead of replacing these.

Steps To Reproduce
  1. At a non-anonymous survey with tokens create a dummy token with first name and last name. enabl the print answers feature
  2. Add a single question of type "boilerplate" and add this as question text:
    "first name: {TOKEN:FIRSTNAME}
    last name: {TOKEN:LASTNAME}"
  3. Activate and run the survey. Click the "Print answers" link at the end of the survey.
  4. The print screen shows the raw placeholders
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.8+180829
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 14 TLS
Webserver software & version (if known)Apache 2
PHP Version7.0.26

Activities

Mazi

Mazi

2018-12-11 12:14

partner  

Mazi

Mazi

2019-01-31 10:15

partner   ~50351

@dominikvitt, can this be fixed for the next release?

Mazi

Mazi

2019-03-11 16:18

partner   ~50906

This seems to be fixed, just tested with version 3.15.9+190214.

Issue History

Date Modified Username Field Change
2018-12-11 12:14 Mazi New Issue
2018-12-11 12:14 Mazi Status new => assigned
2018-12-11 12:14 Mazi Assigned To => dominikvitt
2018-12-11 12:14 Mazi File Added: print_screen_with_placeholders.png
2019-01-31 10:15 Mazi Note Added: 50351
2019-02-05 15:23 ollehar Assigned To dominikvitt => LouisGac
2019-03-11 16:18 Mazi Status assigned => resolved
2019-03-11 16:18 Mazi Resolution open => fixed
2019-03-11 16:18 Mazi Note Added: 50906
2019-04-30 09:11 c_schmitz Status resolved => closed