View Issue Details

IDProjectCategoryView StatusLast Update
14324Bug reports[All Projects] Statisticspublic2018-12-18 08:53
ReporterbabielAssigned ToDenisChenu 
PrioritynoneSeverityblock 
Status closedResolutionno change required 
Product Version3.15.x 
Target VersionFixed in Version 
Summary14324: Statistics export to excel gives 500 ERROR back instead of file
Description

Hi,
we would like to export our statistics in an excel file but it throws a 500 ERROR.

Steps To Reproduce

Click in the survey settings on the left side on "Statistics". Then click on "output format" and click on "Excel". Now click in the right corner "show statistics" and LimeSurvey sends an 500 ERROR back the browser.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.5 (181115)
I will donate to the project if issue is resolvedNo
BrowserChromium, Firefox
Database & DB-Versionmysql Ver 14.14 Distrib 5.5.62
Server OS (if known)Debian 8.11
Webserver software & version (if known)Apache/2.4.10
PHP VersionPHP 5.6.38-0+deb8u1

Activities

DenisChenu

DenisChenu

2018-12-06 19:35

developer   ~49897

Please : http://manual.limesurvey.org/Debug_mode

A,d send the HTML resulted here (save as html is better )

babiel

babiel

2018-12-07 10:41

reporter   ~49903

Added the debug result.



BMZINTR-820_LimeSurvey_Debug.html (144,367 bytes)
babiel

babiel

2018-12-07 10:57

reporter   ~49904

It seems that "save as html" not saving the displayed page. So here is a screenshot from the displayed errors.



debug_screenshot.png (586,279 bytes)
DenisChenu

DenisChenu

2018-12-10 18:16

developer   ~49915

Issue on server :

  1. We have our own Spreadsheet_Writer , then no need this included.
  2. You have /usr/share/php in your include_path
  3. But you disallow it in your open_base_dir.

Best is to set include_path to .

babiel

babiel

2018-12-14 11:38

reporter   ~49966

The file "/usr/share/php/Spreadsheet_Excel_Writer_Workbook.php" doesn't exist.
So we installed the Excel_Writer_Workbook pear package.

We also have set include_path to . already and still have the same error.

babiel

babiel

2018-12-18 08:38

reporter   ~49981

Reopening the ticket. See the last comment.

DenisChenu

DenisChenu

2018-12-18 08:45

developer   ~49982

You don't have to install Excel_Writer_Workbook package … LimeSurvey don't need it.

Send your phpinfo

You can have include_path to . only with LimeSurvey . It's your server issue … you allow to read /usr/share/php/ but you disable the right to read it with open base dir restriction.

NOT RELATED TO LIMESURVEY !

DenisChenu

DenisChenu

2018-12-18 08:53

developer   ~49983

Because i'm kind, put this at top of top of yourconfig.php file,

set_include_path(".");

Just before return array(

Issue History

Date Modified Username Field Change
2018-12-06 12:12 babiel New Issue
2018-12-06 19:35 DenisChenu Note Added: 49897
2018-12-07 10:41 babiel File Added: BMZINTR-820_LimeSurvey_Debug.html
2018-12-07 10:41 babiel Note Added: 49903
2018-12-07 10:57 babiel File Added: debug_screenshot.png
2018-12-07 10:57 babiel Note Added: 49904
2018-12-10 18:16 DenisChenu Assigned To => DenisChenu
2018-12-10 18:16 DenisChenu Status new => closed
2018-12-10 18:16 DenisChenu Resolution open => no change required
2018-12-10 18:16 DenisChenu Note Added: 49915
2018-12-14 11:38 babiel Note Added: 49966
2018-12-18 08:38 babiel Status closed => feedback
2018-12-18 08:38 babiel Resolution no change required => reopened
2018-12-18 08:38 babiel Note Added: 49981
2018-12-18 08:45 DenisChenu Note Added: 49982
2018-12-18 08:45 DenisChenu Status feedback => closed
2018-12-18 08:46 DenisChenu Reproducibility have not tried => N/A
2018-12-18 08:46 DenisChenu Resolution reopened => no change required
2018-12-18 08:53 DenisChenu Status closed => feedback
2018-12-18 08:53 DenisChenu Resolution no change required => reopened
2018-12-18 08:53 DenisChenu Note Added: 49983
2018-12-18 08:53 DenisChenu Status feedback => closed
2018-12-18 08:53 DenisChenu Severity crash => block
2018-12-18 08:53 DenisChenu Resolution reopened => no change required