View Issue Details

IDProjectCategoryView StatusLast Update
14278Bug reports[All Projects] Survey takingpublic2019-04-30 09:12
ReporterMazi Assigned Todominikvitt  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.15.x 
Target Version3.16.xFixed in Version3.15.x 
Summary14278: When resuming a survey there is a wrong warning about disabled JavaScript and a checkbox for "Please confirm you want..." shows
Description

Using the "Save and resume later" feature there are two weird things showing up when loading the survey, see attached screenshot.

  1. a Warning about disabled JS (which IS enabled).
  2. a checkbox + text "Please confirm you want to clear your answers" below the "Resume later" button bottom right.

Tested at demo.limesurvey.org using the default template.

Steps To Reproduce
  1. Import the attached survey.
  2. Use "Save and resume later".
    3, Check screen when being returned to the survey
Additional Information

You may want to check https://bugs.limesurvey.org/view.php?id=14277 as well since this also deadls with the "Save and resume" feature.

Please fix this at code level if possible, not template level.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.5 (demo.limesurvey.org)
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 14 TLS
Webserver software & version (if known)Apache 2
PHP Version7.0.26

Relationships

related to 14277 closeddominikvitt When using an existing user name at the "Save and resume later" feature, there is also a wrong warning about a wrong captcha 

Activities

Mazi

Mazi

2018-11-23 09:32

partner  

limesurvey_survey_113317.lss (19,089 bytes)
save_and_resume_error.png (64,472 bytes)
save_and_resume_error.png (64,472 bytes)
guest

guest

2018-11-23 14:57

viewer   ~49765

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28555

Mazi

Mazi

2018-11-23 15:06

partner   ~49767

Are you sure that this fixes both, the wrong warning and the checkbox shown?

dominikvitt

dominikvitt

2018-11-23 15:08

developer   ~49768

Yes, it fixes both, warning and checkbox were shown because JavaScript was broken.

Mazi

Mazi

2018-11-23 15:10

partner   ~49769

Makes sense!

c_schmitz

c_schmitz

2019-04-30 09:12

administrator   ~51649

Fixed in Version 3.1.7.3

Related Changesets

LimeSurvey: master b8882f93

2018-11-23 14:56:04

Dominik Vitt

Details Diff
Fixed issue 14278: When resuming a survey there is a wrong warning about disabled JavaScript and a checkbox for "Please confirm you want..." shows Affected Issues
14278
mod - assets/packages/template-core/template-core.js Diff File

Issue History

Date Modified Username Field Change
2018-11-23 09:32 Mazi New Issue
2018-11-23 09:32 Mazi File Added: limesurvey_survey_113317.lss
2018-11-23 09:32 Mazi File Added: save_and_resume_error.png
2018-11-23 09:32 Mazi Relationship added related to 14277
2018-11-23 14:57 Changeset attached => LimeSurvey master b8882f93
2018-11-23 14:57 guest Note Added: 49765
2018-11-23 14:57 guest Resolution open => fixed
2018-11-23 14:58 dominikvitt Assigned To => dominikvitt
2018-11-23 14:58 dominikvitt Status new => resolved
2018-11-23 14:58 dominikvitt Fixed in Version => 3.15.x
2018-11-23 15:06 Mazi Note Added: 49767
2018-11-23 15:08 dominikvitt Note Added: 49768
2018-11-23 15:10 Mazi Note Added: 49769
2019-04-30 09:12 c_schmitz Note Added: 51649
2019-04-30 09:12 c_schmitz Status resolved => closed