View Issue Details

IDProjectCategoryView StatusLast Update
14276Bug reports[All Projects] Expression Managerpublic2019-04-30 09:12
ReporterMazi Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.15.x 
Target Version3.16.xFixed in Version3.15.x 
Summary14276: Validation for multiple numeric input is missing details about "equals sum value"
Description

If you set a "maximum sum" value and another "equals sum" value at a multi numeric question, then the information about the equal sum value is missing which makes it impossible for the user to determine why his input is wrong. At survey runtime there is a hint that the sum may not exceed value X but there are no details listed that the sum has to be equal to value Y.

Steps To Reproduce
  1. Import the attached survey.
  2. According to the validation show, input 1, 1, 1 is valid, see attached screenshot. But the note "The sum must be between 1 and 100" is still red.
  3. A valid input is actually 1, 2, 2 because the "equals sum value" at the sample question is 5 but there are no hints shown regarding that limit.
Additional Information

Test survey is also (temporarily) available at https://demo.limesurvey.org/index.php?r=survey/index&sid=113317&newtest=Y&lang=en

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.5 (demo.limesurvey.org)
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 14 TLS
Webserver software & version (if known)Apache 2
PHP Version7.0.26

Activities

Mazi

Mazi

2018-11-23 09:05

partner  

invalid_inout.png (27,897 bytes)
invalid_inout.png (27,897 bytes)
limesurvey_survey_113317.lss (19,089 bytes)
settings.png (33,508 bytes)
settings.png (33,508 bytes)
valid_input.png (22,016 bytes)
valid_input.png (22,016 bytes)
DenisChenu

DenisChenu

2018-11-23 10:19

developer   ~49757

Last edited: 2018-11-23 10:20

View 2 revisions

Removing max sum value and min sum value fix the issue.

In my opinion : we don't need equals_sum_value, since it can be done with max_sum_value == min_sum_value

What to do with min_sum_value = 10 and equals_sum_value = 5 : what condition must be respected ? Seems choice are done to respect min/max and not equals

(there are no good solution …)

DenisChenu

DenisChenu

2018-11-23 10:39

developer   ~49758

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28554

Mazi

Mazi

2018-11-23 11:10

partner   ~49759

Thanks for fixing, Denis!

c_schmitz

c_schmitz

2019-04-30 09:12

administrator   ~51651

Fixed in Version 3.1.7.3

Related Changesets

LimeSurvey: master 789c1d38

2018-11-23 10:39:33

DenisChenu

Details Diff
Fixed issue 14276: Validation for multiple numeric input is missing details about "equals sum value"
Dev: this don't fix User error …
Dev: using (min|max)_sum_value with equals_num_value is silly
Dev: currently js for equals happen after (min|max) then totalvalue class respect equals
Affected Issues
14276
mod - application/helpers/expressions/em_manager_helper.php Diff File

Issue History

Date Modified Username Field Change
2018-11-23 09:05 Mazi New Issue
2018-11-23 09:05 Mazi File Added: invalid_inout.png
2018-11-23 09:05 Mazi File Added: limesurvey_survey_113317.lss
2018-11-23 09:05 Mazi File Added: settings.png
2018-11-23 09:05 Mazi File Added: valid_input.png
2018-11-23 10:19 DenisChenu Note Added: 49757
2018-11-23 10:20 DenisChenu Note Edited: 49757 View Revisions
2018-11-23 10:30 DenisChenu Assigned To => DenisChenu
2018-11-23 10:30 DenisChenu Status new => assigned
2018-11-23 10:39 DenisChenu Changeset attached => LimeSurvey master 789c1d38
2018-11-23 10:39 DenisChenu Note Added: 49758
2018-11-23 10:39 DenisChenu Resolution open => fixed
2018-11-23 10:39 DenisChenu Status assigned => resolved
2018-11-23 10:39 DenisChenu Fixed in Version => 3.15.x
2018-11-23 11:10 Mazi Note Added: 49759
2019-04-30 09:12 c_schmitz Note Added: 51651
2019-04-30 09:12 c_schmitz Status resolved => closed