View Issue Details

IDProjectCategoryView StatusLast Update
14270Bug reports[All Projects] Assessmentspublic2019-04-30 09:12
ReporterDenisChenuAssigned ToDenisChenu 
PriorityhighSeveritymajor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14270: value, valueNAOK etc … broken with GET params
Description

value, valueNAOK return always 0 with urlParam to GET OR any valid get params

Steps To Reproduce

Import included survey, look at survey logic,

  1. test the survey with urlparam to path
  2. test the survey with ?newtest=Y&WithValue=A2

=> prefillFromCommandLine happen BEFORE StartSurvey …

Additional Information

{ASSESSMENT_CURRENT_TOTAL seems broken with PHP5.6 too … (show Unkown on a 5.6) I report it at another issue

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.5 github
I will donate to the project if issue is resolvedNo
Browserfirefox
Database & DB-Versionmysql
Server OS (if known)fedora/linux
Webserver software & version (if known)nginx
PHP Version7.2.12

Relationships

has duplicate 14267 closedDenisChenu Bad evaluation of hidden question with default value and relevance (PHP7.2) 

Activities

DenisChenu

DenisChenu

2018-11-22 12:18

developer  

survey_archive_valueBroken.lsa (3,561 bytes)
DenisChenu

DenisChenu

2018-11-22 12:48

developer   ~49723

Seems $this->surveyOptions is empty in getAnswerSetsForEM …

I already disable all my plugins … i test with a clean setup …

jelo

jelo

2018-11-22 12:54

partner   ~49724

value, valueNAOK returns value under PHP 7.1.
ASSESSMENT_CURRENT_TOTAL is broken (unrelated to PHP version).

Currently I can only recommend to put a PHP 7.1 limit on the installation requirements.
I wonder what the daily development and checking is done.
I will not use PHP 7.2. till LS4 is RC.
We will see many posts and reports about issues, when PHP 7.2 is widely applied.

jelo

jelo

2018-11-22 13:12

partner   ~49726

These PHP 7.2 patches have just began.
https://github.com/LimeSurvey/LimeSurvey/commit/3dda496781fa7411aa2468d9e74306a882d7bf1b#diff-c8167ae9b10e04df148cae0dedcd1224

I wonder why the Yii file was modified. Yii 1.1.20 is PHP 7.2 ready since July.
But LimeSurvey seems to stay on Yii 1.1.19.

DenisChenu

DenisChenu

2018-11-22 13:22

developer   ~49727

Last edited: 2018-11-22 13:30

View 2 revisions

My dev server is on PHP7.2 :) then all my plugin updated since 2 month or after work on php7.2 ;)

Tracking down getAnswerSetsForEM is called before StartSurvey …

DenisChenu

DenisChenu

2018-11-22 14:08

developer   ~49730

NOT related to PHP version, related to urlParam : with GET : prefillFromCommandLine happen BEFORE StartSurvey …

DenisChenu

DenisChenu

2018-11-22 14:18

developer   ~49731

Set priority and severity to major : It can happen a lot more, and do a survey without SurveyOption can really broke a lot of things …

DenisChenu

DenisChenu

2018-11-22 14:31

developer   ~49732

https://github.com/LimeSurvey/LimeSurvey/commit/bb2be1541ddffada017148bc259f1b5be5ce0756 related

jelo

jelo

2018-11-22 14:38

partner   ~49733

Setting the value via URL is not working in PHP 7.1 either.

In my first check, I overlooks the premise to set value via URL GET parameter. Sorry.
Thought the issue is when just answering a question inside the survey.

DenisChenu

DenisChenu

2018-11-22 14:49

developer   ~49734

https://github.com/LimeSurvey/LimeSurvey/pull/1176

DenisChenu

DenisChenu

2018-11-22 15:14

developer   ~49735

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28547

DenisChenu

DenisChenu

2018-11-22 15:22

developer   ~49736

@jelo : (before the fix) even set (&|?)toto=titi broke :)

c_schmitz

c_schmitz

2019-04-30 09:12

administrator   ~51646

Fixed in Version 3.1.7.3

Related Changesets

LimeSurvey: master 0c41165a

2018-11-22 15:14:00

DenisChenu

Details Diff
Fixed issue 14270: value, valueNAOK etc … broken with GET params
Dev: remove usage of LimeExpressionManager in prefillFromCommandLine function
Dev: since it can broke a lot EM : log potential error in setVariableAndTokenMappingsForExpressionManager
Affected Issues
14267, 14270
mod - application/helpers/expressions/em_manager_helper.php Diff File
mod - application/helpers/frontend_helper.php Diff File

Issue History

Date Modified Username Field Change
2018-11-22 12:18 DenisChenu New Issue
2018-11-22 12:18 DenisChenu File Added: survey_archive_valueBroken.lsa
2018-11-22 12:48 DenisChenu Note Added: 49723
2018-11-22 12:54 jelo Note Added: 49724
2018-11-22 13:12 jelo Note Added: 49726
2018-11-22 13:22 DenisChenu Note Added: 49727
2018-11-22 13:30 DenisChenu Note Edited: 49727 View Revisions
2018-11-22 14:08 DenisChenu Note Added: 49730
2018-11-22 14:13 DenisChenu Summary value, valueNAOK etc … broken with PHP7.2 => value, valueNAOK etc … broken with GET params
2018-11-22 14:13 DenisChenu Description Updated View Revisions
2018-11-22 14:13 DenisChenu Steps to Reproduce Updated View Revisions
2018-11-22 14:13 DenisChenu Additional Information Updated View Revisions
2018-11-22 14:18 DenisChenu Priority none => high
2018-11-22 14:18 DenisChenu Severity minor => major
2018-11-22 14:18 DenisChenu Note Added: 49731
2018-11-22 14:30 DenisChenu Assigned To => DenisChenu
2018-11-22 14:30 DenisChenu Status new => assigned
2018-11-22 14:31 DenisChenu Note Added: 49732
2018-11-22 14:38 jelo Note Added: 49733
2018-11-22 14:49 DenisChenu Note Added: 49734
2018-11-22 15:14 DenisChenu Changeset attached => LimeSurvey master 0c41165a
2018-11-22 15:14 DenisChenu Note Added: 49735
2018-11-22 15:14 DenisChenu Resolution open => fixed
2018-11-22 15:21 DenisChenu Status assigned => resolved
2018-11-22 15:21 DenisChenu Fixed in Version => 3.15.x
2018-11-22 15:22 DenisChenu Note Added: 49736
2018-11-27 19:11 DenisChenu Relationship added has duplicate 14267
2019-04-30 09:12 c_schmitz Note Added: 51646
2019-04-30 09:12 c_schmitz Status resolved => closed