View Issue Details

IDProjectCategoryView StatusLast Update
14223Bug reports[All Projects] Authenticationpublic2018-11-13 13:33
ReporterizzysteveAssigned To 
PrioritynoneSeverityminor 
Status newResolutionopen 
Product Version3.13.x 
Target VersionFixed in Version 
Summary14223: Admin Login
Description

First, can you please close 14220 as I reported issue incorrectly as a feature request. This ticket replaces that as a bug report.

I am having issues logging in to my admin area.

I use Google Chrome Version 70.0.3538.77 (Official Build) (64-bit)

My login page is https://illuceo.com/ls/index.php/admin/authentication/sa/login. I enter my credentials, it processes a couple of seconds, and re-displays blank login page - there is no error message.

I have also tried this in Firefox 63.0.1 (64-bit) and I get the same result.

Strangely, if I try IE v11.103.10586.0 I successfully log in, even though this browser is unsupported! At least, though, this proves there is nothing wrong with my credentials or access to database.

I have just applied Comfortupdate and am now on version 3.15.1 (181017), and still have the same issues - no good on Chrome or Firefox; success with IE.

Is there a known issue or can you advise how to find this problem? Without any sort of error showing, I do not know where to start.

Thanks,
Steve

Steps To Reproduce

Launch Chrome or Firerfox

Enter https://illuceo.com/ls/index.php/admin/authentication/sa/login as URL

Enter user name admin + password.

Hit submit.

After couple of seconds, login page re-displays, with user/password blank and no message as why login failed.

Additional Information

I have tried clearing cache in browsers, and even re-booted PC.

I also applied Comfortupdate that was available and this has not solved.

Tagsadmin, login
Complete LimeSurvey version number (& build)Version 3.15.1 (181017)
I will donate to the project if issue is resolvedNo
BrowserChrome and Firefox
Database & DB-Versionmysql 5.7.23
Operating System (Server)linux
Webserver software & versionapache 2.4.34
PHP Version5.6.37

Activities

DenisChenu

DenisChenu

2018-11-07 11:21

developer   ~49569

Strange : since we have the alert about «Incorrect username and/or password!» session seems OK;

Do you have plugin activated (except DBauth one)

izzysteve

izzysteve

2018-11-07 11:27

reporter   ~49570

I have attached screenshot of plugin manager. I haven't been to this page before so the settings must be from initial install?



Plugins.PNG (32,897 bytes)
Plugins.PNG (32,897 bytes)
DenisChenu

DenisChenu

2018-11-07 13:22

developer   ~49573

http://manual.limesurvey.org/Debug_mode

izzysteve

izzysteve

2018-11-07 14:13

reporter   ~49574

Enabled debug on code (2) and SQL (1). I don't get any error messages, but screenshot shows queries.



Debug.PNG (47,265 bytes)
Debug.PNG (47,265 bytes)
izzysteve

izzysteve

2018-11-07 14:19

reporter   ~49575

I pressed F12 on Chrome for developer window and tried to login and this time I got some debug info - see attached



csrf.png (75,106 bytes)
csrf.png (75,106 bytes)
DenisChenu

DenisChenu

2018-11-13 13:14

developer   ~49628

Can you reproduce CRSF issue always ? CRSF issue can come from test.

Else : maybe just rename the session name : https://manual.limesurvey.org/Optional_settings#Session_settings

izzysteve

izzysteve

2018-11-13 13:33

reporter   ~49629

Hi,

I received some advice that suhosin can causes issues with LS. My host has disabled it and I am waiting to see if this has made a difference. To date, no issues encountered, but it's only been a couple of days.

Will keep you posted.

Thanks,
Steve

Issue History

Date Modified Username Field Change
2018-11-07 08:56 izzysteve New Issue
2018-11-07 09:02 izzysteve Tag Attached: login
2018-11-07 09:02 izzysteve Tag Attached: admin
2018-11-07 11:21 DenisChenu Note Added: 49569
2018-11-07 11:27 izzysteve File Added: Plugins.PNG
2018-11-07 11:27 izzysteve Note Added: 49570
2018-11-07 13:22 DenisChenu Note Added: 49573
2018-11-07 14:13 izzysteve File Added: Debug.PNG
2018-11-07 14:13 izzysteve Note Added: 49574
2018-11-07 14:19 izzysteve File Added: csrf.png
2018-11-07 14:19 izzysteve Note Added: 49575
2018-11-13 13:14 DenisChenu Note Added: 49628
2018-11-13 13:33 izzysteve Note Added: 49629