View Issue Details

IDProjectCategoryView StatusLast Update
14217Bug reports[All Projects] Ergonomypublic2019-09-05 15:10
ReporterDenisChenu Assigned Tomarkusfluer  
PrioritynoneSeverityminor 
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.17.x 
Summary14217: Unpleasant rebound effect when editing questions
Description

When editing question : there are an unpleasant rebound effect when click on advanced settings.

Steps To Reproduce

See screencast

Additional Information

With little width windows : this make it really long to update advanced seeting. I know officially need a big screen, but it work with a lesser screen width. Here it's lots.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.1 github
I will donate to the project if issue is resolvedNo
Browserff
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2018-11-06 12:37

developer  

rebound.webm (1,295,687 bytes)
withlittlescreen.webm (903,865 bytes)
DenisChenu

DenisChenu

2018-11-06 12:38

developer   ~49552

on rebound : see particulary Logic (3rd clic) and statistics : go to top , without needing …

DenisChenu

DenisChenu

2018-11-15 14:21

developer   ~49667

@markusfluer i really think we must remove the go to top in javascript … even with a big window : you want to click a checkbox but … this checkbox moved …

markusfluer

markusfluer

2018-11-19 13:52

administrator   ~49697

I will remove it for next release

DenisChenu

DenisChenu

2018-11-19 13:59

developer   ~49698

https://github.com/LimeSurvey/LimeSurvey/pull/1172 ;)

There still a rebound when open a Group after an opened group but really less , and it's a BS issue too. The issue is more because we need (clikc) action on the Settings

markusfluer

markusfluer

2018-11-19 15:00

administrator   ~49699

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28534

DenisChenu

DenisChenu

2018-11-20 08:22

developer   ~49701

There still a little effect : if a big tab is opened before (Timing for example). Then, when move mouse : scroll under mouse … unsure on the way to fix and how to fix (and if it must be fixed)

Maybe move from shown.bs.collapse to show.bs.collapse ?

DenisChenu

DenisChenu

2018-11-20 08:32

developer   ~49702

Screncast with shown (current) and show (merge request)

I really think show is better

https://github.com/LimeSurvey/LimeSurvey/pull/1174/files



Screencast_show.webm (621,443 bytes)
Screencast_shown.webm (746,909 bytes)

Related Changesets

LimeSurvey: master 9f1db507

2018-11-19 14:59:53

DenisChenu


Committer: markusfluer Details Diff
Fixed issue 14217: Unpleasant rebound effect when editing questions (#1172)

Dev: still one rebound, but not a second one 500ms after …
Affected Issues
14217
mod - assets/packages/adminbasics/build/adminbasics.debug.js Diff File
mod - assets/packages/adminbasics/build/adminbasics.js Diff File
mod - assets/packages/adminbasics/build/adminbasics.min.js Diff File
mod - assets/packages/adminbasics/src/parts/globalMethods.js Diff File

Issue History

Date Modified Username Field Change
2018-11-06 12:37 DenisChenu New Issue
2018-11-06 12:37 DenisChenu Status new => assigned
2018-11-06 12:37 DenisChenu Assigned To => markusfluer
2018-11-06 12:37 DenisChenu File Added: rebound.webm
2018-11-06 12:37 DenisChenu File Added: withlittlescreen.webm
2018-11-06 12:38 DenisChenu Note Added: 49552
2018-11-15 14:21 DenisChenu Note Added: 49667
2018-11-19 13:52 markusfluer Note Added: 49697
2018-11-19 13:59 DenisChenu Note Added: 49698
2018-11-19 15:00 markusfluer Changeset attached => LimeSurvey master 9f1db507
2018-11-19 15:00 markusfluer Note Added: 49699
2018-11-19 15:00 markusfluer Resolution open => fixed
2018-11-20 08:22 DenisChenu Note Added: 49701
2018-11-20 08:32 DenisChenu File Added: Screencast_show.webm
2018-11-20 08:32 DenisChenu File Added: Screencast_shown.webm
2018-11-20 08:32 DenisChenu Note Added: 49702
2019-09-05 15:10 markusfluer Status assigned => resolved
2019-09-05 15:10 markusfluer Fixed in Version => 3.17.x