View Issue Details

IDProjectCategoryView StatusLast Update
14183Bug reportsExpression Managerpublic2018-10-25 15:23
ReporterAlbanCatry Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Fixed in Version4.0.0dev 
Summary14183: Using the result of an equation in further questions (text / relevance)
Description

Hello,

I am trying to use the result of an equation to change the tet of a further question, and to make another further question appear or not.
I have seen the example of the manual :

https://manual.limesurvey.org/Expression_Manager_how-tos#Calculate_assessment_values_at_runtime_and_store_the_results_in_the_survey_data

The variable in the equation seems to compute correctly, it is displayed at runtime.
AllAnswered = ( ! is_empty(MyArray_SQ1) and ! is_empty(MyArray_SQ2) and ! is_empty(MyArray_SQ3))

But the further questions are not updated...
I have tried many things :

  • It is not a NAOK problem, because all is visible (I have tried with NAOK anyway)
  • I have tried with the variable affectation {AllAnswered = <myequation>} or without {<myequation>)
  • I have tried using the direct boolean output of the equation, or convert it to int 0/1

I was told to fill a bug report from the forum :
https://www.limesurvey.org/forum/design-issues/116748-using-the-result-of-an-equation-in-further-questions-text-relevance

Thank you

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.15.1
I will donate to the project if issue is resolvedNo
BrowserFirefox 62.0.3 32 bits
Database & DB-Version355
Server OS (if known)Windows
Webserver software & version (if known)?
PHP Version?

Relationships

duplicate of 14047 closedDenisChenu Equation didn't update previous text 

Activities

AlbanCatry

AlbanCatry

2018-10-25 09:54

reporter  

DenisChenu

DenisChenu

2018-10-25 15:23

developer   ~49441

This is an old bug : equation updating didn't really trigger all related equation/expression in same page.

This is fixed in 4.0, to hard to fix it in 3.X.

Solution : copy/paste the equation to condition if it's in same page.

Issue History

Date Modified Username Field Change
2018-10-25 09:54 AlbanCatry New Issue
2018-10-25 09:54 AlbanCatry File Added: limesurvey_survey_948344_equation.lss
2018-10-25 15:21 DenisChenu Relationship added duplicate of 14047
2018-10-25 15:23 DenisChenu Assigned To => DenisChenu
2018-10-25 15:23 DenisChenu Status new => closed
2018-10-25 15:23 DenisChenu Resolution open => duplicate
2018-10-25 15:23 DenisChenu Fixed in Version => 4.0.0dev
2018-10-25 15:23 DenisChenu Note Added: 49441