View Issue Details

IDProjectCategoryView StatusLast Update
14109Bug reports[All Projects] Survey designpublic2018-10-11 09:15
ReporterizzysteveAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status assignedResolutionopen 
Product Version3.13.x 
Target VersionFixed in Version 
Summary14109: SQLSTATE[42S22]
Description

Hi,

I am actually on Version 3.14.9+180917 but was not in list above. Hosting myself.

I copied a survey I created, activated it, ran the survey and submitted and it crashes. I set debug to 2, repeated and attach the output from the crash.

Based on a community suggestion, I also tried export/import of the original survey, activated that, ran it, submitted and all was fine.

Given the source survey did not change in each case, I assume there may be a bug in the copy function?

Thanks

Steps To Reproduce

See description

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.14.9+180917
I will donate to the project if issue is resolvedNo
BrowserChrome and Firefox
Database & DB-Versionmysql 5.7.23
Server OS (if known)linux
Webserver software & version (if known)apache 2.4.34
PHP Version5.6.37

Activities

izzysteve

izzysteve

2018-09-28 10:42

reporter  

error 20180927.zip (6,967 bytes)
izzysteve

izzysteve

2018-09-28 10:55

reporter   ~49163

Attached phpinfo in case it helps

izzysteve

izzysteve

2018-09-28 10:59

reporter  

PHP 5.6.38.pdf (1,741,793 bytes)
DenisChenu

DenisChenu

2018-09-28 12:00

developer   ~49165

Attach survey in lss format please …

izzysteve

izzysteve

2018-09-28 12:06

reporter  

limesurvey_survey_191564.lss (32,675 bytes)
DenisChenu

DenisChenu

2018-09-28 12:10

developer   ~49166

Can you export and upload here the LSA file too, because you write export/import lss fix the issue
https://www.limesurvey.org/forum/installation-a-update-issues/116535-cdbcommand-failed-to-execute-the-sql-statement-sqlstate-42s22#174699

izzysteve

izzysteve

2018-09-28 13:00

reporter   ~49168

Also adding lsa file here



survey_archive_191564.lsa (6,262 bytes)
DenisChenu

DenisChenu

2018-09-28 17:20

developer   ~49188

Last edited: 2018-09-28 17:20

View 2 revisions

I don't have such issue with the lsa … did you just try deactivate/reactivate ?

Surely/maybe a subquestion badly deleted …

Can you look if you have a question that don't exist anymore in group 42 in the database ? lime_question

PS : reupload the HTML of the exception, more easy to see it here ¿



CDbException.html (28,070 bytes)
izzysteve

izzysteve

2018-10-01 14:08

reporter   ~49201

Hi,

Apologies for delay, weekend intervened.

Yes, I have no issue when I too imported from an export file, so it makes sense that you would not have a problem from the .lsa file. It was when I copied the same survey that I had the issue.

I have checked DB and confirm there is no Group 42 in it, not are there any questions that include gid 42.

I have attached error as requested.

Thanks,
Steve



error 20180927-2.zip (6,967 bytes)
dominikvitt

dominikvitt

2018-10-04 17:25

developer   ~49243

I'm unable to reproduce this issue using the latest version.
I did make a copy, activated and submitted a survey, but was always able to finish it successfully.
Do you know of specific condition when it occurs?

izzysteve

izzysteve

2018-10-10 16:56

reporter   ~49295

Apologies, I do not seem to get notifications when a comment is added and didn't realise you had asked a question.

In the last week, I have created other surveys with similar issue - if I use the copy, my answers do not get saved when I submit; if I export/import the very same survey, I have no issues at all.

So sometimes it crashes as per original comment; other times answers not saved. I don't know any specific condition as it is when I click Submit at the end that the issue materialises.

izzysteve

izzysteve

2018-10-10 18:13

reporter   ~49298

I think the best thing is that I will keep checking this over coming weeks, and if I see any useful pattern, I will report back.

Thanks for your help.

DenisChenu

DenisChenu

2018-10-10 18:56

developer   ~49300

PS : Can you look if you have a question that don't exist anymore in group 42 in the database ? lime_question

And see with a broken survey what happen when you click on «Check data integrity»

It can be a subquestion (or not) leave in DB for some old reason : but «Check data integrity» must fix it.

izzysteve

izzysteve

2018-10-11 09:15

reporter   ~49304

I ran the data integrity process and it shows no issues.

I looked at the database and I have no group 42 any more and I also have no questions linked to Group 42. I have deleted the survey that was causing issues, so I think that is all as expected.

As my previous note, I will keep checking for this issue (I have progressed significantly in the 2 weeks I started using LS) and will report back if issue re-occurs. If you want, this can be closed.

Many thanks.

Issue History

Date Modified Username Field Change
2018-09-28 10:42 izzysteve New Issue
2018-09-28 10:42 izzysteve File Added: error 20180927.zip
2018-09-28 10:55 izzysteve Note Added: 49163
2018-09-28 10:59 izzysteve File Added: PHP 5.6.38.pdf
2018-09-28 12:00 DenisChenu Note Added: 49165
2018-09-28 12:06 izzysteve File Added: limesurvey_survey_191564.lss
2018-09-28 12:10 DenisChenu Note Added: 49166
2018-09-28 13:00 izzysteve File Added: survey_archive_191564.lsa
2018-09-28 13:00 izzysteve Note Added: 49168
2018-09-28 17:20 DenisChenu File Added: CDbException.html
2018-09-28 17:20 DenisChenu Note Added: 49188
2018-09-28 17:20 DenisChenu Note Edited: 49188 View Revisions
2018-10-01 14:08 izzysteve File Added: error 20180927-2.zip
2018-10-01 14:08 izzysteve Note Added: 49201
2018-10-04 17:25 dominikvitt Assigned To => dominikvitt
2018-10-04 17:25 dominikvitt Status new => feedback
2018-10-04 17:25 dominikvitt Note Added: 49243
2018-10-10 16:56 izzysteve Note Added: 49295
2018-10-10 16:56 izzysteve Status feedback => assigned
2018-10-10 18:13 izzysteve Note Added: 49298
2018-10-10 18:56 DenisChenu Note Added: 49300
2018-10-11 09:15 izzysteve Note Added: 49304