View Issue Details

IDProjectCategoryView StatusLast Update
14058Bug reports[All Projects] Import/Exportpublic2019-04-30 09:11
Reportermarkusfluer Assigned Tomarkusfluer  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.14.x 
Target Version3.14.xFixed in Version3.14.x 
Summary14058: vvimport failing because of missing default values on newer MariaDB databases
Description

IF the vvexport of a survey without datestamp enabled is imported to a survey with datestamp enabled, the vvimport will fail to import the file.

Steps To Reproduce
  1. create a survey without datestamps
  2. activate and answer it a couple times.
  3. export responses to VV
  4. deactivate survey
  5. enable datestamps
    6 activate survey
    7 import responses from vv file.
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.8 (github 2018-09-15 13:07:00+0200)
I will donate to the project if issue is resolvedNo
BrowserChrome 56+, Firefox 52+
Database & DB-Versionmysqlnd 5.0.12
Server OS (if known)Ubuntu 18.04
Webserver software & version (if known)nginx/1.14.0
PHP Version7.2

Relationships

related to 14050 closeddominikvitt Unable to import all db if stardate added 

Activities

markusfluer

markusfluer

2018-09-15 13:12

administrator   ~49054

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27956

DenisChenu

DenisChenu

2018-09-16 11:17

developer   ~49057

In 14050 : test is done with same server … and i don't find where default can be set …

I hate to don't understand ;)

Thanks

Related Changesets

LimeSurvey: master 68ff2516

2018-09-15 13:09:00

markusfluer

Details Diff
Fixed issue 14058: vvimport failing because of missing default values on newer MariaDB databases Affected Issues
14058
mod - application/helpers/admin/import_helper.php Diff File

Issue History

Date Modified Username Field Change
2018-09-15 13:08 markusfluer New Issue
2018-09-15 13:08 markusfluer Status new => assigned
2018-09-15 13:08 markusfluer Assigned To => markusfluer
2018-09-15 13:12 markusfluer Changeset attached => LimeSurvey master 68ff2516
2018-09-15 13:12 markusfluer Note Added: 49054
2018-09-15 13:12 markusfluer Resolution open => fixed
2018-09-15 13:13 markusfluer Status assigned => resolved
2018-09-15 13:13 markusfluer Fixed in Version => 3.14.x
2018-09-16 11:16 DenisChenu Relationship added related to 14050
2018-09-16 11:17 DenisChenu Note Added: 49057
2019-04-30 09:11 c_schmitz Status resolved => closed