View Issue Details

IDProjectCategoryView StatusLast Update
14027Bug reports[All Projects] Import/Exportpublic2018-09-14 02:00
ReportervinnyboxAssigned Toadamzammit 
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary14027: Qid-token not substituted in quexml pdf export
Description

When exporting/printing a survey as queXML PDF, the Qid-tokens are not being substituted with the corresponding values.
ie. In a questionstekst is states:"1.1. AIAAC.shown maakt zich zorgen over naderende activiteiten en gebeurtenissen.". The token in the survey is correctly replaced with the value. In this case the AIAAC.shown='John'.

When I use the (queXMl)print button at the end of the survey or use the button in the Survey participants overview, the rapport shows the question this way:"1.1. {INSERTANS:898863X186X2223} maakt zich zorgen over naderende activiteiten en gebeurtenissen.". The wanted presentation should be:"1.1. John maakt zich zorgen over naderende activiteiten en gebeurtenissen."

Steps To Reproduce

1 - Start a survey
2 - Answer all questions
3 - Print survey as quexmlpdf - format

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.14.5+180815
I will donate to the project if issue is resolvedNo
BrowserAny
Database & DB-Versionmysqlnd 5.0.12-dev
Operating System (Server)Linux
Webserver software & versionApache
PHP Version 7.0.31

Relationships

duplicate of 13581 closedadamzammit Survey place holders not processed in queXMLPDF 

Activities

vinnybox

vinnybox

2018-09-04 13:57

reporter  

QidNotSubstitutedInQueXMLpdf.png (112,571 bytes)
c_schmitz

c_schmitz

2018-09-04 15:14

administrator   ~48965

Adam, can you please have a look at this?

adamzammit

adamzammit

2018-09-14 02:00

developer   ~49029

Apologies for the delay. This looks like bug 13581 which I have just updated.

Issue History

Date Modified Username Field Change
2018-09-04 13:57 vinnybox New Issue
2018-09-04 13:57 vinnybox File Added: QidNotSubstitutedInQueXMLpdf.png
2018-09-04 15:14 c_schmitz Assigned To => adamzammit
2018-09-04 15:14 c_schmitz Status new => assigned
2018-09-04 15:14 c_schmitz Note Added: 48965
2018-09-07 12:34 c_schmitz View Status private => public
2018-09-14 02:00 adamzammit Note Added: 49029
2018-09-14 02:00 adamzammit Status assigned => closed
2018-09-14 02:00 adamzammit Resolution open => duplicate
2018-09-14 02:00 adamzammit Relationship added duplicate of 13581