View Issue Details

IDProjectCategoryView StatusLast Update
14026Bug reports[All Projects] Installationpublic2018-09-29 10:56
ReporterjeloAssigned Toc_schmitz 
PrioritynoneSeveritycrash 
Status closedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary14026: LTS 2.6.7 and PHP support
Description

LTS 2.6.7 and PHP support
The current description of requirements for LTS 2.6.7 contains
" *PHP 5.3.3 or later with the following modules/libraries enabled"

That would include PHP versions like 7.0, 7.1 or 7.2.

LTS 2.6.7 under PHP 7.2?
When doing a quick installation the preinstallation check already fails under PHP 7.2.

Internal Server Error
Function name must be a string

An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.

Thank you.

PHP 7.1 looks the same.

When moving a complete installation to PHP 7.2. I see no issues.

So the installer might be a bit to edgy ;-) You can run LTS on PHP 7.2, but you cannot install it.

Steps To Reproduce

Just install LTS on PHP 7.1 or PHP 7.2.

TagsNo tags attached.
Complete LimeSurvey version number (& build)2.6.7
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL
Server OS (if known)CentOS 7
Webserver software & version (if known)Apache
PHP Version7.1 / 7.2

Activities

Mazi

Mazi

2018-09-05 14:11

partner   ~48974

There are quite some users running 2.6.x LTS because they do not want to switch to a newer version. But often their PHP versions are updated. So since users are paying for LTS support, please fix this and publish a new release for everyone.

DenisChenu

DenisChenu

2018-09-28 08:54

developer   ~49160

I just update yesterday a IIS/php via webPI with https://github.com/SondagesPro/LimeSurvey-SondagesPro

Can you check it install with 7.2 (i never tested new install)

DenisChenu

DenisChenu

2018-09-29 10:56

developer   ~49190

I think this one are closed :)
https://github.com/LimeSurvey/LimeSurvey/commit/69d632a85d870a71248ee97f777eb5084d4f4397

Related Changesets

LimeSurvey: master 69d632a8

2018-09-28 14:30:27

c_schmitz

Details Diff
Dev Merge & remove branch '2.06lts' Affected Issues
14026

Issue History

Date Modified Username Field Change
2018-09-04 10:16 jelo New Issue
2018-09-05 14:11 Mazi Note Added: 48974
2018-09-28 08:54 DenisChenu Note Added: 49160
2018-09-29 10:56 DenisChenu Assigned To => c_schmitz
2018-09-29 10:56 DenisChenu Status new => closed
2018-09-29 10:56 DenisChenu Resolution open => won't fix
2018-09-29 10:56 DenisChenu Note Added: 49190
2018-09-29 10:56 DenisChenu Changeset attached => LimeSurvey master 69d632a8