View Issue Details

IDProjectCategoryView StatusLast Update
14025Bug reports[All Projects] Otherpublic2019-04-30 09:10
Reporterminnoce Assigned Todominikvitt  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.14.x 
Summary14025: When using custom theme the "Exit and clear all" link does not disappear at the last (survey completed) step
Description

The "exit and clear all" link normally (using a core theme) disappear at the last step of a survey (when the survey is completed).
But when using a custom (extend) theme (no matter which) the "exit and clear all" link is still present (not disappear) at the last step (when the survey is completed).

Steps To Reproduce

1) Extend a core theme and save it
2) Create a simple survey (no matter which questions)
3) Assign the newly extended theme to the survey and activate it
3) Execute the survey
4) At the last step (survey completed), the "exit and clear all" link does not disappear

Additional Information

Looking at the "clearall_links.twig" theme template, there is a test on the "aSurveyInfo.bShowClearAll" variable.
It seem's that this variable does not change to "false" at the last step (completed survey) when using an extended theme.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.8+180829
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMysql 5.5
Server OS (if known)CentOS 6.9
Webserver software & version (if known)Apache 2.2
PHP Version5.6

Activities

dominikvitt

dominikvitt

2018-09-04 10:31

developer   ~48959

I'm unable to reproduce this issue, both locally and on hosting.
It may be related to some specific survey configuration.
Please attach your test lss file.

minnoce

minnoce

2018-09-04 14:14

reporter   ~48962

I'm a bit confused:
I tried a new & fresh limesurvey installation on my local Workstation, with a different environment (Fedora 28 + Apache 2.4 + PHP 7.2 + MariaDB 10.2).
Now if I try the same steps described above (steps to reproduce), the "exit and clear survey" link NEVER disappear (neither at last step). I attached a screenshot.
What should be the correct behaviour?



dominikvitt

dominikvitt

2018-09-04 14:28

developer   ~48963

Correct behavior is to hide it on the last page.
I noticed last week this same behavior you're experiencing now.
Then I fixed it on 31.08.
You're using 3.14.8+180829 version, which was two days before my fix.
You can try to clone repository now or wait until next zipped release.

minnoce

minnoce

2018-09-04 14:52

reporter   ~48964

I tested your patch from repository and I confirm it work correctly in both my environments.
Thanks a lot for the fix!

Issue History

Date Modified Username Field Change
2018-09-03 16:34 minnoce New Issue
2018-09-03 16:59 c_schmitz Assigned To => dominikvitt
2018-09-03 16:59 c_schmitz Status new => assigned
2018-09-04 10:31 dominikvitt Note Added: 48959
2018-09-04 14:14 minnoce File Added: Screenshot from 2018-09-04 14-12-36.png
2018-09-04 14:14 minnoce Note Added: 48962
2018-09-04 14:28 dominikvitt Note Added: 48963
2018-09-04 14:52 minnoce Note Added: 48964
2018-09-04 14:54 dominikvitt Status assigned => resolved
2018-09-04 14:54 dominikvitt Resolution open => fixed
2018-09-04 14:54 dominikvitt Fixed in Version => 3.14.x
2019-04-30 09:10 c_schmitz Status resolved => closed