View Issue Details

IDProjectCategoryView StatusLast Update
14022Bug reports[All Projects] Theme editorpublic2019-05-13 15:21
ReportermikebbAssigned Todominikvitt 
PrioritynoneSeveritymajor 
Status closedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary14022: theme list won't load (times out) after extedning core theme
Description

LS Version 3.14.3+180809 - debian 8
when I extend the core theme 'juicy' and without any theme modification, then go to the themes list page (https://..../index.php/admin/themeoptions) it times outs with no page returned. this is even with max execution time at 1200 secs. I also appear to get a big CPU load (i'm not completely sure of this install on a shared VPS) while this is executing and the browser locks up, even after the max execution time - I cant reload the page on chrome, ff or edge. firefox shows nothing in console.
in config.php I have set debug to 2 and still get no response.

my only recovery is delete the DB theme entries under lime_templates and lime_template_options (and later remove the theme files from /upload/themes/survey/)

I think its a major as if others can reproduce this it compromises all custom themes

Steps To Reproduce

extend the core juicy theme.
try and go to the theme listing page.

TagsNo tags attached.
Complete LimeSurvey version number (& build)LS Version 3.14.3+180809
I will donate to the project if issue is resolvedNo
Browserfirefox, edge and chrome (all latest)
Database & DB-Versionmariadb-client 10.0.35-0+deb8u1
Server OS (if known)Debian 8 (php 5.6.8)
Webserver software & version (if known)Debian - apache2 2.4.10-10+deb8u12
PHP Version5.6.8

Activities

mikebb

mikebb

2018-09-02 03:58

reporter   ~48930

somehow I managed to find an error for https://.../LS/index.php/admin/themeoptions
Undefined property: TemplateConfiguration::$options

Stack Trace #0
/var/www/html/LS/application/models/TemplateConfiguration.php(1186): TemplateConfiguration->__get("options")
$sAttribute = $this->getParentConfiguration()->$name;

#1
/var/www/html/LS/application/models/TemplateConfiguration.php(1003): TemplateConfiguration->__get("options")
if (!empty($this->options)) {

#2
/var/www/html/LS/application/models/TemplateConfiguration.php(968): TemplateConfiguration->setOptions()
if (!empty($this->options)) {

mikebb

mikebb

2018-09-02 05:19

reporter   ~48931

also this:
Fatal error: Maximum execution time of 1200 seconds exceeded in /var/www/html/LS/framework/db/ar/CActiveRecord.php on line 138

weird when the server max execution is 30seconds - does LS extend this?

dominikvitt

dominikvitt

2018-09-06 11:03

developer   ~48981

I'm unable to reproduce this issue using the latest version.
Please try to update your installation to the latest version and then try again.
Also, try to "sudo chmod -R 777 *" to your installation.

LouisGac

LouisGac

2018-09-10 10:59

manager   ~48995

theme "juicy"? not a core theme, could please attach it?

Issue History

Date Modified Username Field Change
2018-09-02 03:15 mikebb New Issue
2018-09-02 03:58 mikebb Note Added: 48930
2018-09-02 05:19 mikebb Note Added: 48931
2018-09-06 11:00 dominikvitt Assigned To => dominikvitt
2018-09-06 11:00 dominikvitt Status new => assigned
2018-09-06 11:03 dominikvitt Note Added: 48981
2018-09-10 10:59 LouisGac Note Added: 48995
2019-05-13 15:21 dominikvitt Status assigned => resolved
2019-05-13 15:21 dominikvitt Resolution open => unable to reproduce
2019-05-13 15:21 dominikvitt Status resolved => closed