View Issue Details

IDProjectCategoryView StatusLast Update
14008Bug reports[All Projects] Otherpublic2018-08-28 12:01
Reportermichielve Assigned Todominikvitt  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.13.x 
Target VersionFixed in Version3.14.x 
Summary14008: Prepopulate question with answer from URL parameter not working
Description

I can't get the first question to prepopulate with the answer from a URL parameter on my local LimeSurvey Version 3.14.6+180821 installation.

The name of the question is qpersname (short text field type). The survey is not activated yet.

The URL I call is:

http://localhost/limesurvey/index.php/798341?newtest=Y&lang=en&qpersname=michiel

I have disabled the welcome page, so the user lands on this question, but the input field stays empty.

When I use the panel integration feature, it works, but according to the URL fields manual section, it should also be possible without panel integration.

Steps To Reproduce
  1. Create new survey with 1 short text field question and name this question qpersname, make sure to disable the welcome page
  2. Try out the survey
  3. Add "&qpersname=testname" at the end of the URL
    Now you should see the question prepopulated with the "testname" value, but nothing shows
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.6+180821
I will donate to the project if issue is resolvedNo
BrowserChrome 68.0.3440.106
Database & DB-VersionMySQL 8.0.12
Server OS (if known)Mac OS High Sierra
Webserver software & version (if known)Apache 2.4.34
PHP Version7.0.31

Activities

DenisChenu

DenisChenu

2018-08-27 10:46

developer   ~48875

Can not reproduce with last GIT version
https://master.sondages.pro/69285?newtest=Y&lang=fr&Qtexte2=toto

Send a lss file for testing

guest

guest

2018-08-27 15:45

viewer   ~48878

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27854

Related Changesets

LimeSurvey: master 2a9d8c4f

2018-08-27 15:45:05

Dominik Vitt

Details Diff
Fixed issue 14008: Prepopulate question with answer from URL parameter not working Affected Issues
14008
mod - application/helpers/expressions/em_manager_helper.php Diff File

Issue History

Date Modified Username Field Change
2018-08-26 09:08 michielve New Issue
2018-08-27 10:46 DenisChenu Note Added: 48875
2018-08-27 10:47 DenisChenu Severity major => minor
2018-08-27 10:47 DenisChenu Reproducibility have not tried => unable to reproduce
2018-08-27 10:49 LouisGac Assigned To => dominikvitt
2018-08-27 10:49 LouisGac Status new => assigned
2018-08-27 15:45 Changeset attached => LimeSurvey master 2a9d8c4f
2018-08-27 15:45 guest Note Added: 48878
2018-08-27 15:45 guest Resolution open => fixed
2018-08-27 16:13 dominikvitt Status assigned => resolved
2018-08-27 16:13 dominikvitt Fixed in Version => 3.14.x
2018-08-28 12:01 LouisGac Status resolved => closed