View Issue Details

IDProjectCategoryView StatusLast Update
13943Bug reports[All Projects] Import/Exportpublic2019-04-30 09:11
Reportericeclimber81Assigned To 
PrioritynoneSeverityminor 
Status closedResolutionopen 
Product Version3.15.x 
Target VersionFixed in Version 
Summary13943: R data file export does not work anymore, producing a .CSV file with only 1 recognisable column
Description

When exporting results as 'R (data file)', the resulting .CSV file appears to have a formatting issue - it looks like the column labels are missing the beginning quotation mark ". Therefore the .CSV file only seems to contain 1 data column and the 'read.csv' data import in R retrieves only 1 column (when opening the .CSV file in Excel, the same issue occurs - only 1 column is recognized).
Therefore the .R syntax file (exported from LimeSurvey) also produces an error on line 9: 'Error in [.data.frame(data, , 2) : undefined columns selected' because there is only 1 data column in the data import.

Steps To Reproduce

Admin > Responses & statistics > Export responses > select 'R (data file)' > click 'Export'

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.13.2, Build 180709
I will donate to the project if issue is resolvedNo
BrowserGoogle Chrome Version 67.0.3396.99
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $
Server OS (if known)Linux dd6928 4.4.0-130-generic #156-Ubuntu SMP Thu Jun 14 08:53:28 UTC 2018 x86_64
Webserver software & version (if known)Apache
PHP Version7.0.30-nmm1

Activities

cdorin

cdorin

2019-02-11 15:31

manager   ~50501

Hey @iceclimber81, could you please attach an .lsa + the .csv file? It seems that I cannot reproduce your issue.

iceclimber81

iceclimber81

2019-02-12 17:20

reporter   ~50528

Hi @cdorin, thanks for checking. I cannot reproduce the issue myself anymore, it appears that something in the recent updates fixed the issue (it occurred on 3.13.2, now using 3.15.8). Thank you for checking anyway - resolved!

cdorin

cdorin

2019-02-12 17:37

manager   ~50532

Last edited: 2019-02-12 17:38

View 2 revisions

@iceclimber81, you're welcome. Yes, there was indeed a recent commit that changed some lines in our R plugin that most probably solved the issue.

Bug report closed.

Issue History

Date Modified Username Field Change
2018-08-07 15:29 iceclimber81 New Issue
2019-02-11 15:31 cdorin Note Added: 50501
2019-02-12 16:44 cdorin Status new => feedback
2019-02-12 17:20 iceclimber81 Note Added: 50528
2019-02-12 17:20 iceclimber81 Status feedback => new
2019-02-12 17:37 cdorin Status new => resolved
2019-02-12 17:37 cdorin Product Version 3.13.x => 3.15.x
2019-02-12 17:37 cdorin Note Added: 50532
2019-02-12 17:38 cdorin Note Edited: 50532 View Revisions
2019-04-30 09:11 c_schmitz Status resolved => closed