View Issue Details

IDProjectCategoryView StatusLast Update
13931Bug reports[All Projects] Installationpublic2018-09-03 17:14
ReporterAndyVincentAssigned Toolle 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.14.x 
Summary13931: Installer enters an infinite redirect loop if the 'tmp' directory is not writable.
Description

Setting up LimeSurvey for the first time, I neglected to make the LS/tmp & other directories writable by the webserver.

Unfortunately this wasn't obvious to be straight away, as when navigating to the limesurvey installer, the error message that would've been displayed was not displayed due to an infinite redirect (coming from the _checkInstallation function in LSYii_Controller, attempting to redirect the 'install' endpoint).

Steps To Reproduce
  1. Start with no installation of LimeSurvey
  2. Extract the LS installation
  3. Skip the step in the manual that says to make limesurvey/tmp (and I suspect the others) writable
  4. Navigate to the .../limesurvey page. Browser [in this case Chrome 68.0.3440.84] will in now attempt to redirect continuously to .../limesurvey/index.php?r=installer eventually giving up with an error message about too many redirects. No LimeSurvey installer is shown.
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.1+180731
I will donate to the project if issue is resolvedNo
BrowserChrome 68.0.3440.84
Database & DB-VersionMySQL 14.14
Operating System (Server)Ubuntu 17.10 [Artful]
Webserver software & versionApache 2.4.27
PHP Version7.1.17

Activities

LouisGac

LouisGac

2018-08-08 11:29

manager   ~48755

Redirect loop is caused by new exception page

olle

olle

2018-08-08 13:10

administrator   ~48758

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27768

c_schmitz

c_schmitz

2018-09-03 17:14

administrator   ~48953

Version 3.14.8+180829 released

Related Changesets

LimeSurvey: master dc30bedc

2018-08-08 13:09:35

olle

Details Diff
Fixed issue 13931: Installer enters an infinite redirect loop if the 'tmp' directory is not writable.
mod - application/core/LSYii_Application.php Diff File

Issue History

Date Modified Username Field Change
2018-08-01 23:08 AndyVincent New Issue
2018-08-07 10:17 LouisGac Assigned To => dominikvitt
2018-08-07 10:17 LouisGac Status new => assigned
2018-08-08 11:28 LouisGac Assigned To dominikvitt => DenisChenu
2018-08-08 11:29 LouisGac Note Added: 48755
2018-08-08 11:30 LouisGac Assigned To DenisChenu => LouisGac
2018-08-08 13:10 olle Changeset attached => LimeSurvey master dc30bedc
2018-08-08 13:10 olle Note Added: 48758
2018-08-08 13:10 olle Assigned To LouisGac => olle
2018-08-08 13:10 olle Resolution open => fixed
2018-08-08 13:11 olle Status assigned => resolved
2018-08-08 13:11 olle Fixed in Version => 3.14.x
2018-09-03 17:14 c_schmitz Note Added: 48953
2018-09-03 17:14 c_schmitz Status resolved => closed