View Issue Details

IDProjectCategoryView StatusLast Update
13903Bug reports[All Projects] _ Unknownpublic2019-04-30 09:13
ReportercairomckenzieAssigned Todominikvitt 
PriorityimmediateSeverityblock 
Status closedResolutionfixed 
Product Version3.9.x 
Target VersionFixed in Version3.14.x 
Summary13903: Get parameters do not work with tokenized survey
Description

When attempting to pass a value to a tokenized survey, the value does not set to the specific question associated in the Get.

attempt to set survey answer using get and the SGQA code for the subquestion. In a non-tokenized survey, the passed variable sets with no problem. In the exact same survey, but this time associated with a token table, the same passed variable will not set. See pictures for my attempts. See attached .lss files for each survey which should demonstrate the error once you activate the surveys.

Steps To Reproduce

using attached .lss
1.Activate survey

  1. Create a token for survey
  2. Open survey using that token
  3. Manually add a get value to attempt to add a value to one of the two questions (adding '?SGQA=somevalue')
  4. Nothing happens.

Repeat steps above, except without the token, in the non-tokenized version of the survey. The value is successfully passed.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.9.0 180604
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMariaDB
Server OS (if known)Ubuntu 16.xx
Webserver software & version (if known)Apache
PHP Version7

Activities

cairomckenzie

cairomckenzie

2018-07-24 18:35

reporter  

bug_getparameters_TOKENS.lss (15,595 bytes)
ls_getparameters_issue.pdf (77,879 bytes)
bug_getparameters_NOTOKENS.lss (15,598 bytes)
DenisChenu

DenisChenu

2018-07-25 08:44

developer   ~48567

You mean when user enter token in the form. Because , i think it's OK if user enter with a link like token=myctoken&Q1=test

DenisChenu

DenisChenu

2018-07-25 08:45

developer   ~48568

  1. Open survey using that token
  2. Manually add a get value to attempt to add a value to one of the two questions (adding '?SGQA=somevalue')

OK : When you do 3 : response are created, not updated after in 4. Then no update of current reponse.

You must copy/paste on a text editor before create the new responses.

cairomckenzie

cairomckenzie

2018-07-25 17:11

reporter   ~48572

Hi Denis

Thanks for looking at this. I'm not sure what you mean about using a text editor. If there is some confusion about what trouble I'm having - I'll try and give some more context.

I hacked together a "dashboard" of sorts to manage multiple surveys for users. From the dashboard, the user will click on links to their specific surveys (which are also tokenized, with the same token used on the 'Dashboard'). At the end of any given survey, the user is redirected using an end url back to their dashboard page. I send back one piece of data, which is the date of the completion of that particular survey. The user doesn't manually enter the data - limesurvey creates it using a combination of expression manager, pass thru variables, etc. I was only manually pasting for expediency. I don't believe it would make a difference if the link was directed automatically from limesurvey, or manually.

The end link formatting can be found below

http://your_server_address/index.php/PASSTHRU:returnSurvey?token={TOKEN:TOKEN}&newtest=Y&lang=en&{PASSTHRU:qcode}={date(%22Y-n-j%22)}

The problem I am having in 3.X versions, is that any get parameters listed (the qcode, in this instance, which is a passthru from the dashboard), are NOT then entered into the dashboard's fields. The 'qcode' in this case is the SGQA code for the field I wish to populate with the current time that the survey was finished.

I know this is an issue with tokenized tables, because I've tested the exact same method using a non tokenized survey with no trouble. And I utilize this method on a 2.x instance of limesurvey with zero issues.

I'm not sure if any of this helps, or if maybe I'm adding to the confusion.

guest

guest

2018-08-30 18:35

viewer   ~48919

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27875

dominikvitt

dominikvitt

2018-08-30 18:36

developer   ~48920

Fixed, would be available from version 3.14.9.

DenisChenu

DenisChenu

2018-08-31 17:21

developer   ~48927

@dominikvitt : can you check somewhere for your account on github to show your name in the message :).

Totally unrelated to any issue ;)

guest

guest

2018-08-31 18:07

viewer   ~48928

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27881

c_schmitz

c_schmitz

2019-04-30 09:13

administrator   ~51694

Fixed in version 3.17.3

Related Changesets

LimeSurvey: master 6e33c923

2018-08-30 18:34:48

Dominik Vitt

Details Diff
Fixed issue 13903: Get parameters do not work with tokenized survey Affected Issues
13903
mod - application/helpers/expressions/em_manager_helper.php Diff File

LimeSurvey: master b1e416aa

2018-08-31 18:07:08

Dominik Vitt

Details Diff
Fixed issue 13903: Get parameters do not work with tokenized survey Affected Issues
13903
mod - application/helpers/expressions/em_manager_helper.php Diff File

Issue History

Date Modified Username Field Change
2018-07-24 18:35 cairomckenzie New Issue
2018-07-24 18:35 cairomckenzie File Added: bug_getparameters_TOKENS.lss
2018-07-24 18:35 cairomckenzie File Added: ls_getparameters_issue.pdf
2018-07-24 18:35 cairomckenzie File Added: bug_getparameters_NOTOKENS.lss
2018-07-25 08:44 DenisChenu Note Added: 48567
2018-07-25 08:45 DenisChenu Note Added: 48568
2018-07-25 17:11 cairomckenzie Note Added: 48572
2018-08-28 11:52 LouisGac Assigned To => dominikvitt
2018-08-28 11:52 LouisGac Status new => assigned
2018-08-28 11:54 LouisGac Priority none => immediate
2018-08-30 18:35 Changeset attached => LimeSurvey master 6e33c923
2018-08-30 18:35 guest Note Added: 48919
2018-08-30 18:35 guest Resolution open => fixed
2018-08-30 18:36 dominikvitt Status assigned => resolved
2018-08-30 18:36 dominikvitt Fixed in Version => 3.14.x
2018-08-30 18:36 dominikvitt Note Added: 48920
2018-08-31 17:21 DenisChenu Note Added: 48927
2018-08-31 18:07 Changeset attached => LimeSurvey master b1e416aa
2018-08-31 18:07 guest Note Added: 48928
2019-04-30 09:13 c_schmitz Note Added: 51694
2019-04-30 09:13 c_schmitz Status resolved => closed