View Issue Details

IDProjectCategoryView StatusLast Update
13865Bug reports[All Projects] _ Unknownpublic2018-09-13 11:55
ReportertizianomuellerAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status resolvedResolutionunable to reproduce 
Product Version3.12.x 
Target VersionFixed in Version 
Summary13865: "Resume later" behaves badly with conditional questions
Description

When using the "Resume later" functionality either with the "Resume later" button or simply by closing the window and then re-entering the survey via the invite link on a conditional question, the resume point is the not the question itself but the Question Group page. Clicking next on that page continues to the next question in the next question group.

Steps To Reproduce
  1. Create a question Q01 with a single choice answer from a selection a/b/c
  2. Create a free-text question Q02 with the condition that it is only displayed if the participant selected 'a'
  3. Create a text message question T01 with the condition that it is only displayed if the participant did not select 'a'
  4. Do the survey, select 'a', go "next"
  5. Click "Resume later" or simply close the window
  6. Re-enter the survey via the invite link which includes the token
  7. The Question Group page for the question group containing Q01, Q02 and T01 is shown
  8. Click next to get to the first question in the next Question Group
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.12.3
I will donate to the project if issue is resolvedNo
BrowserChromium
Database & DB-VersionHosted on LimeQuery.org
Operating System (Server)Hosted on LimeQuery.org
Webserver software & versionHosted on LimeQuery.org
PHP VersionHosted on LimeQuery.org

Activities

LouisGac

LouisGac

2018-07-30 18:32

manager   ~48625

could you please attach a lss file so we can reproduce?

dominikvitt

dominikvitt

2018-09-13 11:06

developer   ~49022

I'm unable to reproduce this issue, both locally and on LimeQuery.org.
Please see if this issue still exists now on LimeQuery.org.
Also, attach your test .lss file.

Issue History

Date Modified Username Field Change
2018-07-10 21:46 tizianomueller New Issue
2018-07-30 18:32 LouisGac Note Added: 48625
2018-08-28 11:51 LouisGac Assigned To => dominikvitt
2018-08-28 11:51 LouisGac Status new => assigned
2018-09-13 11:06 dominikvitt Status assigned => feedback
2018-09-13 11:06 dominikvitt Note Added: 49022
2018-09-13 11:55 LouisGac Status feedback => resolved
2018-09-13 11:55 LouisGac Resolution open => unable to reproduce