View Issue Details

IDProjectCategoryView StatusLast Update
13848Bug reports[All Projects] RemoteControlpublic2018-10-04 11:34
ReporterUllrichAssigned Todominikvitt 
PriorityhighSeveritytweak 
Status resolvedResolutionunable to reproduce 
Product Version3.13.x 
Target VersionFixed in Version 
Summary13848: Multiple entries
Description

The function cpd_importParticipants(integer $sSessionKey, array $aParticipants) : array
checks for duplicates before doing an insert.

It is checked with:

$arRecordExists = Participant::model()->exists(
'firstname = :firstname AND lastname = :lastname AND email = :email AND owner_uid = :owner_uid',
array(
':firstname' => $aData['firstname'],
':lastname' => $aData['lastname'],
':email' => $aData['email'],
':owner_uid' => $aData['owner_uid'],
));

If no firstname and lastname is specified and a praticipant only identified by email no participant is returned and you can insert same data again.
If a firstname and lastname is specified, everything works fine.

Steps To Reproduce

Insert new participant using RemoteControl and do not specify first- and lastname.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.13.1+180629
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version352
Server OS (if known)Ubuntu 16.04
Webserver software & version (if known)Apache 2.4
PHP Version7.1.16

Activities

dominikvitt

dominikvitt

2018-10-04 11:34

developer   ~49229

When I called cpd_importParticipants command for the first time without specifying firstname and lastname, new record is inserted into the database and got response ImportCount: 1.
Then I called it for the second time with same parameters ( firstname and lastname are empty, email is the same ).
It doesn't insert a new record and got response ImportCount: 0.
So, I can't reproduce it according to your explanation, it doesn't insert a new record.
Or maybe I missed something?

Issue History

Date Modified Username Field Change
2018-07-05 13:34 Ullrich New Issue
2018-08-07 10:34 LouisGac Assigned To => dominikvitt
2018-08-07 10:34 LouisGac Status new => assigned
2018-08-28 12:02 LouisGac Priority none => high
2018-10-04 11:34 dominikvitt Status assigned => resolved
2018-10-04 11:34 dominikvitt Resolution open => unable to reproduce
2018-10-04 11:34 dominikvitt Note Added: 49229