View Issue Details

IDProjectCategoryView StatusLast Update
13834Bug reports[All Projects] Survey designpublic2019-07-11 16:11
ReporterbnicholsAssigned Toeddylackmann 
PrioritynoneSeverityminor 
Status feedbackResolutionopen 
Product Version3.12.x 
Target VersionFixed in Version 
Summary13834: Permalink Issue with Deleting Questions/Question Groups
Description

I have LimeSurvey setup on IIS, running with a MySQL database. Works really well, although I have found an issue with some of the links after deleting questions/surveys.

surveys.mydomain.com/index.php?r=admin/s...ons/surveyid/1?gid=7
The above URL was forbidden after deleting a single question.

Note the double ampersand being used (?r=admin and ?gid=7).

Changing the URL
surveys.mydomain.com/index.php?r=admin/s...ons&surveyid=1&gid=7
does work however.

Steps To Reproduce

1) Create a survey
2) Create a question group
3) Create a question
4) Delete that question
5) Error page thrown due to multiple parameters declared in URL (?r=admin and ?gid=7)

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.12.1+180616
I will donate to the project if issue is resolvedNo
BrowserAll
Database & DB-Versionmysqlnd 5.0.11-dev - 20120503
Server OS (if known)Windows NT WEB1 10.0 build 14393 (Windows Server 2016) i586
Webserver software & version (if known)Microsoft-IIS/10.0
PHP Version5.6.31

Activities

cdorin

cdorin

2019-07-11 15:09

manager   ~52837

@bnichols , still having the error?

eddylackmann

eddylackmann

2019-07-11 16:10

developer   ~52846

i can't reproduce the error.

Issue History

Date Modified Username Field Change
2018-07-03 11:08 bnichols New Issue
2019-07-11 15:09 cdorin Note Added: 52837
2019-07-11 15:47 LouisGac Assigned To => eddylackmann
2019-07-11 15:47 LouisGac Status new => assigned
2019-07-11 16:10 eddylackmann Note Added: 52846
2019-07-11 16:11 eddylackmann Status assigned => feedback