View Issue Details

IDProjectCategoryView StatusLast Update
13828Bug reports[All Projects] _ Unknownpublic2018-06-29 17:12
Reporterfbrei Assigned Todominikvitt  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.13.x 
Target VersionFixed in Version3.13.x 
Summary13828: Internal Server Error when clicking on 'Theme Options' in Survey Admin Area
Description

As a survey admin I would like to access the theme options in the admin area of a survey. But when I click on the menu item I receive 'Internal Server Error
Call to undefined function mime_content_type()'
All other menu items are working fine. I have restarted both the Apache software as well as the whole server.

This issue started after installing the latest Comfort Update.

Steps To Reproduce

Open any survey, click on 'Theme Options', oberve 'Internal Server Error'

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.13.0+180628
I will donate to the project if issue is resolvedNo
BrowserGoogle Chrome
Database & DB-Version5.5.56-MariaDB
Server OS (if known)FreeBSD 11.1-RELEASE-p11
Webserver software & version (if known)Apache/2.4.33 (FreeBSD)
PHP Version 7.2.4

Activities

ollehar

ollehar

2018-06-29 10:59

administrator   ~48392

Is mime_content_type missing on FreeBSD PHP?

ollehar

ollehar

2018-06-29 11:00

administrator   ~48393

The php.net page doesn't say anything specific. https://secure.php.net/manual/en/function.mime-content-type.php

c_schmitz

c_schmitz

2018-06-29 11:04

administrator   ~48394

It does not appear to be available if the server is not properly configured. It makes no sense to have our own solution here- Instead we should use CFileHelper which can handle this case properly.

fbrei

fbrei

2018-06-29 11:29

reporter   ~48397

Thank you for your quick replies :)
I found a solution to the problem. I think that mime_content_type was only used because fileinfo was missing. I installed the php72-fileinfo package and now it is working again. Maybe it could be listed explicitly as a dependency in the wiki?

c_schmitz

c_schmitz

2018-06-29 11:41

administrator   ~48398

Last edited: 2018-06-29 11:41

View 2 revisions

@fbrei We don't list it as a dependency because by default it is enabled in PHP, see http://php.net/manual/en/fileinfo.installation.php

@dominikvitt Still switch it to use CFileHelper, please.

fbrei

fbrei

2018-06-29 11:53

reporter   ~48401

@c_schmitz Thank you for posting that link. I asked the php guys to include a note in their documentation that the fileinfo module is not installed by default on FreeBSD.

guest

guest

2018-06-29 14:00

viewer   ~48405

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27571

dominikvitt

dominikvitt

2018-06-29 14:04

developer   ~48407

This issue is fixed, the solution would work with both mime_content_type and fileinfo libraries.

c_schmitz

c_schmitz

2018-06-29 17:12

administrator   ~48419

Version 3.13.1+180629 released.

Related Changesets

LimeSurvey: master 903c8e4e

2018-06-29 14:00:16

Dominik Vitt

Details Diff
Fixed issue 13828: Internal Server Error when clicking on 'Theme Options' in Survey Admin Area Affected Issues
13828
mod - application/core/LSYii_ImageValidator.php Diff File

Issue History

Date Modified Username Field Change
2018-06-29 10:22 fbrei New Issue
2018-06-29 10:59 ollehar Note Added: 48392
2018-06-29 11:00 ollehar Note Added: 48393
2018-06-29 11:00 ollehar Status new => feedback
2018-06-29 11:04 c_schmitz Note Added: 48394
2018-06-29 11:04 c_schmitz Assigned To => dominikvitt
2018-06-29 11:04 c_schmitz Status feedback => assigned
2018-06-29 11:29 fbrei Note Added: 48397
2018-06-29 11:41 c_schmitz Note Added: 48398
2018-06-29 11:41 c_schmitz Note Edited: 48398 View Revisions
2018-06-29 11:53 fbrei Note Added: 48401
2018-06-29 14:00 Changeset attached => LimeSurvey master 903c8e4e
2018-06-29 14:00 guest Note Added: 48405
2018-06-29 14:00 guest Resolution open => fixed
2018-06-29 14:04 dominikvitt Status assigned => resolved
2018-06-29 14:04 dominikvitt Fixed in Version => 3.13.x
2018-06-29 14:04 dominikvitt Note Added: 48407
2018-06-29 17:12 c_schmitz Note Added: 48419
2018-06-29 17:12 c_schmitz Status resolved => closed