View Issue Details

IDProjectCategoryView StatusLast Update
13812Bug reports[All Projects] Statisticspublic2019-10-25 14:52
Reportervisionit Assigned Toeddylackmann  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.12.x 
Target VersionFixed in Version 
Summary13812: Statistics Export does not show Graphs / Images
Description

Hi there,

I'm using LimeSurvey 3.12.0 together with Apache 2.4 and PHP 7.2.

For some reason, graphs no longer show up in my statistic exports, both in HTML and PDF.
When I click on the 'Export images' button, I just get an empty ZIP file.
There are no errors in the JavaScript-Browser-Console.

I have ensured the PHP extensions gd and iconv are installed and enabled.

I know that the exact same survey produces viewable graphs in the output at least half a year ago.

Regards
Jack

Steps To Reproduce
  1. Finish a survey
  2. Select 'Responses' -> 'Responses & Statistics'
  3. Select 'Statistics'
  4. Check 'View summary of all available fields' and 'Show graphs'
  5. Select either HTML or PDF as output format
  6. Click 'View Statistics'
    => Statistics output comes up without graphs
Tagsexport, graph, html, image, PDF
Complete LimeSurvey version number (& build)3.12.0+180615
I will donate to the project if issue is resolvedNo
BrowserFirefox 62.0
Database & DB-VersionMySQL
Server OS (if known)Debian
Webserver software & version (if known)Apache 2.4
PHP VersionPHP 7.2

Activities

cdorin

cdorin

2019-07-11 14:58

manager   ~52833

Hello @visionit, could you please confirm if this is still an issue? (please update first to 3.17.7)

visionit

visionit

2019-07-11 16:00

reporter   ~52845

Hi @cdorin , I haven't seen the Release 3.17.7 on Github yet, so I tried using 3.17.6+190624. The issue still exists, the statistics output comes up without graphs.

Mazi

Mazi

2019-10-21 08:54

partner   ~54122

@cdorin, I checked this using Chrome with the latest LS version (3.19.2). It seems to be working fine if all charts were generated on the page but according to a customer it seems to fail with Firefox. Can someone look into this?

visionit

visionit

2019-10-25 12:24

reporter   ~54217

@mazi I just check it using Firefox 70.0 and LimeSurvey 3.19.2+191017. Also seems to work fine, I can see charts in both HTML and PDF output.

Looks good.

Mazi

Mazi

2019-10-25 14:43

partner   ~54224

@cdorin, looks like we can close this one.

Issue History

Date Modified Username Field Change
2018-06-26 10:44 visionit New Issue
2018-06-26 10:45 visionit Tag Attached: export
2018-06-26 10:45 visionit Tag Attached: PDF
2018-06-26 10:45 visionit Tag Attached: html
2018-06-26 10:46 visionit Tag Attached: graph
2018-06-26 10:46 visionit Tag Attached: image
2019-07-11 14:58 cdorin Assigned To => cdorin
2019-07-11 14:58 cdorin Status new => feedback
2019-07-11 14:58 cdorin Note Added: 52833
2019-07-11 16:00 visionit Note Added: 52845
2019-07-11 16:00 visionit Status feedback => assigned
2019-08-08 17:19 cdorin Assigned To cdorin => eddylackmann
2019-10-21 08:54 Mazi Note Added: 54122
2019-10-25 12:24 visionit Note Added: 54217
2019-10-25 14:43 Mazi Note Added: 54224
2019-10-25 14:43 eddylackmann Status assigned => resolved
2019-10-25 14:43 eddylackmann Resolution open => fixed
2019-10-25 14:52 cdorin Status resolved => closed