View Issue Details

IDProjectCategoryView StatusLast Update
13800Bug reports[All Projects] Survey takingpublic2019-05-23 09:58
ReporterdgeilsAssigned Toc_schmitz 
PrioritynoneSeverityblock 
Status closedResolutionfixed 
Product Version3.7.x 
Target VersionFixed in Version3.13.x 
Summary13800: Did not save on Survey Participation
Description

I have installed LimeSurvey version 3.7.2. After installation I create a survey. The survey is built and has a link that I may use to access the survey. On the initial survey load, under the LimeSurvey logo displays, which is not shown in the HTML save of the web page:
Did not save
An unexpected error has occurred and your responses cannot be saved.
Try to submit again

I immediately check the database and a row has been added with “id”, “starlanguage” and “seed” populated. The fields “token”, “submitdate”, “lastpage” and question answer column have “NULL”.

Based on this information, I select “Next” to see what the results are. It displays the survey but it still has the same “Did not save” message below the logo. I complete the survey, simple “yes”, “no” radial button single question and select “submit”. The completion page is displayed with the “Did not save” message below the logo. I check the database and there are three rows in the database, one for each page, with “id”, “starlanguage” and “seed” populated and “token”, “submitdate”, “lastpage” and question answer column have “NULL”.

Main configuration:
• Fast-CGI PHP Version 7.0.29 (build PHP Version 7.0.29)
• MSSQL 2012 (same issue with 2016)
• LimeSurvey Version 3.7.2+180508 (Attempted limesurvey2.67.2+170719.zip with same results)
• IIS Version 1607 (OS Build 14393.2312)
• Server 2012 R2

Alternate configuration:
• Apache 2.4
• PHP 7.0.30 (cli) (built: Apr 24 2018 16:16:46) ( ZTS )
• MSSQL 2012 (same issue with 2016)
• LimeSurvey Version 3.7.2+180508 (Attempted limesurvey2.67.2+170719.zip with same results)
• Server 2012 R2

I have done extensive searches and it appears many people are having this issue. Please provide a fix or workaround.

Thank you.

Steps To Reproduce

Build a survey with the environment listed. Select the survey URL and attempt to take the survey.

Additional Information

I have attempted two completely separate configurations. They are below:

Main configuration:
• Fast-CGI PHP Version 7.0.29 (build PHP Version 7.0.29)
• MSSQL 2012 (same issue with 2016)
• LimeSurvey Version 3.7.2+180508 (Attempted limesurvey2.67.2+170719.zip with same results)
• IIS Version 1607 (OS Build 14393.2312)
• Server 2012 R2

Alternate configuration:
• Apache 2.4
• PHP 7.0.30 (cli) (built: Apr 24 2018 16:16:46) ( ZTS )
• MSSQL 2012 (same issue with 2016)
• LimeSurvey Version 3.7.2+180508 (Attempted limesurvey2.67.2+170719.zip with same results)
• Server 2012 R2

Also, I have started paying for support for future updates as a method of financially supporting.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.7.2+180508
I will donate to the project if issue is resolvedNo
BrowserChrome and IE
Database & DB-VersionMSSQL 2012 (same issue with 2016)
Server OS (if known)Server 2012 R2
Webserver software & version (if known)IIS Version 1607 (OS Build 14393.2312) and Apache 2.4
PHP VersionFast-CGI PHP Version 7.0.29 (build PHP Version 7.0.29) and • PHP 7.0.30 (cli) (built: Apr 24 2018 16:16:46) ( ZTS )

Activities

dgeils

dgeils

2018-06-21 14:49

reporter  

ApacheConfiguration.html (15,536 bytes)
DatabaseView.JPG (21,043 bytes)
DatabaseView.JPG (21,043 bytes)
DidNotSavePicture.JPG (41,779 bytes)
DidNotSavePicture.JPG (41,779 bytes)
ollehar

ollehar

2018-06-21 15:01

administrator   ~48264

Please try with the latest version (3.12.1).

DenisChenu

DenisChenu

2018-06-21 15:46

developer   ~48265

  • need a lss (and surely a lsa) to see if there specific part on the survey
efingdmi

efingdmi

2018-06-25 11:54

reporter   ~48290

Same for me with every survey using 3.12.1
Windows Server 2012 R2 64Bit
MS SQL Server 2016
Apache Apache 2.4.33 (64bit)
PHP 7.2.6 (64bit)

c_schmitz

c_schmitz

2018-06-26 19:01

administrator   ~48306

@dgeils @efingdmi

I cannot reproduce this issue using the latest version.
Can you please update and check? If you still have the issue please attach a small sample survey which we may use to reproduce the issue reliably.

efingdmi

efingdmi

2018-06-29 09:49

reporter   ~48385

Hi all,
I can't export a survey out of 3.13 (the button has no function in IE11 and FF) so I share the survey created in 3.12.1
The error message
"Did not save
An unexpected error has occurred and your responses cannot be saved.
Try to submit again"
is gone in 3.13, but the answers still won't be saved. Participation once has following result:
Two "answers" where no answer is saved (see attachted screenshot)

Dominik



limesurvey_survey_456547.lss (12,559 bytes)
answers.png (17,113 bytes)
answers.png (17,113 bytes)
efingdmi

efingdmi

2018-06-29 10:41

reporter   ~48388

FF 61.0 is working, 60.0.2 not - but cut be a customized error, thats ok :)
.lss attached



limesurvey_survey_595431.lss (12,559 bytes)
c_schmitz

c_schmitz

2018-06-29 10:47

administrator   ~48389

Ok, so I import that survey, activate it and start it once, select anything for the first question. Response saved here, no problem.
Can you do the same with your file and see if the duplicate works?

efingdmi

efingdmi

2018-06-29 14:32

reporter   ~48409

I would, but I can't even import a Survey (see https://bugs.limesurvey.org/view.php?id=13821) ´
Answers don't get saved correctly, Import works not correctly, create user Shows Errors (https://bugs.limesurvey.org/view.php?id=13752), and saving questions Shows Errors (https://bugs.limesurvey.org/view.php?id=13829) - everthing while using mssql

Maybe there is one reason for all theses problems, could it be "php-driver" related? I wonder why you can't reproduce it? And I'm rly happy to help wherever I can.

c_schmitz

c_schmitz

2018-06-29 14:45

administrator   ~48412

How does your freetds.conf look like?

efingdmi

efingdmi

2018-07-13 07:19

reporter   ~48504

Seems to be solved in 3.13.2

Issue History

Date Modified Username Field Change
2018-06-21 14:49 dgeils New Issue
2018-06-21 14:49 dgeils File Added: ApacheConfiguration.html
2018-06-21 14:49 dgeils File Added: DatabaseView.JPG
2018-06-21 14:49 dgeils File Added: DidNotSavePicture.JPG
2018-06-21 15:01 ollehar Note Added: 48264
2018-06-21 15:01 ollehar Status new => feedback
2018-06-21 15:46 DenisChenu Note Added: 48265
2018-06-25 11:54 efingdmi Note Added: 48290
2018-06-26 13:52 LouisGac Assigned To => c_schmitz
2018-06-26 13:52 LouisGac Status feedback => assigned
2018-06-26 19:01 c_schmitz Status assigned => feedback
2018-06-26 19:01 c_schmitz Note Added: 48306
2018-06-29 09:49 efingdmi File Added: limesurvey_survey_456547.lss
2018-06-29 09:49 efingdmi File Added: answers.png
2018-06-29 09:49 efingdmi Note Added: 48385
2018-06-29 10:41 efingdmi File Added: limesurvey_survey_595431.lss
2018-06-29 10:41 efingdmi Note Added: 48388
2018-06-29 10:47 c_schmitz Note Added: 48389
2018-06-29 14:32 efingdmi Note Added: 48409
2018-06-29 14:45 c_schmitz Note Added: 48412
2018-07-13 07:19 efingdmi Note Added: 48504
2019-05-23 09:58 c_schmitz Status feedback => closed
2019-05-23 09:58 c_schmitz Resolution open => fixed
2019-05-23 09:58 c_schmitz Fixed in Version => 3.13.x