View Issue Details

IDProjectCategoryView StatusLast Update
13795Bug reports[All Projects] Theme editorpublic2018-08-07 17:01
ReporterArneDAssigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.12.x 
Target VersionFixed in Version3.13.x 
Summary13795: Custom logo is not saved
Description

A) We are unsure about the problem (if it is a problem in the global design options or in the survey design options): Sometimes the frontend saves a URL of the type [....]/tmp/assert/[...]. But we think this is wrong. This is a path to a temp folder. The file may be deleted. The logo file is existing in the folder but will never displayed in the questionnaire

B) Via the design template options (of a questionnaire) a logo with a relative URL is specified via the advanced settings. As soon as you save the entry it is set to NULL.

Steps To Reproduce

See A) B)

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.12.1+180616
I will donate to the project if issue is resolvedNo
BrowserSafari
Database & DB-VersionMysql 5.19
Server OS (if known)Linux
Webserver software & version (if known)Apache
PHP Version5.56

Relationships

related to 13827 resolvedDenisChenu Feature requests Allow custom logo from Survey not only template 

Activities

DenisChenu

DenisChenu

2018-06-20 11:32

developer   ~48245

I have the same issue :). And since asset can be removed : must have a better solution :)

LouisGac

LouisGac

2018-06-25 10:54

manager   ~48286

Ok, I need more details about how to reproduce.

"This is a path to a temp folder. The file may be deleted. "

It's generated via the asset manager, so if the tmp file is deleted, a new one is created and the path "should" be updated.

DenisChenu

DenisChenu

2018-06-26 16:48

developer   ~48300

@LouisGac : if you save current asset url for picture,

But reset asset version number a lot of time : i think old asset url become invalid (and the not recreated)

And currently : something happen in my test system

  1. Last week i upload a picture
  2. Set this picture in the list, select it
  3. reset asset version number 5 times (in global settings)
  4. this week : my won logo was replaced by default

It's hard to reproduce, because it take times (and TemplateConfig have some auto repair system).

Adding a image with ./files/myfile.png work better :) .

DenisChenu

DenisChenu

2018-07-12 18:15

developer   ~48501

@LouisGac : i can confirm : after some day : assets directory is removed … the no logo



Capture du 2018-07-12 18-13-30.png (192,916 bytes)
LouisGac

LouisGac

2018-07-13 09:02

manager   ~48506

thank you Denis

DenisChenu

DenisChenu

2018-07-13 16:17

developer   ~48510

PS : on forum : seems not exactly the same issue … :/

markusfluer

markusfluer

2018-07-30 17:30

administrator   ~48617

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27724

markusfluer

markusfluer

2018-08-07 17:01

administrator   ~48702

Release 3.14.2+180807

Related Changesets

LimeSurvey: master 4555aaf4

2018-07-30 17:30:01

markusfluer

Details Diff
Fixed issue 13795: Custom logo is not saved Affected Issues
13795
mod - application/models/TemplateConfiguration.php Diff File
mod - themes/survey/bootswatch/options/options.twig Diff File
mod - themes/survey/fruity/options/options.twig Diff File
mod - themes/survey/vanilla/options/options.twig Diff File

Issue History

Date Modified Username Field Change
2018-06-20 10:58 ArneD New Issue
2018-06-20 11:32 DenisChenu Note Added: 48245
2018-06-25 10:24 LouisGac Assigned To => LouisGac
2018-06-25 10:24 LouisGac Status new => assigned
2018-06-25 10:54 LouisGac Note Added: 48286
2018-06-26 16:48 DenisChenu Note Added: 48300
2018-06-29 00:46 DenisChenu Relationship added related to 13827
2018-07-12 18:15 DenisChenu File Added: Capture du 2018-07-12 18-13-30.png
2018-07-12 18:15 DenisChenu Note Added: 48501
2018-07-13 09:02 LouisGac Note Added: 48506
2018-07-13 16:17 DenisChenu Note Added: 48510
2018-07-16 13:27 LouisGac Assigned To LouisGac => markusfluer
2018-07-30 17:30 markusfluer Status assigned => resolved
2018-07-30 17:30 markusfluer Resolution open => fixed
2018-07-30 17:30 markusfluer Fixed in Version => 3.13.x
2018-07-30 17:30 markusfluer Changeset attached => LimeSurvey master 4555aaf4
2018-07-30 17:30 markusfluer Note Added: 48617
2018-08-07 17:01 markusfluer Status resolved => closed
2018-08-07 17:01 markusfluer Note Added: 48702