View Issue Details

IDProjectCategoryView StatusLast Update
13790Bug reports[All Projects] Survey takingpublic2018-06-27 15:29
ReporterTonisOrmissonAssigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.11.x 
Target VersionFixed in Version3.12.x 
Summary13790: End-URL redfirect is not working
Description

See

https://demo.limesurvey.org/index.php?r=admin/survey/sa/view&surveyid=183875

Steps To Reproduce

create a new token
open the token interview
submit
should be redirected to
http://google.com/c/{TOKEN}
instead:
https://demo.limesurvey.org/index.php?r=survey/index&sid=183875

TagsNo tags attached.
Complete LimeSurvey version number (& build) 3.12.1
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version Linux limesurvey-1.limesurvey.org 4.13.0-31-generic
Server OS (if known) Linux limesurvey-1.limesurvey.org 4.13.0-31-generic
Webserver software & version (if known) nginx/1.10.3
PHP Version7.0.30-0ubuntu0.16.04.1

Activities

ollehar

ollehar

2018-06-19 12:33

administrator   ~48215

Can you attach the survey here, please?

TonisOrmisson

TonisOrmisson

2018-06-19 13:44

developer   ~48216

There is a failing example on your live demo

ollehar

ollehar

2018-06-19 14:33

administrator   ~48218

The demo installation is purged periodically. Please attach the survey here instead.

atosspm

atosspm

2018-06-19 15:09

reporter   ~48223

I have the same issue on Chrome & Safari (on Mac) and Chrome (on Windows). It's working fine on Internet Explorer for me. I attached a small demo.



limesurvey_survey_928171.lss (13,044 bytes)
ollehar

ollehar

2018-06-19 15:16

administrator   ~48224

Great, thanks!

Which version of Internet Explorer? OBS: Edge != IE.

holch

holch

2018-06-19 15:37

reporter   ~48225

I have the same issue on Chrome, just tested it. Worked fine with my previous version 3.9.x, I upgraded to 3.12.1 today and it does not work anymore. Here the discussion:
https://www.limesurvey.org/forum/installation-a-update-issues/115573-survey-loops-round-to-start-without-confirming-completion

holch

holch

2018-06-19 15:42

reporter   ~48226

IE 11 works fine
Chrome does redirect to the survey start, not to the respective End URL
Ups, Edge (42.17134.1.0) doesn't even do anything when clicking on next to get into the survey!! Seems to be another bug!

atosspm

atosspm

2018-06-19 15:43

reporter   ~48227

My version numbers are:

On Mac:
Chrome: Version 67.0.3396.87
Safari: Version 11.1.1 (13605.2.8)

Windows:
Internet Explorer: Version: 11.0.9600.18977 (really IE, not Edge)
Chrome: Version 67.0.3396.87

DenisChenu

DenisChenu

2018-06-19 17:45

developer   ~48230

Again : ajax mode issue … deactivate ajax mode : redirect is OK …

TonisOrmisson

TonisOrmisson

2018-06-19 19:57

developer   ~48231

btw: the mantis notification e-mails do not reach me

TonisOrmisson

TonisOrmisson

2018-06-19 20:05

developer   ~48232

Tested with ajax mode disabled and the redirection works, BUT the {TOKEN} is not replaced in the url

mills

mills

2018-06-19 23:51

reporter   ~48236

I'm not clear if this is exactly the same issue, but on submit Edge is not saving survey results (saves an incomplete response with no answers) and loops back to the start. This is without any end URL redirect, on 3.12.1.

Initially reported/discussed here:-
https://www.limesurvey.org/forum/installation-a-update-issues/115573-survey-loops-round-to-start-without-confirming-completion

DenisChenu

DenisChenu

2018-06-20 09:43

developer   ~48239

@mills : here it's about end url redirect.
@TonisOrmisson : Then 2 bug : one with redirect not working + one with {TOKEN} not replaced :) (did you try {TOKEN:TOKEN} or anything in survey ?)

TonisOrmisson

TonisOrmisson

2018-06-20 11:05

developer   ~48240

{TOKEN:TOKEN} works, yes thanks

DenisChenu

DenisChenu

2018-06-20 11:31

developer   ~48244

It's a pleasure ;) (still an issue, but 1st one to fix is no redirect)

markusfluer

markusfluer

2018-06-22 15:41

administrator   ~48276

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27510

DenisChenu

DenisChenu

2018-06-23 13:45

developer   ~48278

Now : redirect can show a white page …
Please : fix in javascript, not in php.

ollehar

ollehar

2018-06-25 10:31

administrator   ~48283

@DenisChenu, this didn't break after you commit "Fixed issue : unable to use Survey::model in command"?

ollehar

ollehar

2018-06-25 11:50

administrator   ~48288

@DenisChenu, also please specify how to reproduce the white-page problem. Thanks.

c_schmitz

c_schmitz

2018-06-27 15:29

administrator   ~48331

Version 3.12.3+180627 released

Related Changesets

LimeSurvey: master 26cfe780

2018-06-22 15:23:40

markusfluer

Details Diff
Fixed issue 13790: End-URL redfirect is not working in AJAX mode Affected Issues
13790
mod - application/helpers/SurveyRuntimeHelper.php Diff File
mod - assets/packages/pjax/min/pjax.combined.min.js Diff File
mod - assets/packages/pjax/min/pjax.min.js Diff File
mod - assets/packages/pjax/pjax.js Diff File
mod - themes/survey/vanilla/scripts/ajaxify.js Diff File

Issue History

Date Modified Username Field Change
2018-06-19 10:43 TonisOrmisson New Issue
2018-06-19 12:33 ollehar Note Added: 48215
2018-06-19 13:44 TonisOrmisson Note Added: 48216
2018-06-19 14:33 ollehar Note Added: 48218
2018-06-19 15:09 atosspm File Added: limesurvey_survey_928171.lss
2018-06-19 15:09 atosspm Note Added: 48223
2018-06-19 15:16 ollehar Note Added: 48224
2018-06-19 15:37 holch Note Added: 48225
2018-06-19 15:42 holch Note Added: 48226
2018-06-19 15:43 atosspm Note Added: 48227
2018-06-19 17:45 DenisChenu Note Added: 48230
2018-06-19 19:57 TonisOrmisson Note Added: 48231
2018-06-19 20:05 TonisOrmisson Note Added: 48232
2018-06-19 23:51 mills Note Added: 48236
2018-06-20 09:43 DenisChenu Note Added: 48239
2018-06-20 11:05 TonisOrmisson Note Added: 48240
2018-06-20 11:31 DenisChenu Note Added: 48244
2018-06-22 15:41 markusfluer Changeset attached => LimeSurvey master 26cfe780
2018-06-22 15:41 markusfluer Note Added: 48276
2018-06-22 15:41 markusfluer Assigned To => markusfluer
2018-06-22 15:41 markusfluer Resolution open => fixed
2018-06-22 16:35 markusfluer Status new => resolved
2018-06-22 16:35 markusfluer Fixed in Version => 3.12.x
2018-06-23 13:45 DenisChenu Note Added: 48278
2018-06-25 10:31 ollehar Note Added: 48283
2018-06-25 11:50 ollehar Note Added: 48288
2018-06-27 15:29 c_schmitz Note Added: 48331
2018-06-27 15:29 c_schmitz Status resolved => closed