View Issue Details

IDProjectCategoryView StatusLast Update
13736Bug reports[All Projects] Survey takingpublic2018-06-15 14:27
ReporterDenisChenuAssigned ToDenisChenu 
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.8.x 
Target VersionFixed in Version3.8.x 
Summary13736: No javascript : bad date not saved but error not shown
Description

If you deactivate javascript and enter bad value in date : this allow to move to next, db is empty and no errors are shown.

Steps To Reproduce

Import included survey, activate,
deactivate javascript, (midori is great for this)
test

Additional Information

I think we fix it before ?
We try to fix : https://github.com/LimeSurvey/LimeSurvey/blob/ca844d498966355614ac446b48306b0df34d2f8c/application/helpers/expressions/em_manager_helper.php#L8845

But broken currently

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.8.1 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant (mysql)
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 12721 closeddominikvitt Date shown in error is not date entered by user 

Activities

DenisChenu

DenisChenu

2018-06-02 15:26

developer   ~47946

Think we can use invalidAnswerString

DenisChenu

DenisChenu

2018-06-02 15:50

developer   ~47947

Still error with dropdown date : have 2 solution :

  • Show text input for nojs only
  • Test dropdown if value is empty
DenisChenu

DenisChenu

2018-06-02 15:54

developer   ~47949

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27296

DenisChenu

DenisChenu

2018-06-02 16:05

developer   ~47950

Choose the quiquest way and don't want to add another test in EM …

DenisChenu

DenisChenu

2018-06-02 16:22

developer   ~47951

Test wait getStateKeyPrefix, but it don't seems to be shown : it's in session but not in real situation. @olle : i look and try to fix the test next week :)

ollehar

ollehar

2018-06-05 10:33

administrator   ~47985

Fix committed to develop branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27320

c_schmitz

c_schmitz

2018-06-15 14:27

administrator   ~48134

New version released.

Related Changesets

LimeSurvey: master d490dcd6

2018-06-02 15:54:28

DenisChenu

Details Diff
Fixed issue 13736: No javascript : bad date not saved but error not shown
Dev: we must always control in PHP, js is an user help, not a dev control …
Affected Issues
13736
mod - application/helpers/expressions/em_manager_helper.php Diff File

LimeSurvey: develop dfe3f66e

2018-06-02 15:54:28

DenisChenu


Committer: ollehar Details Diff
Fixed issue 13736: No javascript : bad date not saved but error not shown
Dev: we must always control in PHP, js is an user help, not a dev control …
Affected Issues
13736
mod - .travis.yml Diff File
mod - application/helpers/expressions/em_manager_helper.php Diff File

LimeSurvey: master 7620482a

2018-06-02 16:03:39

DenisChenu

Details Diff
Fixed issue : Unable to answer to dropdown date without js
Dev: use near same html than selector
Dev: adding ls-js-hidden and ls-no-js-hidden where needed
Affected Issues
13736
mod - application/views/survey/questions/answer/date/dropdown/answer.twig Diff File

Issue History

Date Modified Username Field Change
2018-06-02 15:12 DenisChenu New Issue
2018-06-02 15:26 DenisChenu Note Added: 47946
2018-06-02 15:49 DenisChenu Assigned To => DenisChenu
2018-06-02 15:49 DenisChenu Status new => assigned
2018-06-02 15:50 DenisChenu Note Added: 47947
2018-06-02 15:52 DenisChenu Relationship added related to 12721
2018-06-02 15:54 DenisChenu Changeset attached => LimeSurvey master d490dcd6
2018-06-02 15:54 DenisChenu Note Added: 47949
2018-06-02 15:54 DenisChenu Resolution open => fixed
2018-06-02 16:04 DenisChenu Changeset attached => LimeSurvey master 7620482a
2018-06-02 16:04 DenisChenu Status assigned => resolved
2018-06-02 16:04 DenisChenu Fixed in Version => 3.8.x
2018-06-02 16:05 DenisChenu Note Added: 47950
2018-06-02 16:22 DenisChenu Note Added: 47951
2018-06-05 10:33 ollehar Changeset attached => LimeSurvey develop dfe3f66e
2018-06-05 10:33 ollehar Note Added: 47985
2018-06-15 14:27 c_schmitz Note Added: 48134
2018-06-15 14:27 c_schmitz Status resolved => closed