View Issue Details

IDProjectCategoryView StatusLast Update
13696Bug reports[All Projects] Survey takingpublic2018-05-22 15:05
ReporterHan Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.7.x 
Target VersionFixed in Version3.7.x 
Summary13696: Error: Duplicate attributes accesskey / data-confirmedby.
Description

When I preview a survey or do the survey i see HTML-warnings.

Additional Information

In the generated code for the clearrall-button and the previous-button the attributes data-confirmedby / .accesskey are used twice, and not only once.

button id="ls-button-previous" type="submit" value="moveprev" name="move" accesskey="p" accesskey="n" class=" ls-move-btn ls-move-previous-btn btn btn-lg btn-default

button type="submit" value="clearall" name="move" data-confirmedby="confirm-clearall" class="ls-clearaction ls-clearall btn btn-link" data-confirmedby="confirm-clearall" title

TagsNo tags attached.
Complete LimeSurvey version number (& build)Versie 3.7.3+180516
I will donate to the project if issue is resolvedNo
BrowserFirefox
Database & DB-VersionMySQL 5.7.14
Server OS (if known)Windows10
Webserver software & version (if known)apache
PHP Version5.6.25

Activities

DenisChenu

DenisChenu

2018-05-19 10:30

developer   ~47692

I think acceskey must be template related (and easily update by admin via gui) but data-confirmedby must be core related (or config.xml related ?)

DenisChenu

DenisChenu

2018-05-19 11:00

developer   ~47693

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27183

DenisChenu

DenisChenu

2018-05-19 11:04

developer   ~47695

Not same fix :) . One to core and one to template.

Thanks for reporting

Related Changesets

LimeSurvey: master 1c780528

2018-05-19 10:43:11

DenisChenu

Details Diff
Fixed issue 13696: Error: Duplicate attributes data-confirmedby for clear all button
Dev: come from core since js included in survey.js
Affected Issues
13696
mod - themes/survey/vanilla/views/subviews/navigation/clearall_buttons.twig Diff File

LimeSurvey: master a84d76d2

2018-05-19 11:00:41

DenisChenu

Details Diff
Fixed issue 13696: Error: Duplicate attributes accesskey for prev button
Dev: move accesskey to template, in twig (easy update by admin user)
Dev: this accesskey are english related …
Dev: use same accesskey for next and submit (it's more same action)
Affected Issues
13696
mod - application/models/TemplateConfig.php Diff File
mod - themes/survey/vanilla/views/subviews/content/quotas.twig Diff File
mod - themes/survey/vanilla/views/subviews/navigation/navigator.twig Diff File
mod - themes/survey/vanilla/views/subviews/navigation/save_buttons.twig Diff File

Issue History

Date Modified Username Field Change
2018-05-18 17:36 Han New Issue
2018-05-19 10:30 DenisChenu Note Added: 47692
2018-05-19 10:32 DenisChenu Assigned To => DenisChenu
2018-05-19 10:32 DenisChenu Status new => assigned
2018-05-19 11:00 DenisChenu Changeset attached => LimeSurvey master 1c780528
2018-05-19 11:00 DenisChenu Changeset attached => LimeSurvey master a84d76d2
2018-05-19 11:00 DenisChenu Note Added: 47693
2018-05-19 11:00 DenisChenu Resolution open => fixed
2018-05-19 11:04 DenisChenu Status assigned => resolved
2018-05-19 11:04 DenisChenu Fixed in Version => 3.7.x
2018-05-19 11:04 DenisChenu Note Added: 47695
2018-05-22 15:05 ollehar Status resolved => closed