View Issue Details

IDProjectCategoryView StatusLast Update
13684Feature requestsConditionspublic2020-05-07 16:58
ReporterDoberdan Assigned To 
PrioritynormalSeverityfeature 
Status acknowledgedResolutionopen 
Summary13684: If the exclusive option is selected, the excluded options default to "missing" instead of "no"
Description

If you choose the question type "multiple options" and add an exclusive option (e.g. ask "Which brands do you know?", show 5 brands and also the option "don't know any of them") , the datasets of panelists who selected the exclusive option contain missing values for the other options instead of the value "N" or "not selected".

Steps To Reproduce

Create a multiple options question.
Create two options.
Make on the exclusive option.
Activate the survey.
Answer the survey, selecting the exclusive option.
Download the survey data.
Data for the non-exclusive option will be missing.

TagsNo tags attached.

Relationships

parent of 16203 resolvedDenisChenu Bug reports Multiple choice questions with "other" optionactivated: Setting an answer as "exclusive" and selecting it gives an error message 
parent of 16226 resolvedDenisChenu Bug reports Inavlid count on multi with exlude : broke logic 

Activities

Doberdan

Doberdan

2018-05-17 14:25

reporter  

ollehar

ollehar

2018-05-17 14:29

administrator   ~47662

Just FYI, when implemented it will be added to LS 3.x, not 2.73.

ollehar

ollehar

2018-05-17 14:31

administrator   ~47663

Last edited: 2020-05-05 14:47

I propose a solution where it will be possible to configure which default answer will be recorded for the non-chosen answer options.

ollehar

ollehar

2018-05-18 13:20

administrator   ~47682

Last edited: 2020-05-05 14:47

Also, for the future, don't attach an exported question but the whole survey. It's not possible to import a question unless the primary language of the survey is correct.

ollehar

ollehar

2018-05-18 14:01

administrator   ~47684

Last edited: 2020-05-05 14:47

@Doberdan I just saw that there's some logic in the export code that skips non-selected answers in exclusive question. Would it be enough for you that you can choose to export empty values for these subquestions, or do you also need the value 'N' to be exported? That is, an empty value is not enough.

ollehar

ollehar

2018-05-18 14:12

administrator   ~47685

Last edited: 2020-05-05 14:47

And Daniel, did you try this one (see pic)?

Selection_447.png (33,232 bytes)   
Selection_447.png (33,232 bytes)   
p_teichmann

p_teichmann

2019-07-17 13:46

administrator   ~52911

Last edited: 2020-05-05 14:47

fixed in LS 4 https://github.com/LimeSurvey/LimeSurvey/commit/30a85bb9791d4650653276618a50e3fb1424f911

DenisChenu

DenisChenu

2020-04-29 19:52

developer   ~57474

Last edited: 2020-05-05 14:47

There is 2 issue here

  1. Logic : it muts be NULL value no reason to change this, or this must be defaumlt to null (if adding a settings)
  2. 'N' never exist for checkbox : only 3 options : 'Y', '' or null
DenisChenu

DenisChenu

2020-04-29 20:06

developer   ~57475

Last edited: 2020-05-05 14:47

My opinion : this really need to be reverted/reviewed
https://github.com/LimeSurvey/LimeSurvey/pull/1413

It's the case in 2.05 and surely before.

If need a solution : need a cleaner solution with an option "Set excluded option to " Null/empty

DenisChenu

DenisChenu

2020-05-05 09:42

developer   ~57530

Last edited: 2020-05-05 14:47

I confirm the issue with actual solution :

If an answer was filtered but have exclude : answer are set to N : it must be NULL

See the included survey

p_teichmann

p_teichmann

2020-05-05 18:34

administrator   ~57557

Okay i have tested it as well and yes you can revert it however it should be fixed properly.

In the attached file you can see that the second line in the marked area is empty when nothing is selected. However when you select the exclusive option, in this case SQ03, all other fields should be empty as well and not null.

multiple choice.png (43,575 bytes)   
multiple choice.png (43,575 bytes)   
DenisChenu

DenisChenu

2020-05-05 19:18

developer   ~57559

In the attached file you can see that the second line in the marked area is empty when nothing is selected. However when you select the exclusive option, in this case SQ03, all other fields should be empty as well and not null.

The should are a point of view :).
In my opinion : must have a completely new attribute (exclude_set_empty) or an attribute using current exclude.

The worst part are using 'N'

And here : you manage it for M and Q, but not for ABCEFPK : https://manual.limesurvey.org/Question_type_-_Array#Exclusive_option_.28exclusive_option.29 for array for example.

DenisChenu

DenisChenu

2020-05-05 19:21

developer   ~57560

And about «bas option since year»

exclude_all_others_auto : this one can set Y to all other (relevant) question … i think it's the best option.

To have a clean way to set : we need a clean way to set value in Expression Manager.

My objective : is to have it in an external plugin … less code in core : more easy to update and fix.

DenisChenu

DenisChenu

2020-05-07 16:58

developer   ~57616

OK,

Another issue with current fix : ordered dependant …

Peek 07-05-2020 16-57.gif (120,920 bytes)

Issue History

Date Modified Username Field Change
2018-05-17 14:25 Doberdan New Issue
2018-05-17 14:25 Doberdan File Added: limesurvey_question_265104.lsq
2018-05-17 14:29 ollehar Note Added: 47662
2018-05-17 14:30 ollehar Steps to Reproduce Updated View Revisions
2018-05-17 14:31 ollehar Note Added: 47663
2018-05-17 14:31 ollehar Assigned To => ollehar
2018-05-17 14:31 ollehar Status new => assigned
2018-05-18 13:20 ollehar Note Added: 47682
2018-05-18 14:01 ollehar Note Added: 47684
2018-05-18 14:12 ollehar File Added: Selection_447.png
2018-05-18 14:12 ollehar Note Added: 47685
2018-05-18 14:13 ollehar Status assigned => feedback
2019-07-17 13:46 p_teichmann Assigned To ollehar => p_teichmann
2019-07-17 13:46 p_teichmann Status feedback => resolved
2019-07-17 13:46 p_teichmann Resolution open => fixed
2019-07-17 13:46 p_teichmann Fixed in Version => 4.0.0-RC2
2019-07-17 13:46 p_teichmann Note Added: 52911
2020-03-09 15:36 c_schmitz Status resolved => closed
2020-04-29 19:52 DenisChenu Status closed => new
2020-04-29 19:52 DenisChenu Resolution fixed => reopened
2020-04-29 19:52 DenisChenu Note Added: 57474
2020-04-29 19:52 DenisChenu Status new => feedback
2020-04-29 20:02 DenisChenu Relationship added parent of 16203
2020-04-29 20:06 DenisChenu Note Added: 57475
2020-05-05 09:42 DenisChenu Note Added: 57530
2020-05-05 09:42 DenisChenu File Added: survey_archive_624189.lsa
2020-05-05 10:12 DenisChenu Relationship added parent of 16226
2020-05-05 14:47 cdorin Assigned To p_teichmann => cdorin
2020-05-05 14:47 cdorin Priority none => high
2020-05-05 18:34 p_teichmann Note Added: 57557
2020-05-05 18:34 p_teichmann File Added: multiple choice.png
2020-05-05 19:18 DenisChenu Note Added: 57559
2020-05-05 19:21 DenisChenu Note Added: 57560
2020-05-07 16:21 DenisChenu Assigned To cdorin => DenisChenu
2020-05-07 16:22 DenisChenu Assigned To DenisChenu =>
2020-05-07 16:22 DenisChenu Status feedback => acknowledged
2020-05-07 16:47 DenisChenu Project Bug reports => Feature requests
2020-05-07 16:48 DenisChenu Priority high => normal
2020-05-07 16:48 DenisChenu Severity @50@ => feature
2020-05-07 16:48 DenisChenu Resolution reopened => open
2020-05-07 16:48 DenisChenu Product Version 3.0.x =>
2020-05-07 16:48 DenisChenu Fixed in Version 4.0.0-RC2 =>
2020-05-07 16:58 DenisChenu Note Added: 57616
2020-05-07 16:58 DenisChenu File Added: survey_archive_624189-2.lsa
2020-05-07 16:58 DenisChenu File Added: Peek 07-05-2020 16-57.gif