View Issue Details

IDProjectCategoryView StatusLast Update
13679Bug reports[All Projects] Theme editorpublic2018-06-15 14:27
ReporterduvemysterAssigned ToLouisGac 
PriorityimmediateSeveritymajor 
Status closedResolutionnot fixable 
Product Version3.7.x 
Target VersionFixed in Version 
Summary13679: 'Copy to local theme and save' sometimes saves without copying
Description

While a few of the file do copy to local theme, most of them don't. Following are at least some of the ones where use results in saving changes to vanilla instead of changes to the extended theme:

  • head.twig
  • custom_header.twig
  • nav_bar.twig
  • progress_bar.twig
  • welcome.twig
  • warnings.twig
  • no_js_alert.twig
  • privacy.twig
  • language_changer_first_page.twig
  • theme.js
  • custom.js
Steps To Reproduce
  1. Extend a theme. (Bootwatch was used in this case.)
  2. Change to one of the files listed above.
  3. Click 'Copy to local theme and save' and note that it does not copy, instead saving to vanilla, thus impacting all themes that inherit the file if a change was also made.
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.7.3+180516
I will donate to the project if issue is resolvedNo
BrowserFirefox Qantum 60.0 (64-bit)
Database & DB-VersionMaridb with Mysql client api 5.5.58
Server OS (if known)Linux
Webserver software & version (if known)Apache 2.0
PHP VersionPHP Version 5.6.30-0+deb8u1

Activities

duvemyster

duvemyster

2018-05-16 22:00

reporter   ~47657

Following are some additional screen part files that are saving to vanilla instead of copying to a local theme:

Assessments: assessments.twig

Registration:

  • register_error.twig
  • register_head.twig
  • register_message.twig
  • register_success.twig
  • required.twig

Print Answers:

  • printanswers_question.twig
  • printanswers_table.twig

Navigation:

  • ajax_indicator.twig
  • clearall_links.twig
  • language_changer_top_menu.twig
  • navigator.twig
  • question_index_menu.twig
  • save_links.twig
DenisChenu

DenisChenu

2018-05-18 09:41

developer   ~47670

Last edited: 2018-05-18 10:02

View 2 revisions

Please : don't read this : i made an error when try to understand the issue …

When copying a survey : twig must NOT be copied :

The principle are :

  • You extend "Bootwatch" to "Bootwatch_extend"
  • You update ajax_indicator.twig in "Bootwatch_extend"
  • You extend "bootstrap_extend" to "Bootwatch_final"
  • You update clearall_links.twig in "Bootwatch_final"

For survey (and Template edition) When you get a twig file : system (code) MUST find it :

  1. In Bootwatch_final
  2. If not exist in Bootwatch_extend
  3. If not exist in Bootwatch
  4. If not exist in Vanilla

Because : if you update again ajax_indicator.twig in Bootwatch_extend : this must be applied to Bootwatch_final

Here:
for clearall_links.twig it take from final
for ajax_indicator from extend
for question_text_container from Bootwatch
for question from Vanilla

(there are a lack of "core" part)

DenisChenu

DenisChenu

2018-05-18 09:43

developer   ~47671

Oups … maybe i didn't understand the issue : the update was done on Vanilla file 8| big issue !

DenisChenu

DenisChenu

2018-05-18 10:00

developer   ~47673

Trying to reproduce exactly the issue : debug set to 2 : i have a php warning
With debug=0 : reproduce the issue
We have the explanation



PHP warning.html (22,032 bytes)
DenisChenu

DenisChenu

2018-05-28 17:42

developer   ~47880

Seems to be fixed on mast git version. @duvemyster : can you confirm ?

LouisGac

LouisGac

2018-05-28 17:46

manager   ~47881

Probably fixed with another commit.
If you still face the bug, let us know.

c_schmitz

c_schmitz

2018-06-15 14:27

administrator   ~48157

New version released.

Issue History

Date Modified Username Field Change
2018-05-16 21:05 duvemyster New Issue
2018-05-16 22:00 duvemyster Note Added: 47657
2018-05-18 09:41 DenisChenu Note Added: 47670
2018-05-18 09:43 DenisChenu Note Added: 47671
2018-05-18 10:00 DenisChenu File Added: PHP warning.html
2018-05-18 10:00 DenisChenu File Added: Capture du 2018-05-18 10-00-31.png
2018-05-18 10:00 DenisChenu Note Added: 47673
2018-05-18 10:01 DenisChenu Assigned To => LouisGac
2018-05-18 10:01 DenisChenu Status new => assigned
2018-05-18 10:02 DenisChenu Note Edited: 47670 View Revisions
2018-05-23 12:56 LouisGac Priority none => immediate
2018-05-23 12:56 LouisGac Sticky Issue No => Yes
2018-05-28 17:42 DenisChenu Note Added: 47880
2018-05-28 17:46 LouisGac Status assigned => resolved
2018-05-28 17:46 LouisGac Resolution open => not fixable
2018-05-28 17:46 LouisGac Note Added: 47881
2018-05-28 17:46 LouisGac Sticky Issue Yes => No
2018-06-15 14:27 c_schmitz Note Added: 48157
2018-06-15 14:27 c_schmitz Status resolved => closed