View Issue Details

IDProjectCategoryView StatusLast Update
13646Bug reports[All Projects] LimeSurvey Websitepublic2018-06-28 10:57
ReporterTinummAssigned Toc_schmitz 
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.7.x 
Target VersionFixed in Version3.12.x 
Summary13646: Error after Database Query MSSQL
Description

After succesfull installation of LimeSurvey a random database input results in an internal Servererror.

Steps To Reproduce
  1. Start LimeSurvey Webinterface

  2. try to change admin password
    2.1 succesfully enter "Current password:"
    2.2 succesfully enter "New password:"
    2.3 succesfully enter "Repeat new password:"

  3. when enter "Save" / "Save and close" no changes will be made and an wild error appears.
    translated:
    CDbCommand failed to execute the SQL statement: SQLSTATE [42000]: [Microsoft] [ODBC Driver 17 for SQL Server] [SQL Server] The implicit conversion of the char data type to
    binary is not allowed. Use the CONVERT function to execute this query.

  4. Same Error appears when trying to change the personal language setting

  5. Same Error appears when trying to change "email" or "full name"

Seems like it's not important what kind of data i want to change - the error stays

Additional Information

+Microsoft ODBC Driver 13 for SQL Server (13.1.4414.46)
+Microsoft ODBC Driver 17 for SQL Server (17.1.0.1)
+Microsoft Visual C++ 2008 Redistributable x64
+Microsoft Visual C++ 2008 Redistributable x86
+Microsoft Visual C++ 2013 Redistributable x64
+Microsoft Visual C++ 2017 Redistributable x64
+Microsoft Visual C++ 2017 Redistributable x86
+PHP extension "php_pdo_sqlsrv_72_nts_x86.dll" & "php_sqlsrv_72_nts_x86.dll"

Tagserror!, mssql
Complete LimeSurvey version number (& build)limesurvey3.7.1+180424 (same with "limesurvey3.7.0+180418")
I will donate to the project if issue is resolvedNo
BrowserMozilla Firefox 59.0.2 / Internet Explorer 11.1480
Database & DB-VersionMSSSQL 14.0.3022.28 (2017)
Server OS (if known)Windows Server 2016 x64 Standard
Webserver software & version (if known)IIS 10
PHP VersionPHP 7.2.5 x86 and attempted x64

Activities

Tinumm

Tinumm

2018-05-03 14:31

reporter  

application.log (5,315 bytes)
LimeSurvey_error_IE10.jpg (122,647 bytes)
Tinumm

Tinumm

2018-06-27 15:02

reporter   ~48324

push

c_schmitz

c_schmitz

2018-06-27 15:26

administrator   ~48325

IMHO this issue has been fixed in the latest version.
Please update and let us know if this issue exists in the latest version.

Tinumm

Tinumm

2018-06-28 10:34

reporter   ~48354

hey there,
i can confirm that the error is solved.
Installed version "limesurvey3.12.3+180627" and everything worked fine.

Thanks alot, c_schmitz.

Issue History

Date Modified Username Field Change
2018-05-03 14:31 Tinumm New Issue
2018-05-03 14:31 Tinumm Status new => assigned
2018-05-03 14:31 Tinumm Assigned To => c_schmitz
2018-05-03 14:31 Tinumm File Added: application.log
2018-05-03 14:31 Tinumm File Added: LimeSurvey_error_IE10.jpg
2018-05-03 14:33 Tinumm Tag Attached: mssql
2018-05-03 14:33 Tinumm Tag Attached: error!
2018-06-27 15:02 Tinumm Note Added: 48324
2018-06-27 15:26 c_schmitz Status assigned => feedback
2018-06-27 15:26 c_schmitz Note Added: 48325
2018-06-28 10:34 Tinumm Note Added: 48354
2018-06-28 10:34 Tinumm Status feedback => assigned
2018-06-28 10:57 c_schmitz Status assigned => closed
2018-06-28 10:57 c_schmitz Resolution open => fixed
2018-06-28 10:57 c_schmitz Fixed in Version => 3.12.x