View Issue Details

IDProjectCategoryView StatusLast Update
13631Bug reports[All Projects] Installationpublic2019-05-21 18:52
Reporterollehar Assigned Toc_schmitz  
PrioritynoneSeveritycrash 
Status closedResolutionfixed 
Product Version4.0.0dev 
Target Version4.0.0devFixed in Version4.0.0-beta 
Summary13631: alterColumn does not work with type "pk" in postgres
Description

Offensive line: 2233 in updatedb_helper.php, etc.

Steps To Reproduce
  1. Check out master, install on postgres.
  2. Check out develop, reload to do database upgrade.
  3. Error.
Additional Information

t02=# ALTER TABLE "lime_questions" ALTER COLUMN "qid" TYPE serial;
ERROR: type "serial" does not exist

Function alterColumn() need to be updated to check for type "pk".

TagsNo tags attached.
Complete LimeSurvey version number (& build)develop
I will donate to the project if issue is resolvedNo
Browser-
Database & DB-Versionpostgres
Server OS (if known)-
Webserver software & version (if known)-
PHP Version-

Activities

DenisChenu

DenisChenu

2018-04-25 08:21

developer   ~47514

@olle : do you want i test on pg9 ?

ollehar

ollehar

2018-04-26 16:17

administrator   ~47543

@DenisChenu, if you have time, sure, would be good.

dominikvitt

dominikvitt

2019-05-21 18:52

developer   ~52024

@c_schmitz: No error message on the latest develop version, so it looks like it is fixed correctly.

Issue History

Date Modified Username Field Change
2018-04-24 14:40 ollehar New Issue
2018-04-24 14:40 ollehar Status new => assigned
2018-04-24 14:40 ollehar Assigned To => c_schmitz
2018-04-25 08:21 DenisChenu Note Added: 47514
2018-04-26 16:17 ollehar Note Added: 47543
2019-05-21 17:10 c_schmitz Status assigned => closed
2019-05-21 17:10 c_schmitz Resolution open => fixed
2019-05-21 17:10 c_schmitz Fixed in Version => 4.0.0-beta
2019-05-21 18:52 dominikvitt Note Added: 52024