View Issue Details

IDProjectCategoryView StatusLast Update
13626Bug reports[All Projects] ComfortUpdatepublic2019-05-21 17:12
ReporterDenisChenu Assigned Toc_schmitz  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.0.0dev 
Target VersionFixed in Version4.0.0-beta 
Summary13626: Unable to update (Integrity constraint violation: 1062 Duplicate entry)
Description

When updating receive (from 3.73 version)

An non-recoverable error happened during the update. Error details:

CDbCommand failed to execute the SQL statement: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry '1000--0-0' for key 'PRIMARY'

File updatedb_helper.php, line 2325.

Steps To Reproduce

Import in your DB sql attached
OR
have a multilingual question with default value (short text here)

Additional Information

We don't have a defaultvalues_I10n then : …

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionmysql 5.something
Server OS (if known)debian7+dotdeb (i know, must update)
Webserver software & version (if known)apache2
PHP VersionPHP5.6

Relationships

related to 13603 closedLouisGac Importing survey : PHP Notice 

Activities

DenisChenu

DenisChenu

2018-04-23 19:19

developer   ~47497

After fixing issue : CDbCommand failed to execute the SQL statement: SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'limeliste_question_l10ns' already exists

Seems transaction and create table didn't work …

DenisChenu

DenisChenu

2018-04-23 19:19

developer   ~47498

@LouisGac : not ComfortUpdate … update directly

DenisChenu

DenisChenu

2018-04-24 17:03

developer   ~47513

1st issue : https://github.com/LimeSurvey/LimeSurvey/blob/bdcf3850a1a07602c9eb294a2c7551e267172932/application/helpers/update/updatedb_helper.php#L2325

But the issue is table are created https://github.com/LimeSurvey/LimeSurvey/blob/bdcf3850a1a07602c9eb294a2c7551e267172932/application/helpers/update/updatedb_helper.php#L2225
even if https://github.com/LimeSurvey/LimeSurvey/blob/bdcf3850a1a07602c9eb294a2c7551e267172932/application/helpers/update/updatedb_helper.php#L2329 didn't happen

LouisGac

LouisGac

2018-05-16 12:56

manager   ~47630

is it still a bug?

c_schmitz

c_schmitz

2019-05-21 17:12

administrator   ~52019

Should be resolved

Issue History

Date Modified Username Field Change
2018-04-23 19:16 DenisChenu New Issue
2018-04-23 19:16 DenisChenu Status new => assigned
2018-04-23 19:16 DenisChenu Assigned To => LouisGac
2018-04-23 19:19 DenisChenu Note Added: 47497
2018-04-23 19:19 DenisChenu Note Added: 47498
2018-04-24 16:47 DenisChenu Relationship added related to 13603
2018-04-24 16:47 DenisChenu Description Updated View Revisions
2018-04-24 16:59 DenisChenu Database & DB-Version not relevant => mysql 5.something
2018-04-24 16:59 DenisChenu Operating System (Server) not relevant => debian7+dotdeb (i know, must update)
2018-04-24 16:59 DenisChenu Webserver software & version not relevant => apache2
2018-04-24 16:59 DenisChenu PHP Version not relevant => PHP5.6
2018-04-24 17:03 DenisChenu Note Added: 47513
2018-04-24 17:07 LouisGac Assigned To LouisGac => c_schmitz
2018-05-16 12:56 LouisGac Status assigned => feedback
2018-05-16 12:56 LouisGac Note Added: 47630
2019-05-21 17:12 c_schmitz Status feedback => closed
2019-05-21 17:12 c_schmitz Resolution open => fixed
2019-05-21 17:12 c_schmitz Fixed in Version => 4.0.0-beta
2019-05-21 17:12 c_schmitz Note Added: 52019