View Issue Details

IDProjectCategoryView StatusLast Update
13552Bug reports[All Projects] Otherpublic2019-01-30 14:12
ReporterfbreiAssigned Tomarkusfluer 
PriorityurgentSeveritymajor 
Status closedResolutionreopened 
Product Version3.3.x 
Target VersionFixed in Version3.14.x 
Summary13552: Beginner tour not available without superadmin permission
Description

Survey admins are not able to take the beginner tour when they do not have the superadmin permission. The menu entry 'tutorials' is visible, but when you click on it you only see a white bar.

The tour that starts when you first log in or did not create any survey yet works though.

I asked the forum first and were told to report it here. I found the issue in version 3.5.4 (the initial version I installed) and it remained after an update to 3.6.0.

Steps To Reproduce

Choose any survey admin, grant him an arbitrary combination of permissions except being a superadmin. Then click on 'Tutorials' to see that the entry is missing.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.6.0+180328
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version5.5.56-MariaDB
Server OS (if known)FreeBSD 11.1-RELEASE-p8
Webserver software & version (if known)Apache 2.4.29
PHP Version7.2.3

Relationships

related to 13667 feedbackmarkusfluer Beginner Tutorial only available to SuperAdmin 

Activities

markusfluer

markusfluer

2018-04-05 11:36

administrator   ~47338

Currently it is expected behaviour to have only survey administrators to see the tour.
It is a bug, that it is shown to all users.

fbrei

fbrei

2018-04-05 13:23

reporter   ~47339

Hi markus, thanks for your reply.

[Currently it is expected behaviour to have only survey administrators to see the tour.]
Don't you mean super administrators? Because if survey administrators would see the tour, I wouldn't have filed this report :)

[It is a bug, that it is shown to all users.]
Do you mean the menu item 'Tutorials'?

So what I understand is that no one but super admins should see that menu item and it will be removed for anyone else in a future release?

markusfluer

markusfluer

2018-04-05 13:27

administrator   ~47340

Sorry I meant super administrators.

I meant that the tutorial is also schown to users that have not yet created s survey.
That shouldn't be.

The menu should stay there, because in the coming dev it will be more of an extension menu and Tutorials will be a part of that.
Also in the next major you will be able to create your own tutorials, so this is more or less an in beetween step.

fbrei

fbrei

2018-04-05 13:46

reporter   ~47342

Ok I see.

Is there a way to start the survey tutorial 'on demand' as a survey admin? I'm thinking about users who used Limesurvey for a while, then took a longer break and now need a quick refresher on how things work.

Aside from that you can close this issue if you want, I got all the information I need now :)

DenisChenu

DenisChenu

2018-04-06 08:48

developer   ~47352

Why not show the tutorials for user with Survey/create Permission ?

markusfluer

markusfluer

2018-04-09 12:49

administrator   ~47366

I will check to activate the tutorial for survey create permission.

markusfluer

markusfluer

2018-04-09 13:34

administrator   ~47367

The Basic tutorial should be available for anyone having permission survey/create

c_schmitz

c_schmitz

2018-05-25 11:30

administrator   ~47850

Version 3.8.1+180524 released

Mazi

Mazi

2018-06-05 16:03

partner   ~47992

At Version 3.8.2+180529 there is still (or again) an issue with calling the tour from the menu. The error I see at console is:
/admin/tutorial/sa/triggerfinished/tid/firstStartTour:1
Failed to load resource: the server responded with a status of 500 (Internal Server Error)

John_K

John_K

2018-06-27 22:06

reporter   ~48351

Hi LS Team,
I am now on LS 3.12.1 & Non-admin Users (with create survey permission) still cannot launch/start the tutoril tour, on my company installation.

If U want to test/check this out, go to(https://demo.limesurvey.org/index.php?r=admin/authentication/sa/login)
I have today, created a survey as a Non-Admin user 'J98007' with create survey permission. The SurveyID#112597: BeginnerTour(Tutorial)NotWorkingForNon-AdminUsersWith_CreateSurveyPermissions.

However when signed on as 'J98007', this user is not able to launch the BeginnerTour Tutorial, even though user 'J98007' can & did create a survey. Check this out or create one ur own to reproduce.
(PW=LSj98007)
Thanks
JK

michaelp

michaelp

2018-09-06 12:26

reporter   ~48984

Beginner tour still doesn't work for survey admins with version 3.14.8+180829.
It shows the first modal "Welcome to LimeSurvey" but clicking the "Next" button results in a 404 error requesting "/admin/tutorial/sa/triggerfinished/tid/firstStartTour" (logged in browser debug console)

michaelp

michaelp

2018-09-07 16:10

reporter   ~48989

Solved it for 3.14.8+180829: you have to enable the "Create survey" in "Home page settings" for user group "Everybody" or a group where the user is in.

c_schmitz

c_schmitz

2018-09-07 16:39

administrator   ~48990

But that's the default, isn't it?

markusfluer

markusfluer

2018-09-26 15:38

administrator   ~49142

The setting is expected to at least expect permission survey create to be available.
This is the case.

ritapas

ritapas

2019-01-30 12:17

reporter   ~50340

Hello, I think that the proposed solution could be improved. We have users with different roles in the same group and we wouldn't want to enable the "Create survey" action for each of them.
I suggest to create a setting for that in the Home page settings page.

DenisChenu

DenisChenu

2019-01-30 13:13

developer   ~50341

I don't understand : «we wouldn't want to enable the "Create survey" action» => if they can't create survey : no reason to show current begoinner tour since it does only Create survey (and need user allowed create survey).

ritapas

ritapas

2019-01-30 14:07

reporter   ~50343

Hi, indeed I wish the tutorial section will get expanded to include more topics which don't require the create survey action.
I would also be glad to help if I had the skills.

DenisChenu

DenisChenu

2019-01-30 14:12

developer   ~50344

Yes, but when we have an new tutorials for "Theme managing" foir example,

Test done are updated to Survey/create OR Theme/edit

Since currently there are no way to add tutorial without updating LimeSurey core : no need to add a system.

Issue History

Date Modified Username Field Change
2018-03-29 14:14 fbrei New Issue
2018-04-05 11:36 markusfluer Note Added: 47338
2018-04-05 13:23 fbrei Note Added: 47339
2018-04-05 13:27 markusfluer Note Added: 47340
2018-04-05 13:46 fbrei Note Added: 47342
2018-04-06 08:48 DenisChenu Note Added: 47352
2018-04-09 12:49 markusfluer Note Added: 47366
2018-04-09 13:34 markusfluer Assigned To => markusfluer
2018-04-09 13:34 markusfluer Status new => resolved
2018-04-09 13:34 markusfluer Resolution open => fixed
2018-04-09 13:34 markusfluer Fixed in Version => 3.6.x
2018-04-09 13:34 markusfluer Note Added: 47367
2018-05-25 11:30 c_schmitz Note Added: 47850
2018-05-25 11:30 c_schmitz Status resolved => closed
2018-06-05 16:03 Mazi Status closed => feedback
2018-06-05 16:03 Mazi Resolution fixed => reopened
2018-06-05 16:03 Mazi Note Added: 47992
2018-06-05 16:03 Mazi Status feedback => assigned
2018-06-05 16:22 Mazi Relationship added related to 13667
2018-06-27 22:06 John_K Note Added: 48351
2018-09-06 12:26 michaelp Note Added: 48984
2018-09-07 12:49 c_schmitz Priority none => urgent
2018-09-07 12:49 c_schmitz Severity minor => major
2018-09-07 16:10 michaelp Note Added: 48989
2018-09-07 16:39 c_schmitz Note Added: 48990
2018-09-26 15:38 markusfluer Status assigned => resolved
2018-09-26 15:38 markusfluer Fixed in Version 3.6.x => 3.14.x
2018-09-26 15:38 markusfluer Note Added: 49142
2018-09-26 15:38 markusfluer Status resolved => closed
2019-01-30 12:17 ritapas Note Added: 50340
2019-01-30 13:13 DenisChenu Note Added: 50341
2019-01-30 14:07 ritapas Note Added: 50343
2019-01-30 14:12 DenisChenu Note Added: 50344