View Issue Details

IDProjectCategoryView StatusLast Update
13530Bug reports[All Projects] Otherpublic2018-05-16 13:42
ReportergabrieljenikAssigned ToLouisGac 
PrioritynoneSeveritymajor 
Status closedResolutionunable to reproduce 
Product Version3.3.x 
Target VersionFixed in Version 
Summary13530: Quota termination url is not autoloaded, but the whole survey is reset
DescriptionI setup up a termination url for a quota as auto-load.
I execute the survey and answer as to get the termination url auto-loaded.
Instead of being redirected to the url, I get the survey to start all over.
Additional InformationAfter digging in, I notice that there is some incompatibility in between the quota auto-redirect and the pjax mechanism implemented in LS3.

A temp workaround is
1 - set quotas at not autoload
2 - add this code to custom.js

    // Quota url - auto click
    var quotaLinks = $('.ls-endurl.ls-quotaurl');
    if (quotaLinks.length > 0)
    {
       $('#main-row').hide();
       quotaLinks[0].click();
    }
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.3.1+180214
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version?
Operating System (Server)?
Webserver software & version?
PHP Version?

Activities

gabrieljenik

gabrieljenik

2018-03-23 22:21

developer   ~47204

>>>
After digging in, I notice that there is some incompatibility in between the quota auto-redirect and the pjax mechanism implemented in LS3.
>>>

That means that, when auto-load, server does:
location('header: xxx');

I believe pjax can't handle this kind of answer.
gabrieljenik

gabrieljenik

2018-03-24 13:20

developer   ~47205

I think this is related: https://github.com/yiisoft/jquery-pjax/issues/44#issuecomment-260384224
jelo

jelo

2018-03-24 14:10

updater   ~47206

Is your last note about the bug itself or your workaround?
The root issue seemed to be fixed in Yii 2. https://github.com/yiisoft/yii2/pull/13694
LS is still on Yii1. So that might never be fixed in Yii1.

You stated LS 3.3.1 as your test environment. Perhaps LS 3.5.4 is no longer showing the issue.
jelo

jelo

2018-03-24 14:15

updater   ~47207

Can you attach an surveyexample?
I tried to reproduce the issue via demo.limesurvey.org (LS 3.5.4) with a quota on a yes/no question and autoload-URL worked fine.

Issue History

Date Modified Username Field Change
2018-03-23 22:18 gabrieljenik New Issue
2018-03-23 22:21 gabrieljenik Note Added: 47204
2018-03-24 13:20 gabrieljenik Note Added: 47205
2018-03-24 14:10 jelo Note Added: 47206
2018-03-24 14:15 jelo Note Added: 47207
2018-05-16 13:42 LouisGac Assigned To => LouisGac
2018-05-16 13:42 LouisGac Status new => closed
2018-05-16 13:42 LouisGac Resolution open => unable to reproduce