View Issue Details

IDProjectCategoryView StatusLast Update
13443Bug reports[All Projects] Survey takingpublic2018-03-09 16:36
Reporterorvil Assigned Tomarkusfluer  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.4.x 
Summary13443: Logic error by using an Eclusive Option in a multiple choice question
Description

Scenario:

  • Using a exclusive option in a multiple choice question (say Q1).

  • This Q1 question has some items and one item 'none of these' as an Exclusive Option

  • Using a second e.g. array question (say Q2) depending on Q1 with an Array filter (rows ar only shown when selected in Q1)

  • Respondent checks first one (or more) items in Q1 then the exclusive option 'none of these' (something that happens in reality)
    Here comes the bug:

  • Q2 logically depending on Array Filter in Q1 will now show all items formerly selected in Q1 before none of these was selected instead of none of these

Note: when the answers are saved, the db is correct - no item is saved as marked, when option 'none of these' was choosen.

Steps To Reproduce

See the image I attached or check it out at https://survey.asktom.cc/index.php/389245?lang=en

Additional Information

When an exclusive option is selected in a multiple choice question, all other items are hidden. This is a little confusing for participants, because the 'non of these' answer is not yet understandable in this moment. I'll report this in an extra issue.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.4.3
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

orvil

orvil

2018-03-04 10:28

reporter  

Clipboard26.jpg (80,124 bytes)
Clipboard26.jpg (80,124 bytes)
DenisChenu

DenisChenu

2018-03-04 19:18

developer   ~46880

Can you send a simple lss file to test and reproduce the issue ? Just 2 question for example :).

I think you have already same system in 2.73 and/or before : can you confirm it's a regression ?

orvil

orvil

2018-03-04 19:37

reporter   ~46883

Thanks for your reply, here is the *.lss file containing the 2 necessary questions



limesurvey_survey_issue13443.lss (29,183 bytes)
markusfluer

markusfluer

2018-03-06 15:49

administrator   ~46928

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26674

c_schmitz

c_schmitz

2018-03-09 16:36

administrator   ~46986

Version 3.5.0 180309 released

Related Changesets

LimeSurvey: master 63511c18

2018-03-06 15:48:59

markusfluer

Details Diff
Fixed issue 13443: Logic error by using an Eclusive Option in a multiple choice question Affected Issues
13443
mod - assets/packages/limesurvey/survey.js Diff File

Issue History

Date Modified Username Field Change
2018-03-04 10:28 orvil New Issue
2018-03-04 10:28 orvil File Added: Clipboard26.jpg
2018-03-04 19:18 DenisChenu Note Added: 46880
2018-03-04 19:37 orvil File Added: limesurvey_survey_issue13443.lss
2018-03-04 19:37 orvil Note Added: 46883
2018-03-06 15:49 markusfluer Assigned To => markusfluer
2018-03-06 15:49 markusfluer Status new => resolved
2018-03-06 15:49 markusfluer Resolution open => fixed
2018-03-06 15:49 markusfluer Fixed in Version => 3.4.x
2018-03-06 15:49 markusfluer Changeset attached => LimeSurvey master 63511c18
2018-03-06 15:49 markusfluer Note Added: 46928
2018-03-09 16:36 c_schmitz Note Added: 46986
2018-03-09 16:36 c_schmitz Status resolved => closed