View Issue Details

IDProjectCategoryView StatusLast Update
13365Bug reports[All Projects] Theme editorpublic2018-02-19 15:09
ReporterRichieB Assigned Tomarkusfluer  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.1.x 
Target VersionFixed in Version3.4.x 
Summary13365: custom.css never gets loaded
Description

When I edit custom.css and clear the asset cache, the custom.css never gets loaded in a survey. Adding the same modification in theme.css work fine.

Steps To Reproduce
  1. Extend the fruity theme into a new theme
  2. Edit the custom.css and save it
  3. Clear asset cache
  4. For good measure, uninstall and then install the new theme
  5. Watch the custom.css does not get used (never referenced in the HTML, never gets loaded by the browser)
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.2.0+180206
I will donate to the project if issue is resolvedNo
BrowserSafari + Firefox
Database & DB-Versionmysql 5.7.21-0ubuntu0.16.04.1
Server OS (if known)Ubuntu 16.04.1
Webserver software & version (if known)apache 2.4.18-2ubuntu3.5
PHP Version7.0.22-0ubuntu0.16.04.1

Activities

LouisGac

LouisGac

2018-02-16 10:25

manager   ~46546

please, update first to 3.3 and make sure you've taken in account those points:
https://manual.limesurvey.org/New_Template_System_in_LS3.x#FAQ_about_theme_customization

RichieB

RichieB

2018-02-16 15:20

reporter   ~46553

I am running 3.3.1+180214 and did follow the FAQ. The problem is that custom.css is never loaded in the HTML code. In the theme editor preview the custom.css is loaded but on the actual HTML in a survey it is never referenced nor used.

LouisGac

LouisGac

2018-02-16 15:21

manager   ~46554

could please try to uninstall and reinstall the theme from theme list?

RichieB

RichieB

2018-02-16 15:38

reporter   ~46555

Thanks, reinstalling did enable custom.css. However, when I change the variant to Sunset_Orange, custom.css is no longer use. The problem is that the files_css column of the lime_template_configuration table originally says:

{"add":["css\/ajaxify.css","css\/animate.css","css\/variations\/sea_green.css","css\/theme.css","css\/custom.css"]}

after selecting Sunset_Orange it says:

{"add":["css/animate.css","css/ajaxify.css","css/variations/sea_green.css","css/theme.css"]}

so it is no longer using custom.css

RichieB

RichieB

2018-02-16 15:39

reporter   ~46556

Oops. that last files_css is of course actually:

{"add":["css/animate.css","css/ajaxify.css","css/variations/sunset_orange.css","css/theme.css"]}

LouisGac

LouisGac

2018-02-16 15:53

manager   ~46557

ok thank you very much for all those reports:

  1. Options are a bit buggy right now: we're working on it, it will be fixed on next release. (it's a small issue with option.js we didn't noticed before)

  2. To avoid the install/uninstall process, starting with next release, you'll can use in config.php: 'force_xmlsettings_for_survey_rendering' => true,
    If debug mode is on, it will force the rendering engine to get its values from the XML files rather than from DB.

markusfluer

markusfluer

2018-02-16 18:26

administrator   ~46570

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26507

Related Changesets

LimeSurvey: master eba40fdc

2018-02-16 18:26:32

markusfluer

Details Diff
Fixed issue 13365: custom.css never gets loaded
Fixed issue: some options not loaded on uninheriting the parent theme
Affected Issues
13365
mod - application/models/TemplateConfiguration.php Diff File
mod - themes/survey/fruity/options/options.js Diff File
mod - themes/survey/fruity/options/options.twig Diff File
mod - themes/survey/vanilla/options/options.js Diff File
mod - themes/survey/vanilla/options/options.twig Diff File

Issue History

Date Modified Username Field Change
2018-02-16 00:00 RichieB New Issue
2018-02-16 10:25 LouisGac Note Added: 46546
2018-02-16 14:08 markusfluer Assigned To => markusfluer
2018-02-16 14:08 markusfluer Status new => feedback
2018-02-16 15:20 RichieB Note Added: 46553
2018-02-16 15:20 RichieB Status feedback => assigned
2018-02-16 15:21 LouisGac Note Added: 46554
2018-02-16 15:38 RichieB Note Added: 46555
2018-02-16 15:39 RichieB Note Added: 46556
2018-02-16 15:53 LouisGac Note Added: 46557
2018-02-16 18:25 markusfluer Status assigned => resolved
2018-02-16 18:25 markusfluer Resolution open => fixed
2018-02-16 18:25 markusfluer Fixed in Version => 3.3.x
2018-02-16 18:26 markusfluer Changeset attached => LimeSurvey master eba40fdc
2018-02-16 18:26 markusfluer Note Added: 46570
2018-02-19 15:09 ollehar Status resolved => closed
2018-02-19 15:09 ollehar Fixed in Version 3.3.x => 3.4.x