View Issue Details

IDProjectCategoryView StatusLast Update
13358Bug reports[All Projects] Survey designpublic2018-02-27 14:23
ReporterDenisChenu Assigned Tomarkusfluer  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.3.x 
Target VersionFixed in Version3.4.x 
Summary13358: Usage of .question in end message broken
Description

With previous version (2.73 and 2.6lts) : usage of QCODE.question work very good. Not now : expression manager are disable

Steps To Reproduce

Import include survey and test

Additional Information

It's OK in question text.

OK show result in question, notOK in endmessage.

Seems to be pseudo broken HTML
LIST.question content are
You choose
You choose
<ul>
{if(!is_empty(Quest_RED.NAOK),'<li style="color:red">red</li>','')}
{if(!is_empty(Quest_GREEN.NAOK),'<li style="color:green">green</li>','')}
{if(!is_empty(Quest_BLUE.NAOK),'<li style="color:blue">blue</li>','')}
</ul>

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.3.1git
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionmysql
Server OS (if known)debian7+dotdeb (i know, must update)
Webserver software & version (if known)apache2
PHP VersionPHP5.6

Activities

DenisChenu

DenisChenu

2018-02-15 09:42

developer  

notOK.png (16,751 bytes)
notOK.png (16,751 bytes)
OK.png (5,474 bytes)
OK.png (5,474 bytes)
limesurvey_survey_emQuestiuonUsage2.lss (19,488 bytes)
c_schmitz

c_schmitz

2018-02-21 16:46

administrator   ~46700

Version 3.4.1. released

DenisChenu

DenisChenu

2018-02-21 17:05

developer   ~46706

Last edited: 2018-02-21 17:06

View 2 revisions

Still unfixed

vanilla template : https://master.sondages.pro/index.php/853122/newtest/Y

3.4.github

markusfluer

markusfluer

2018-02-21 17:35

administrator   ~46707

Seems to be working?



Selection_218.jpg (194,099 bytes)
DenisChenu

DenisChenu

2018-02-21 17:45

developer   ~46709

End message : AFTER submit. Here it's in question … the desired behaviour …

markusfluer

markusfluer

2018-02-22 08:43

administrator   ~46712

This has to do with the recursion level, we found the issue.
All in all it is not a good idea to recurse expression manager variables, but we added a second run to the end message, to stay backwards compatible.

markusfluer

markusfluer

2018-02-22 08:44

administrator   ~46714

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&amp;id=26551

c_schmitz

c_schmitz

2018-02-27 14:23

administrator   ~46800

Version 3.4.3 Build 180227 released.

Related Changesets

LimeSurvey: master 72aba24d

2018-02-22 08:43:45

markusfluer

Details Diff
Fixed issue 13358: Usage of .question in end message broken Affected Issues
13358
mod - application/helpers/SurveyRuntimeHelper.php Diff File

Issue History

Date Modified Username Field Change
2018-02-15 09:42 DenisChenu New Issue
2018-02-15 09:42 DenisChenu File Added: notOK.png
2018-02-15 09:42 DenisChenu File Added: OK.png
2018-02-15 09:42 DenisChenu File Added: limesurvey_survey_emQuestiuonUsage2.lss
2018-02-15 09:42 DenisChenu Additional Information Updated View Revisions
2018-02-15 09:43 DenisChenu Additional Information Updated View Revisions
2018-02-16 18:25 markusfluer Assigned To => markusfluer
2018-02-16 18:25 markusfluer Status new => resolved
2018-02-16 18:25 markusfluer Resolution open => fixed
2018-02-16 18:25 markusfluer Fixed in Version => 3.3.x
2018-02-21 16:46 c_schmitz Note Added: 46700
2018-02-21 16:46 c_schmitz Status resolved => closed
2018-02-21 17:05 DenisChenu Status closed => feedback
2018-02-21 17:05 DenisChenu Resolution fixed => reopened
2018-02-21 17:05 DenisChenu Note Added: 46706
2018-02-21 17:05 DenisChenu Fixed in Version 3.3.x =>
2018-02-21 17:06 DenisChenu Note Edited: 46706 View Revisions
2018-02-21 17:35 markusfluer File Added: Selection_218.jpg
2018-02-21 17:35 markusfluer Note Added: 46707
2018-02-21 17:45 DenisChenu Note Added: 46709
2018-02-21 17:45 DenisChenu Status feedback => assigned
2018-02-22 08:43 markusfluer Status assigned => resolved
2018-02-22 08:43 markusfluer Resolution reopened => fixed
2018-02-22 08:43 markusfluer Note Added: 46712
2018-02-22 08:43 markusfluer Fixed in Version => 3.4.x
2018-02-22 08:44 markusfluer Changeset attached => LimeSurvey master 72aba24d
2018-02-22 08:44 markusfluer Note Added: 46714
2018-02-27 14:23 c_schmitz Note Added: 46800
2018-02-27 14:23 c_schmitz Status resolved => closed