View Issue Details

IDProjectCategoryView StatusLast Update
13343Bug reports[All Projects] Survey takingpublic2018-02-14 18:19
ReportertpartnerAssigned ToLouisGac 
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.3.x 
Target Version3.2.xFixed in Version 
Summary13343: Cannot load files in theme extension
Description

Although referenced in config.xml, files are not loaded - see attached template and screenshot.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.3.0
I will donate to the project if issue is resolvedNo
Browsern/a
Database & DB-Versionmysqlnd 5.0.12-dev
Operating System (Server)Windows 10
Webserver software & versionApache/2.4.27 (Win32) OpenSSL/1.0.2l PHP/7.1.9
PHP Version7.1.9

Activities

tpartner

tpartner

2018-02-13 14:54

developer  

capture-2.png (22,514 bytes)
capture-2.png (22,514 bytes)
Demo_Card_Sort_For_3x_Template.zip (525,509 bytes)
LouisGac

LouisGac

2018-02-13 17:15

manager   ~46416

can't reproduce ^^

tpartner

tpartner

2018-02-13 17:38

developer   ~46418

So, you're saying those files load for you?

LouisGac

LouisGac

2018-02-13 17:53

manager   ~46419

yep

tpartner

tpartner

2018-02-13 18:01

developer   ~46420

Did you try it on a Windows machine? I don't make up these bugs for fun.

LouisGac

LouisGac

2018-02-13 18:14

manager   ~46421

I took some time to check your theme and to run it: everything works fine (with/without assets, with debug mode, etc).
I tryed to upload it to LimeService to show you... but it seems that we have a problem:
https://mofudtest.limequery.com/745397?newtest=Y&lang=en

For any testing on Windows Server: only Carsten can do it.
So I will ask him tomorrow (also, I have not closed the ticket, because I guess it's not solved for you)

Just in case: can you dissable the asset to check if the problem is related?

LouisGac

LouisGac

2018-02-13 18:31

manager   ~46422

Ok, so on limeservice:
https://mofudtest.limequery.com/745397?newtest=Y&lang=en

as you can see, the files are loaded as expected.

tpartner

tpartner

2018-02-13 18:31

developer   ~46423

Last edited: 2018-02-13 18:32

View 2 revisions

The initial template was extended through the template editor and the files were not loaded.

I deleted that template, imported the attached template and, after re-uploading some files that were skipped in the import, it works.

As a test, I created a new extension of Bootswatch via the template editor, and again, the files were not loaded.

I exported then deleted that template and after importing, it worked as expected.

So, the problem is clearly with templates that are newly created via the template manager.

How do you want me to disable the assets manager? I'm already in debug = 1.

LouisGac

LouisGac

2018-02-13 18:56

manager   ~46424

after you changed the XML file, you must uninstall and reinstall the theme (I'll add a button "reload conf" to do it)
that's the normal behaviour: "install" means that the XML files is read and pushed to DB

LouisGac

LouisGac

2018-02-13 19:01

manager   ~46425

Also: I've prepared a way to avoid those "install/uninstall" when creating a theme
https://github.com/LimeSurvey/LimeSurvey/blob/master/application/config/config-defaults.php#L683

but I must first check that it's still working fine
Basically, when it's on: the DB is not used (nor for options, nothing), the XML file is loaded and read at each frontend call.

tpartner

tpartner

2018-02-13 19:14

developer   ~46426

Yes, thanks, I can confirm that uninstalling and reinstalling the theme after modifying config.xml does result in the appropriate files being loaded.

c_schmitz

c_schmitz

2018-02-14 18:19

administrator   ~46491

Version 3.3.1 released

Issue History

Date Modified Username Field Change
2018-02-13 14:54 tpartner New Issue
2018-02-13 14:54 tpartner Status new => assigned
2018-02-13 14:54 tpartner Assigned To => LouisGac
2018-02-13 14:54 tpartner File Added: capture-2.png
2018-02-13 14:54 tpartner File Added: Demo_Card_Sort_For_3x_Template.zip
2018-02-13 17:15 LouisGac Note Added: 46416
2018-02-13 17:38 tpartner Note Added: 46418
2018-02-13 17:53 LouisGac Note Added: 46419
2018-02-13 18:01 tpartner Note Added: 46420
2018-02-13 18:14 LouisGac Note Added: 46421
2018-02-13 18:31 LouisGac Note Added: 46422
2018-02-13 18:31 tpartner Note Added: 46423
2018-02-13 18:32 tpartner Note Edited: 46423 View Revisions
2018-02-13 18:56 LouisGac Note Added: 46424
2018-02-13 19:01 LouisGac Note Added: 46425
2018-02-13 19:14 tpartner Note Added: 46426
2018-02-14 10:21 LouisGac Status assigned => resolved
2018-02-14 10:21 LouisGac Resolution open => fixed
2018-02-14 18:19 c_schmitz Note Added: 46491
2018-02-14 18:19 c_schmitz Status resolved => closed