View Issue Details

IDProjectCategoryView StatusLast Update
13341Bug reports[All Projects] Import/Exportpublic2018-02-14 16:40
ReporterYuVeReAssigned Toolle 
PrioritynoneSeverityfeature 
Status closedResolutionwon't fix 
Product Version3.3.x 
Target VersionFixed in Version 
Summary13341: Export "Completed response only" not work
Description

When trying to export (PDF, Word ... formats) with the selected option "Completed responses only" in the "Completion State" always shows / prints all the unanswered questions.

Steps To Reproduce

1) Select a survey
2) Responses: Responses & statistics
3) Export: Export responses
4) Format: Export Format: PDF
General: Completion state: Completed responses only
5) Press Export button

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.3.0 (180206)
I will donate to the project if issue is resolvedNo
BrowserGoogle Chrome 63.0.3239.132 (Build oficial) (64 bits)
Database & DB-VersionMySQL 5.7.20-0 & LimeDBVersion 347
Operating System (Server)Ubuntu 16.04.3 LTS
Webserver software & versionApache/2.4.18
PHP Version7.0.22

Activities

YuVeRe

YuVeRe

2018-02-13 05:05

reporter  

Captura.png (35,393 bytes)
Captura.png (35,393 bytes)
olle

olle

2018-02-13 16:51

administrator   ~46410

It works for me. What was your expected result? Can you attach your LSA file, please?

YuVeRe

YuVeRe

2018-02-14 01:28

reporter   ~46429

Hi, attach you LSA file and export PDF survey



survey_archive_821823.lsa (203,493 bytes)
SSVF_1.0.1 (25).pdf (218,379 bytes)
olle

olle

2018-02-14 12:12

administrator   ~46437

Again, please explain the issue here. What I can see from your survey structure, group 4 is only mandatory if question G3Q00001 is answered yes. In the picture you attached, he/she answered "no", meaning questions 4.1 would never be shown.

YuVeRe

YuVeRe

2018-02-14 16:14

reporter   ~46458

The problem is that there are different questions and according to the answer (yes / no) the person does the survey, then some questions are not necessarily answered and when I export the survey in the option "Completed responses only" should print only the questions that they were answered.

olle

olle

2018-02-14 16:19

administrator   ~46460

Ah! Sorry, this is a misunderstanding of what it means to be "complete". A response is complete if the user finished the survey. If the survey is aborted in the middle, the response is marked as incomplete.

YuVeRe

YuVeRe

2018-02-14 16:29

reporter   ~46462

But what I need is that when you export in the part "Completed responses only", only the complete answers come out. Please can you help me, thanks.

olle

olle

2018-02-14 16:40

administrator   ~46464

That is a question for the forum, but maybe export CSV file and then filter empty answers?

Issue History

Date Modified Username Field Change
2018-02-13 05:05 YuVeRe New Issue
2018-02-13 05:05 YuVeRe File Added: Captura.png
2018-02-13 16:51 olle Status new => feedback
2018-02-13 16:51 olle Note Added: 46410
2018-02-14 01:28 YuVeRe File Added: survey_archive_821823.lsa
2018-02-14 01:28 YuVeRe File Added: SSVF_1.0.1 (25).pdf
2018-02-14 01:28 YuVeRe Note Added: 46429
2018-02-14 01:28 YuVeRe Status feedback => new
2018-02-14 12:12 olle Note Added: 46437
2018-02-14 12:12 olle Assigned To => olle
2018-02-14 12:12 olle Status new => feedback
2018-02-14 16:14 YuVeRe Note Added: 46458
2018-02-14 16:14 YuVeRe Status feedback => assigned
2018-02-14 16:19 olle Note Added: 46460
2018-02-14 16:20 olle Status assigned => closed
2018-02-14 16:20 olle Resolution open => won't fix
2018-02-14 16:29 YuVeRe Note Added: 46462
2018-02-14 16:40 olle Note Added: 46464