View Issue Details

IDProjectCategoryView StatusLast Update
13315Bug reports[All Projects] Data Entry (non public)public2018-02-09 17:02
ReporterChristofke Assigned Toollehar  
PrioritynoneSeveritytweak 
Status closedResolutionfixed 
Product Version3.1.x 
Target VersionFixed in Version3.2.x 
Summary13315: Multiple choise with comments
Description

I'm using the multiple choice with comment to let the participant make a certain choice, and place his comment if any.
Meaning that if he wants to leave a comment he can do so, if not....That is the problem.
If no comment is entered, and you add a choice, the first choice is undone.
I know this has much to do with the way the word "comment" is interpreted.

I would like to see the possibility to make the "comment" mandatory or not, in that way the multiple choice can be used in a variety of ways.
I've noticed a work-around, grouping the questions and comment with a <Div> statement, creating an array look, where the choice and the comment is considerate as independent fields, but this way is too complex for a non-programmer like me.

Steps To Reproduce

Default multiple choice with comment.

Additional Information

Love your program. Keep on the good work.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.2.1+180207
I will donate to the project if issue is resolvedYes
Browserfirefox/edge
Database & DB-Version10.1.30-MariaDB
Server OS (if known)localhost
Webserver software & version (if known)Apache/2.4.29 (Win32) OpenSSL/1.1.0g PHP/7.2.1
PHP VersionPHP/7.2.1

Activities

c_schmitz

c_schmitz

2018-02-08 11:57

administrator   ~46315

This seems to be a regression. In 2.73 the box was not unchecked if there was no comment.
Please fix.

ollehar

ollehar

2018-02-08 14:17

administrator   ~46321

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&amp;id=26389

DenisChenu

DenisChenu

2018-02-08 16:13

developer   ~46325

Last edited: 2018-02-08 16:14

View 2 revisions

The fixed behaviour in 2.0 and less : no comment if checkbox are unechecked
Adding a settings in 2.5 or 2.6 : https://manual.limesurvey.org/Question_type_-_Multiple_choice_with_comments#Comment_only_when_..._.28commented_checkbox.29

But the javascript was broken during a time in 2.50 or 2.60 or 2.70 … act like No control on checkbox.

DenisChenu

DenisChenu

2018-02-08 16:15

developer   ~46326

@Christofke : about mandatory comment , it's ready in develop version using em_question

c_schmitz

c_schmitz

2018-02-09 17:02

administrator   ~46358

Version 3.3.0 released

Related Changesets

LimeSurvey: master a6686834

2018-02-08 14:17:43

ollehar

Details Diff
Fixed issue 13315: Make it possible to submit mandatory multiple choice with empty comment Affected Issues
13315
mod - assets/scripts/multiplechoice_withcomments.js Diff File

Issue History

Date Modified Username Field Change
2018-02-07 19:52 Christofke New Issue
2018-02-08 11:35 ollehar Assigned To => ollehar
2018-02-08 11:35 ollehar Status new => feedback
2018-02-08 11:57 c_schmitz Note Added: 46315
2018-02-08 11:57 c_schmitz Status feedback => assigned
2018-02-08 14:17 ollehar Changeset attached => LimeSurvey master a6686834
2018-02-08 14:17 ollehar Note Added: 46321
2018-02-08 14:17 ollehar Resolution open => fixed
2018-02-08 14:18 ollehar Status assigned => resolved
2018-02-08 14:18 ollehar Fixed in Version => 3.2.x
2018-02-08 16:13 DenisChenu Note Added: 46325
2018-02-08 16:14 DenisChenu Note Edited: 46325 View Revisions
2018-02-08 16:15 DenisChenu Note Added: 46326
2018-02-09 17:02 c_schmitz Note Added: 46358
2018-02-09 17:02 c_schmitz Status resolved => closed