View Issue Details

IDProjectCategoryView StatusLast Update
13310Bug reports[All Projects] Survey designpublic2018-03-05 17:30
Reportertpartner Assigned Toollehar  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.2.x 
Target Version3.2.xFixed in Version3.4.x 
Summary13310: Cannot delete surveys in Survey list when debug == 1
Description

The delete icon has no effect when debug is set to 1. It works fine when debug == 0.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.2.0
I will donate to the project if issue is resolvedNo
Browsern/a
Database & DB-Versionmysqlnd 5.0.12-dev
Server OS (if known)Windows 10
Webserver software & version (if known)Apache/2.4.27 (Win32) OpenSSL/1.0.2l PHP/7.1.9
PHP Version7.1.9

Activities

tpartner

tpartner

2018-02-06 16:14

developer  

capture-8.png (19,634 bytes)
capture-8.png (19,634 bytes)
LouisGac

LouisGac

2018-02-08 17:54

manager   ~46332

I can't reproduce

tpartner

tpartner

2018-02-08 19:28

developer  

capture-9.png (31,933 bytes)
capture-9.png (31,933 bytes)
tpartner

tpartner

2018-02-08 19:28

developer   ~46333

I can still reproduce it in all browsers. It looks like listActions.js is not loaded when debug is 1 or 2, it is loaded when debug is 0.

LouisGac

LouisGac

2018-02-09 11:07

manager   ~46341

I'd say it's a server configuration problem on your side: it seems that files under application/ are not reachable.

LouisGac

LouisGac

2018-02-09 12:03

manager   ~46343

also, a quick fix can be to set in config:
'use_asset_manager'=>true,

it will for the use of asset manager

tpartner

tpartner

2018-02-09 12:14

developer   ~46345

I don't understand how it can be a server configuration when the files are accessible and loaded correctly when debug = 0.

LImeSurvey was installed on an out-of-the-box XAMPP platform for Windows with no modifications. I'm no server expert, but I would assume it should work on that platform. Have you tried on a Windows box?

Regarding 'use_asset_manager', one of the reasons that I use debug = 1 is to bypass the assets manager.

LouisGac

LouisGac

2018-02-09 12:16

manager   ~46346

when debug=0 files are moved to root/tmp/
Here the files are under application/
Check your config, I bet my 2cts that files under application/ can't be reached directly.

tpartner

tpartner

2018-02-09 12:27

developer   ~46347

What do I check in config?

LouisGac

LouisGac

2018-02-09 12:28

manager   ~46348

indeed, it's a bug in our htaccess I guess:
https://github.com/LimeSurvey/LimeSurvey/blob/master/application/.htaccess

tpartner

tpartner

2018-02-09 12:43

developer   ~46350

Yep, commenting that out fixes it.

ollehar

ollehar

2018-02-09 16:58

administrator   ~46352

That .htaccess file has stayed the same since 2011. Could it really be the problem? Maybe we need to move the script for the massive action widget to another folder?

LouisGac

LouisGac

2018-02-09 16:59

manager   ~46353

yep, we need a clear separation of private/ and web/... like in Yii2 ^^

tpartner

tpartner

2018-03-01 16:59

developer   ~46854

This also prevents deleting responses when debug == 1

ollehar

ollehar

2018-03-02 10:20

administrator   ~46863

@tpartner, can you try to add a .htaccess file with allow from all, in folder

application/extensions/admin/grid/MassiveActionsWidget/assets

tpartner

tpartner

2018-03-02 12:46

developer   ~46864

@olle, yes, that fixes it.

But should we be worried about any other files in /application that may need access when debug == 1 (when the assets manager is bypassed)?

Currently everything is blocked by the .htaccess file in /application.

ollehar

ollehar

2018-03-02 13:23

administrator   ~46865

Yeah, we need such a file in every folder that should be accessible.

How did your new .htaccess file exactly look like?

tpartner

tpartner

2018-03-02 13:58

developer   ~46869

Simply "Allow from all"



capture-1.png (1,211 bytes)
capture-1.png (1,211 bytes)
ollehar

ollehar

2018-03-02 14:14

administrator   ~46871

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26634

tpartner

tpartner

2018-03-02 14:27

developer   ~46874

Thanks Olle.

Related Changesets

LimeSurvey: master 63b42f79

2018-03-02 14:14:37

ollehar

Details Diff
Fixed issue 13310: Cannot delete surveys in Survey list when debug is on Affected Issues
13310
mod - application/controllers/admin/themes.php Diff File
add - application/extensions/admin/grid/MassiveActionsWidget/assets/.htaccess Diff File

Issue History

Date Modified Username Field Change
2018-02-06 16:14 tpartner New Issue
2018-02-06 16:14 tpartner File Added: capture-8.png
2018-02-08 17:54 LouisGac Note Added: 46332
2018-02-08 19:28 tpartner File Added: capture-9.png
2018-02-08 19:28 tpartner Note Added: 46333
2018-02-09 11:07 LouisGac Note Added: 46341
2018-02-09 12:03 LouisGac Note Added: 46343
2018-02-09 12:14 tpartner Note Added: 46345
2018-02-09 12:16 LouisGac Note Added: 46346
2018-02-09 12:27 tpartner Note Added: 46347
2018-02-09 12:28 LouisGac Note Added: 46348
2018-02-09 12:43 tpartner Note Added: 46350
2018-02-09 16:58 ollehar Note Added: 46352
2018-02-09 16:59 LouisGac Note Added: 46353
2018-02-09 17:30 c_schmitz Assigned To => LouisGac
2018-02-09 17:30 c_schmitz Status new => assigned
2018-03-01 16:59 tpartner Note Added: 46854
2018-03-02 10:20 ollehar Note Added: 46863
2018-03-02 10:20 ollehar Assigned To LouisGac => ollehar
2018-03-02 10:20 ollehar Status assigned => feedback
2018-03-02 12:46 tpartner Note Added: 46864
2018-03-02 12:46 tpartner Status feedback => assigned
2018-03-02 13:23 ollehar Note Added: 46865
2018-03-02 13:47 ollehar Status assigned => feedback
2018-03-02 13:58 tpartner File Added: capture-1.png
2018-03-02 13:58 tpartner Note Added: 46869
2018-03-02 13:58 tpartner Status feedback => assigned
2018-03-02 14:14 ollehar Changeset attached => LimeSurvey master 63b42f79
2018-03-02 14:14 ollehar Note Added: 46871
2018-03-02 14:14 ollehar Resolution open => fixed
2018-03-02 14:15 ollehar Status assigned => resolved
2018-03-02 14:15 ollehar Fixed in Version => 3.4.x
2018-03-02 14:27 tpartner Note Added: 46874
2018-03-05 17:30 ollehar Status resolved => closed