View Issue Details

IDProjectCategoryView StatusLast Update
13268Feature requests[All Projects] _ Unknownpublic2018-04-06 11:48
ReporterVitelinsideAssigned Tomarkusfluer 
PrioritynoneSeverityfeature 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0 
Summary13268: Impossibilité de désactiver un questionnaire
DescriptionBonjour,
Suite à cette manipulation (reproductible) :
- création d'un questionnaire avec un seul groupe et une seule question
- activation du questionnaire
- puis suppression de la seule question (ce qui est possible malgré que le questionnaire soit activé!)
- le message d'erreur "AdminController ne peut trouver la vue « /admin/survey/Question/massive_actions/_action_results »." apparaît (comme dans le rapport de bug N°13015).

Le problème est qu'il devient impossible de désactiver le questionnaire car le bouton a disparu et il est toujours impossible d'ajouter d'autres groupes ou d'autres questions puisque le questionnaire est resté activé !
Du coup, pas d'autre solution que de supprimer le questionnaire

Merci par avance de votre retour.
TagsNo tags attached.

Activities

markusfluer

markusfluer

2018-02-02 15:58

manager   ~46217

Hello, since most of our developers don't speak french we need bug reports to be in english.
Thank you for your understanding.
Vitelinside

Vitelinside

2018-02-12 12:25

reporter   ~46390

In english...
Hello !
Each time after you do this :
- Create a survey with only one group and only one question
- Activate the survey
- Delete the one question (which is possible even if the survey is activated !)
- error message ""AdminController ne peut trouver la vue « /admin/survey/Question/massive_actions/_action_results »." appears (as in bug report N°13015).

The problem is that it becomes impossible to disable the survey because the button has disappeared and it is still impossible to add other groups or other questions since the survey has remained activated !
So we have no other solution than to delete the survey.
thank you.
markusfluer

markusfluer

2018-03-09 11:18

manager   ~46957

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26700

Related Changesets

LimeSurvey: master 8ec03ab0

2018-03-09 11:18:38

markusfluer

Details Diff
Fixed issue 13268: Impossibilité de désactiver un questionnaire
mod - application/views/admin/survey/Question/massive_actions/_selector.php Diff File

Issue History

Date Modified Username Field Change
2018-01-30 16:57 Vitelinside New Issue
2018-02-02 15:58 markusfluer Assigned To => markusfluer
2018-02-02 15:58 markusfluer Status new => feedback
2018-02-02 15:58 markusfluer Note Added: 46217
2018-02-12 12:25 Vitelinside Note Added: 46390
2018-02-12 12:25 Vitelinside Status feedback => assigned
2018-03-09 11:18 markusfluer Changeset attached => LimeSurvey master 8ec03ab0
2018-03-09 11:18 markusfluer Note Added: 46957
2018-03-09 11:18 markusfluer Resolution open => fixed
2018-03-09 11:20 markusfluer Status assigned => resolved
2018-03-09 11:20 markusfluer Fixed in Version => 3.0
2018-04-06 11:48 markusfluer Status resolved => closed