View Issue Details

IDProjectCategoryView StatusLast Update
13249Bug reports[All Projects] Survey designpublic2018-02-09 17:02
ReporterGabryxx7Assigned Tomarkusfluer 
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.1.x 
Target VersionFixed in Version3.1.x 
Summary13249: Cannot reorder questions and/or groups
Description

I've been tried to reorder questions and groups for a while now. I checked the manual multiple times to be sure I was doing right but it did not work anyway.
Everytime I press the three lines on the left side of the question row and I move the question or the group to another position, it graphically stays there but it goes back to it's original position after reloading the page or after clicking on a question (and triggering a page refresh).

  • NO conditions on questions, I am still in the process of testing, so questions don't have any condition, they are just yes/no questions or text displays with no conditions whatsoever. - The survey is NOT active
  • The folders on the server have all the needed permissions
  • The database is accessible and working, and limesurvey has access to it (it created the tables when I installed limesurvey)
  • I had the same issues with 3.0.5 and was hoping to see it solved in 3.1.0

It looks like the question or group order in the database is not updated (maybe the query is bot being executed?) so every time the page is reloaded, the query to get the questions and the groups is executed, getting the old, unmodified values from the table.

Steps To Reproduce
  1. Create 3 or more questions groups, with 3 or more questions inside
  2. Try to reorder the groups or the questions either by changing groups order, group's internal questions order, or even by moving a question from a group to another in different positions
  3. Clicking on a question, a group, or simply reloading the page will move everything back to its original position.
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.1.0+180124
I will donate to the project if issue is resolvedNo
BrowserGoogle Chrome
Database & DB-VersionMYSQL v.5.5
Server OS (if known)Debian 6
Webserver software & version (if known) Apache
PHP Version 5.6.32

Activities

c_schmitz

c_schmitz

2018-02-09 17:02

administrator   ~46372

Version 3.3.0 released

Related Changesets

LimeSurvey: master dae3d852

2018-01-25 13:18:36

markusfluer

Details Diff
Fixed issue: group ordering doesn't work Affected Issues
13249
mod - assets/packages/adminpanel/build/lsadminpanel.debug.js Diff File
mod - assets/packages/adminpanel/build/lsadminpanel.js Diff File
mod - assets/packages/adminpanel/build/lsadminpanel.js.map Diff File
mod - assets/packages/adminpanel/build/lsadminpanel.min.js Diff File
mod - assets/packages/adminpanel/src/components/sidebar.vue Diff File

Issue History

Date Modified Username Field Change
2018-01-26 09:52 Gabryxx7 New Issue
2018-01-26 10:20 c_schmitz Assigned To => markusfluer
2018-01-26 10:20 c_schmitz Status new => assigned
2018-01-26 10:20 c_schmitz Changeset attached => LimeSurvey master dae3d852
2018-01-26 10:21 c_schmitz Status assigned => resolved
2018-01-26 10:21 c_schmitz Resolution open => fixed
2018-01-26 10:21 c_schmitz Fixed in Version => 3.1.x
2018-02-09 17:02 c_schmitz Note Added: 46372
2018-02-09 17:02 c_schmitz Status resolved => closed