View Issue Details

IDProjectCategoryView StatusLast Update
13246Bug reports[All Projects] Response browsingpublic2018-03-05 17:30
Reporterdhenriquez Assigned Toollehar  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.1.x 
Target VersionFixed in Version3.4.x 
Summary13246: Survey responses, some functions doesnt work.
Description

There are several problems in the response module, below I detail:

1.- The submenu selected responses does not work, when I click on any of the options, the system does not do anything.

2.- The filter of the columns works only when you previously ordered the column.

3.- When I try to delete an answer the system shows the error

PHP Error [500]

Class 'LimeSurvey \ PluginManager \ Survey' not found

Thanks in advance,

Deivis

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.1.0+180124
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMaria DB 10
Server OS (if known)Linux
Webserver software & version (if known)Apache 2
PHP Version5.6

Activities

dhenriquez

dhenriquez

2018-01-25 17:21

reporter  

sub-menu.png (12,132 bytes)
sub-menu.png (12,132 bytes)
params-delete.png (22,938 bytes)
params-delete.png (22,938 bytes)
delete.png (21,087 bytes)
delete.png (21,087 bytes)
date.png (42,555 bytes)
date.png (42,555 bytes)
c_schmitz

c_schmitz

2018-01-25 20:26

administrator   ~46097

Do you have debug mode activated?

dhenriquez

dhenriquez

2018-01-25 20:30

reporter   ~46098

No



debug.png (18,360 bytes)
debug.png (18,360 bytes)
LouisGac

LouisGac

2018-01-26 12:22

manager   ~46106

I can't reproduce.
Please, check if you have any plugin activated like auditlog

dhenriquez

dhenriquez

2018-01-26 21:39

reporter   ~46122

Hello Louis,

just This one



plugins.png (48,512 bytes)
plugins.png (48,512 bytes)
lau95

lau95

2018-02-27 10:46

reporter   ~46769

It can be reproduced following an import of a current questionnaire from Limesurvey V2 to Limesurvey V3 or from LimeSurvey V3 to LimeSurvey V3

ollehar

ollehar

2018-02-27 10:57

administrator   ~46770

Cannot reproduce. Please enable debug => 2 in config.php and try again. Copy-paste the full error message here.

ollehar

ollehar

2018-02-27 10:58

administrator   ~46771

And make sure the latest version is being used (3.4.2).

lau95

lau95

2018-02-27 11:39

reporter   ~46776

Hello,

Version 3.4.2+180223

The full error message :
Error

Class 'LimeSurvey\PluginManager\Survey' not found (/var/www/html/application/libraries/PluginManager/LimesurveyApi.php:189)

#0 /var/www/html/plugins/AuditLog/AuditLog.php(293): LimeSurvey\PluginManager\LimesurveyApi->getResponse(314967, 19, true)
#1 [internal function]: AuditLog->beforeDataEntryDelete()
#2 /var/www/html/application/libraries/PluginManager/PluginManager.php(185): call_user_func(Array)
#3 /var/www/html/application/controllers/admin/responses.php(534): LimeSurvey\PluginManager\PluginManager->dispatchEvent(Object(PluginEvent))
#4 [internal function]: responses->actionDelete(314967)
#5 /var/www/html/framework/web/actions/CAction.php(109): ReflectionMethod->invokeArgs(Object(responses), Array)
#6 /var/www/html/application/core/Survey_Common_Action.php(83): CAction->runWithParamsInternal(Object(responses), Object(ReflectionMethod), Array)
#7 /var/www/html/framework/web/CController.php(308): Survey_Common_Action->runWithParams(Array)
#8 /var/www/html/framework/web/CController.php(286): CController->runAction(Object(responses))
#9 /var/www/html/framework/web/CController.php(265): CController->runActionWithFilters(Object(responses), Array)
#10 /var/www/html/application/controllers/AdminController.php(158): CController->run('responses')
#11 /var/www/html/framework/web/CWebApplication.php(282): AdminController->run('responses')
#12 /var/www/html/framework/web/CWebApplication.php(141): CWebApplication->runController('admin/responses')
#13 /var/www/html/framework/base/CApplication.php(185): CWebApplication->processRequest()
#14 /var/www/html/index.php(194): CApplication->run()
#15 {main}

kllam

kllam

2018-02-28 07:51

reporter   ~46810

I had same problem, and solved it by:

Add below code at (/var/www/html/application/libraries/PluginManager/LimesurveyApi.php) line 8:
use \Survey;

Modify line: 189 to
$survey = \Survey::model()->findByPk($surveyId);

Hope it help you too.

ollehar

ollehar

2018-02-28 10:04

administrator   ~46811

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26612

Related Changesets

LimeSurvey: master ae29d81a

2018-02-28 10:04:12

ollehar

Details Diff
Fixed issue 13246: Fix plugin in survey responses Affected Issues
13246
mod - application/libraries/PluginManager/LimesurveyApi.php Diff File

Issue History

Date Modified Username Field Change
2018-01-25 17:21 dhenriquez New Issue
2018-01-25 17:21 dhenriquez File Added: sub-menu.png
2018-01-25 17:21 dhenriquez File Added: params-delete.png
2018-01-25 17:21 dhenriquez File Added: delete.png
2018-01-25 17:21 dhenriquez File Added: date.png
2018-01-25 20:26 c_schmitz Note Added: 46097
2018-01-25 20:30 dhenriquez File Added: debug.png
2018-01-25 20:30 dhenriquez Note Added: 46098
2018-01-26 11:43 LouisGac Sticky Issue No => Yes
2018-01-26 12:22 LouisGac Note Added: 46106
2018-01-26 21:39 dhenriquez File Added: plugins.png
2018-01-26 21:39 dhenriquez Note Added: 46122
2018-01-30 14:32 ollehar Sticky Issue Yes => No
2018-02-27 10:46 lau95 Note Added: 46769
2018-02-27 10:57 ollehar Note Added: 46770
2018-02-27 10:57 ollehar Assigned To => ollehar
2018-02-27 10:57 ollehar Status new => feedback
2018-02-27 10:58 ollehar Note Added: 46771
2018-02-27 11:39 lau95 Note Added: 46776
2018-02-28 07:51 kllam Note Added: 46810
2018-02-28 10:04 ollehar Changeset attached => LimeSurvey master ae29d81a
2018-02-28 10:04 ollehar Note Added: 46811
2018-02-28 10:04 ollehar Resolution open => fixed
2018-02-28 10:05 ollehar Status feedback => resolved
2018-02-28 10:05 ollehar Fixed in Version => 3.4.x
2018-03-05 17:30 ollehar Status resolved => closed