View Issue Details

IDProjectCategoryView StatusLast Update
13218Bug reports[All Projects] Survey participants (Tokens)public2018-02-21 16:46
ReportersnowsamAssigned Toc_schmitz 
PrioritynoneSeverityblock 
Status closedResolutionfixed 
Product Version3.0.x 
Target VersionFixed in Version3.4.x 
Summary13218: Sending Invitations or Reminders - Emails sent using "There are more emails pending" are corrupt
Description

I got reports that some users who received our survey invites and reminders received corrupted emails.
After investigating, I found that when you have more emails to send than the "email batch size" system setting allows, any sent using "there are more emails pending... continue" are corrupted!

By corrupted, I mean that every so many characters a "= " shows up in the email. This results in broken links, broken images, etc. NOT GOOD!

Steps To Reproduce
  1. In global settings --> Email settings, set your email batch size to "1".
  2. create a sample survey and populate it with 1000 dummy participants all using your email address.
  3. Send invites to participants.
    The first one will send fine. Then you will get the message that you have more emails to send and you can hit continue to send your second email. Then cancel sending any more at this time.
  4. Inspect the received emails. The first should be good. In the body of the second you should find "= " every line or two. This is is message corruption.

See the attached screen shots.

Workaround for this issue:

  1. Set your batch size to be larger than your number or participants.
  2. Instead of "continuing" to send more invites, cancel the send and restart new each time.
Additional Information

This should not matter, but MTA for sending is qmail. MTA receiving is Exchange 2012 and client is Outlook 2016. I tested using both the PHP and the qmail send method.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.0.5+180118
I will donate to the project if issue is resolvedNo
BrowserFirefox 57.0.4 (64-bit) on windows
Database & DB-VersionMySQL 5.5.53
Server OS (if known)Debian
Webserver software & version (if known)Apache2
PHP Version5.6.29-0+deb8u1

Activities

snowsam

snowsam

2018-01-19 07:20

reporter  

screen1a.PNG (147,753 bytes)
screen1.PNG (17,005 bytes)
screen1.PNG (17,005 bytes)
snowsam

snowsam

2018-01-19 14:37

reporter   ~45918

Is anyone else with v3 installed able to duplicate this?

snowsam

snowsam

2018-01-24 20:43

reporter   ~46048

Confirmed still an issue with Version 3.1.0+180124 .

Is anyone else able to reproduce this issue?

c_schmitz

c_schmitz

2018-01-24 23:04

administrator   ~46050

Can you attach the related survey as .lss file with which you can reproduce this?

snowsam

snowsam

2018-01-24 23:40

reporter   ~46055

LSS attached!



limesurvey_survey_621661.lss (20,200 bytes)
c_schmitz

c_schmitz

2018-02-16 18:04

administrator   ~46565

Last edited: 2018-02-16 18:05

View 3 revisions

After investigating deeply into this the reason that the second email looks different than the first one is that the encoding of the email changes because the linebreaks change after first post because of using a Windows browser.

The email format is still valid though, just encoded a bit differently. In my email client the 2nd email looks perfectly fine - I can only see the difference in the source of the email.

I therefore assume that it is actually some issue with your email reader.
Can you try in a different reader?

Note: I tested with 3.3.1

snowsam

snowsam

2018-02-16 19:11

reporter   ~46572

Thank you for your time.

I just did another test using 3.2.0+180206 .
I sent invites to three destinations:
Exchange 2010+update19 + Outlook 2016
same messages access from outlook webmail

Linux Server running qmail (where LS is installed) and viewed on Thunderbird (windows)

Gmail web client

  1. The problem was only visible on the exchange server. It was visible on both the web client and Outlook, so that takes the client out of the picture. I believe this indicates an email formatting issue that the exchange server does not like.

  2. When we sent out surveys, I received feedback from a certain percentage that the email they received was corrupted (as described). So this confirms the issue is with more than just the exchange server where I am able to test.

Where do we go from here? Can the difference between the emails not be corrected?

jelo

jelo

2018-02-17 00:09

partner   ~46573

Did you verify if the feedback is coming from recipients without Exchange?

Take a look at this discussion:
https://github.com/PHPMailer/PHPMailer/issues/606

c_schmitz

c_schmitz

2018-02-21 10:34

administrator   ~46630

@jelo: That is an excellent hint - thank you!
@snowsam: I have updated the PHPMailer library now and it will be included in next release. Please test again once we released.
if it still does not work after that please feel free to reopen this issue.

snowsam

snowsam

2018-02-21 14:22

reporter   ~46675

Thank you both!

-Sam

c_schmitz

c_schmitz

2018-02-21 16:46

administrator   ~46696

Version 3.4.1. released

Issue History

Date Modified Username Field Change
2018-01-19 07:20 snowsam New Issue
2018-01-19 07:20 snowsam File Added: screen1a.PNG
2018-01-19 07:20 snowsam File Added: screen1.PNG
2018-01-19 14:37 snowsam Note Added: 45918
2018-01-24 20:43 snowsam Note Added: 46048
2018-01-24 23:04 c_schmitz Assigned To => c_schmitz
2018-01-24 23:04 c_schmitz Status new => feedback
2018-01-24 23:04 c_schmitz Note Added: 46050
2018-01-24 23:04 c_schmitz Category _ Unknown => Survey participants (Tokens)
2018-01-24 23:40 snowsam File Added: limesurvey_survey_621661.lss
2018-01-24 23:40 snowsam Note Added: 46055
2018-01-24 23:40 snowsam Status feedback => assigned
2018-02-16 18:04 c_schmitz Status assigned => feedback
2018-02-16 18:04 c_schmitz Note Added: 46565
2018-02-16 18:04 c_schmitz Note Edited: 46565 View Revisions
2018-02-16 18:05 c_schmitz Note Edited: 46565 View Revisions
2018-02-16 19:11 snowsam Note Added: 46572
2018-02-16 19:11 snowsam Status feedback => assigned
2018-02-17 00:09 jelo Note Added: 46573
2018-02-21 10:34 c_schmitz Status assigned => resolved
2018-02-21 10:34 c_schmitz Resolution open => fixed
2018-02-21 10:34 c_schmitz Fixed in Version => 3.4.x
2018-02-21 10:34 c_schmitz Note Added: 46630
2018-02-21 14:22 snowsam Note Added: 46675
2018-02-21 16:46 c_schmitz Note Added: 46696
2018-02-21 16:46 c_schmitz Status resolved => closed