View Issue Details

IDProjectCategoryView StatusLast Update
13170Bug reports[All Projects] Survey designpublic2018-01-12 15:24
ReporterfvanderstarreAssigned Toolle 
PrioritynoneSeveritymajor 
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary13170: Database error when attempting to enter answer option for radio question (mssql)
Description

After creating a new survey and question group and question of type "radio button", I tried to enter the first answer option but got a database error: General error: 20018 Cannot insert the value NULL into column 'assessment_value', table 'LimeSurvey_temp.dbo.answers'; column does not allow nulls. INSERT fails. [20018] (severity 16) [(null)].
Insert statement as traced by SQL Server profiler:
INSERT INTO [dbo].[answers] ([qid], [code], [answer], [language], [sortorder], [scale_id]) VALUES (49, 'A1', '', 'nl', 0, 0)
No value specified for assessment_value, which is defined as NOT NULL in the database.

Steps To Reproduce

See above

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.0.2+180110
I will donate to the project if issue is resolvedNo
BrowserAny
Database & DB-VersionMS-SQL 2008 R2
Operating System (Server)Linux RHEL 7
Webserver software & versionApache 2.4.6
PHP Version5.6.33

Relationships

duplicate of 13163 closedolle cant add answer options to "single choice Questions" 

Activities

olle

olle

2018-01-12 15:24

administrator   ~45589

Already fixed/duplicate.

Issue History

Date Modified Username Field Change
2018-01-12 14:29 fvanderstarre New Issue
2018-01-12 15:24 olle Assigned To => olle
2018-01-12 15:24 olle Status new => closed
2018-01-12 15:24 olle Resolution open => no change required
2018-01-12 15:24 olle Fixed in Version => 3.0.3
2018-01-12 15:24 olle Note Added: 45589
2018-01-12 15:24 olle Relationship added duplicate of 13163