View Issue Details

IDProjectCategoryView StatusLast Update
13107Bug reports[All Projects] Survey designpublic2018-06-18 13:34
Reportersnathan99Assigned ToLouisGac 
PrioritynoneSeveritymajor 
Status closedResolutionunable to reproduce 
Product Version3.0.0-rc.x 
Target VersionFixed in Version3.0.x 
Summary13107: Unable to edit/enter Question Text
Description

When adding a new question, the Question Code field is enabled, but the Question Text and Question Help fields are both disabled.

Steps To Reproduce

Add Group, then add question

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.0.1+171228
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL 5.5.40-0ubuntu0.14.04.1 - (Ubuntu)
Operating System (Server)Linux 3.13.0-37-generic #64-Ubuntu
Webserver software & versionApache/2.4.7 (Ubuntu)
PHP VersionPHP 5.5.9-1ubuntu4.4

Activities

snathan99

snathan99

2018-01-03 22:09

reporter   ~45417

This appears to be a problem on FireFox. Works on Chrome.

markusfluer

markusfluer

2018-01-08 12:42

manager   ~45480

Can you give us a little bit more information, right now i have trouble reproducing the issue.
Did you use the Save and add question button, or did you save and added a new question at once.
Are you in Debug mode, or in production mode?
Can you activate js-debug for backend (Global Settings) and post a screenshot of the console?

snathan99

snathan99

2018-01-08 13:37

reporter   ~45484

Hello: I am unable to reproduce the issue! In fact I was able to reproduce the issue once and then it is now consistently working. Appreciate you checking on this. You may close this ticket. Will reopen it with a screen capture if this shows up again.

markusfluer

markusfluer

2018-01-08 13:38

manager   ~45485

Awesome, thanks a lot!
Please don't stop submitting bugs, we can't see everything and appreciate all input we get.

snathan99

snathan99

2018-02-26 14:14

reporter   ~46749

This issue is back on limesurvey3.4.2+180223.zip. Group Description is not editable. This is a brand new install. Tried with Mozilla and Internet Explorer and group description is uneditable. In IE, the question description was editable, while in Mozilla even the question description was NOT editable. In Chrome, it works without issues.



snathan99

snathan99

2018-04-06 11:45

reporter   ~47353

This issue is back again. Created a brand new install using limesurvey3.6.1+180329.zip and a brand new survey. Group Description and Question are not editable. Browser shows the box is specifically made invisible.



Hidden.png (39,584 bytes)
Hidden.png (39,584 bytes)
snathan99

snathan99

2018-04-06 11:48

reporter   ~47354

Issue has come back again.

markusfluer

markusfluer

2018-04-06 11:49

manager   ~47355

Can activate js-debug for the backend and post the console.logs?

markusfluer

markusfluer

2018-04-09 12:35

manager   ~47361

I cannot reproduce this at all.

snathan99

snathan99

2018-04-11 14:01

reporter   ~47402

Changing the global setting for "Default HTML editor mode" to "HTML Source" or "Popup" makes this visible again. Of course when you click the HTML edit button only get a blank page. So something to do with HTML Editor option.

DenisChenu

DenisChenu

2018-04-30 10:40

developer   ~47556

Can you , on firefox, activate console, on console, check request to see if there are some Content Security Policy or some 404 error

LouisGac

LouisGac

2018-05-16 12:34

manager   ~47620

what is your FIrefox version?

snathan99

snathan99

2018-05-16 13:57

reporter   ~47649

Firefox version: 59.0.3 (64-bit)

When I click on the Edit button (while in "Default HTML editor mode" to "HTML Source" or "Popup") I get a 404 for URL:
https://MYDOMAIN.TLD/index.php/admin/htmleditor_pop/sa/index/name/welcome_en/text/[Welcome:](en)/type/survey-welc/action/surveygeneralsettings/sid/221186/gid//qid//lang/en

I also see that the said path (admin directory) on the server only has two files: admin.php & index.php. Does it possibly have something to do with URL rewrite? I copied over the default .htaccess on the file system to my Apache configuration.

LouisGac

LouisGac

2018-05-16 14:59

manager   ~47652

in your url, the gid is empty.
question is why, and why only you is affected?
could you try to reinstall to see if you still have the problem?
or to install a fresh new limesurvey next to your old installation?

DenisChenu

DenisChenu

2018-05-18 10:11

developer   ~47676

@LouisGac : editing survey-welc : no gid (and qid) : need to be empty. It's not this issue.

Maybe related to 'urlFormat' => 'path', VS 'urlFormat' => 'get', (url_rewriting)

LimeSurvey didn't use always the best way for generating url … "controller/action",[params] but do a lot of "controller/action/param1/1/param2/2"

LouisGac

LouisGac

2018-05-23 10:36

manager   ~47720

real question is: how is that only one single user is affected?

LouisGac

LouisGac

2018-06-04 15:10

manager   ~47970

if nobody confirm this bug, I'll close it next time I'll check it.

Issue History

Date Modified Username Field Change
2017-12-29 19:13 snathan99 New Issue
2018-01-03 22:09 snathan99 Note Added: 45417
2018-01-08 11:16 LouisGac Assigned To => markusfluer
2018-01-08 11:16 LouisGac Status new => assigned
2018-01-08 12:42 markusfluer Note Added: 45480
2018-01-08 12:42 markusfluer Status assigned => feedback
2018-01-08 13:37 snathan99 Note Added: 45484
2018-01-08 13:37 snathan99 Status feedback => assigned
2018-01-08 13:38 markusfluer Note Added: 45485
2018-01-08 13:38 markusfluer Status assigned => closed
2018-01-08 13:38 markusfluer Resolution open => fixed
2018-01-08 13:38 markusfluer Fixed in Version => 3.0.x
2018-02-26 14:14 snathan99 File Added: Group Description Not editable.PNG
2018-02-26 14:14 snathan99 Note Added: 46749
2018-04-06 11:45 snathan99 File Added: Hidden.png
2018-04-06 11:45 snathan99 Note Added: 47353
2018-04-06 11:48 snathan99 Status closed => feedback
2018-04-06 11:48 snathan99 Resolution fixed => reopened
2018-04-06 11:48 snathan99 Note Added: 47354
2018-04-06 11:49 markusfluer Note Added: 47355
2018-04-06 16:08 snathan99 Status feedback => assigned
2018-04-09 12:34 markusfluer Assigned To markusfluer =>
2018-04-09 12:34 markusfluer Status assigned => feedback
2018-04-09 12:35 markusfluer Note Added: 47361
2018-04-11 14:01 snathan99 Note Added: 47402
2018-04-11 14:01 snathan99 Status feedback => new
2018-04-30 10:40 DenisChenu Note Added: 47556
2018-05-16 12:34 LouisGac Note Added: 47620
2018-05-16 13:57 snathan99 Note Added: 47649
2018-05-16 14:59 LouisGac Note Added: 47652
2018-05-18 10:11 DenisChenu Note Added: 47676
2018-05-23 10:36 LouisGac Note Added: 47720
2018-06-04 15:10 LouisGac Assigned To => LouisGac
2018-06-04 15:10 LouisGac Status new => feedback
2018-06-04 15:10 LouisGac Note Added: 47970
2018-06-18 13:34 LouisGac Status feedback => resolved
2018-06-18 13:34 LouisGac Resolution reopened => unable to reproduce
2018-06-18 13:34 LouisGac Status resolved => closed