View Issue Details

IDProjectCategoryView StatusLast Update
13014Bug reports[All Projects] Survey designpublic2018-01-15 11:09
Reporterabc99Assigned Tomarkusfluer 
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.0.0-rc.x 
Target VersionFixed in Version 
Summary13014: Can't reorder questions groups - js error
Description

Drag and drop reordering of question groups doesn't work. The group gets highlighted, but I can't drag it to a new position. See my screenshot from the chrome js console..

(This feature worked fine in a pull of the 3.0.0rc I did last week) -

Steps To Reproduce

I an existing survey try to reorder question groups by drag and drop. The wont

Additional Information

Note: I connected the lime installation with the database tables from a week old version of the 3.0.0.rc (e.g. pulled from github a week ago). I did't try a fresh install of the lime tables, since it seems to be a front end js issue, but I might be wrong about that.

If it is not something in the db, I guess it would be nice to have some basic testing in place in this part of the user interface, to check things before commiting .. I had another important js-based operation not working last week (you couldn't navigate to the page, where you edit a question). That is now fixed (thanks by the way) however this issue now appeared.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3rc - pulled from github 15/12-2017 (latest commit 4ed6fc4374109eb635ea7d124efade7b7bc3629a)
I will donate to the project if issue is resolvedNo
Browserchrome - latest
Database & DB-VersionN/A
Operating System (Server)linux
Webserver software & versionn/A
PHP Version7.1

Activities

abc99

abc99

2017-12-16 00:01

reporter  

Capture.PNG (10,890 bytes)
Capture.PNG (10,890 bytes)
abc99

abc99

2018-01-05 00:51

reporter   ~45420

update: I tried a fresh reinstall, creating a new limesurvey db.. The js problem is still there. To reorder questions, I have to change values directly in the database.

Issue History

Date Modified Username Field Change
2017-12-16 00:01 abc99 New Issue
2017-12-16 00:01 abc99 File Added: Capture.PNG
2018-01-05 00:51 abc99 Note Added: 45420
2018-01-08 11:23 LouisGac Assigned To => markusfluer
2018-01-08 11:23 LouisGac Status new => assigned
2018-01-15 11:09 LouisGac Status assigned => closed
2018-01-15 11:09 LouisGac Resolution open => fixed