View Issue Details

IDProjectCategoryView StatusLast Update
13008Bug reports[All Projects] Import/Exportpublic2018-01-15 10:41
ReporterLiod_DSAssigned ToDenisChenu 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version2.7x.x 
Target VersionFixed in Version2.7x.x 
Summary13008: SPSS export invalid A0 for string
Description

After the last few patches the spss export it's changed, i found a major bugs in the export_helper

Steps To Reproduce

i think the new function to calculate the lenght of the strings can return the value "0".

Obviusly in SPSS the value "A0" is not allowed, and it gives errors.
Ulteriori informazioni the function is stringSize($sColumn) [found in application/helpers/export_helper.php] and i fixed it by adding a line before the return

-> if ((int)$lengthReal == 0){$lengthReal = 1;}

but i can't really say if it will broke some other things, so please check !

TagsNo tags attached.
Complete LimeSurvey version number (& build)V 2.72.5+171121
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQl
Operating System (Server)Ubuntu
Webserver software & versiondon't rember
PHP Versiondon't rember

Activities

DenisChenu

DenisChenu

2017-12-14 15:31

developer   ~45296

Seems some difference betwwen SPSS version then :).

Can you test about integer if it's OK too ? F8.0 for example.

It's not really a major issue : update file is easy :)

Liod_DS

Liod_DS

2017-12-14 15:40

reporter   ~45297

yes you're right !

The function for the number works fine, even with the x.0 decimals, i have a few in my export !

I'm using PsPP and it keep give me some waring/errors but it works, ofc in the previous export no warnig popped out.

I feel the errors are related to the newest lenght calculating function, but with the hard fix i can deliver the datas today ... so i post the screen just in case it can help you



Output — PSPPIRE Output Viewer.jpg (115,269 bytes)
DenisChenu

DenisChenu

2017-12-16 10:22

developer   ~45310

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=25533

DenisChenu

DenisChenu

2017-12-16 10:24

developer   ~45311

Fix committed to develop branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=25534

DenisChenu

DenisChenu

2017-12-16 10:28

developer   ~45312

OK, fixed this one.

@Liod_DS : for the other : can you compare the 2 files ? I didn't understand : i didn't update other part , i think i only update the GET DATA syntax part … :(
And report it at another bug

Liod_DS

Liod_DS

2017-12-18 09:27

reporter   ~45316

@DenisChenu i don't know, the PsPP software get it but leave me some warning, maybe it's my enviroment ( I have change some configurations before edit the helper) ... i think i can't compare 1:1 to an old file because the different sizes (and the survey change slightly every month).... i will try to search for difference in the sintaxt !

DenisChenu

DenisChenu

2017-12-18 09:31

developer   ~45317

Hi,

:). If you want i have an old 2.6lts running : i can export the syntax file from this one :) .

It's more esy if you don't have warning after ;)

c_schmitz

c_schmitz

2018-01-15 10:41

administrator   ~45763

Version 3.0.3 released.

Related Changesets

LimeSurvey: master 8ad0150b

2017-12-16 10:22:29

DenisChenu

Details Diff
Fixed issue 13008: SPSS export invalid A0 for string
mod - application/helpers/export_helper.php Diff File

LimeSurvey: develop f20a3f08

2017-12-16 10:24:25

DenisChenu

Details Diff
fixed issue 13008: SPSS export invalid A0 for string
mod - application/helpers/export_helper.php Diff File

Issue History

Date Modified Username Field Change
2017-12-14 13:50 Liod_DS New Issue
2017-12-14 15:15 DenisChenu Assigned To => DenisChenu
2017-12-14 15:15 DenisChenu Status new => assigned
2017-12-14 15:31 DenisChenu Note Added: 45296
2017-12-14 15:31 DenisChenu Severity major => minor
2017-12-14 15:40 Liod_DS File Added: Output — PSPPIRE Output Viewer.jpg
2017-12-14 15:40 Liod_DS Note Added: 45297
2017-12-16 10:17 DenisChenu Summary SPSS export broken => SPSS export invalid A0 for string
2017-12-16 10:22 DenisChenu Changeset attached => LimeSurvey master 8ad0150b
2017-12-16 10:22 DenisChenu Note Added: 45310
2017-12-16 10:22 DenisChenu Resolution open => fixed
2017-12-16 10:24 DenisChenu Changeset attached => LimeSurvey develop f20a3f08
2017-12-16 10:24 DenisChenu Note Added: 45311
2017-12-16 10:28 DenisChenu Status assigned => resolved
2017-12-16 10:28 DenisChenu Fixed in Version => 2.7x.x
2017-12-16 10:28 DenisChenu Note Added: 45312
2017-12-18 09:27 Liod_DS Note Added: 45316
2017-12-18 09:31 DenisChenu Note Added: 45317
2018-01-15 10:41 c_schmitz Note Added: 45763
2018-01-15 10:41 c_schmitz Status resolved => closed